Setting tag ipfw-0.9-16
[ipfw.git] / planetlab / ipfwslice.spec
1 #
2 # $Id: ipfwslice.spec 16174 2009-12-15 13:38:15Z marta $
3 #
4 # TODO:
5 # restart crond
6 # modprobe ipfw_mod.ko (depmod ?)
7 #
8 %define url $URL$
9
10 # Marta Carbone <marta.carbone@iet.unipi.it>
11 # 2009 - Universita` di Pisa
12 # License is BSD.
13
14 %define name ipfwslice
15 %define version 0.9
16 %define taglevel 16
17
18 %define release %{kernel_version}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
19 %define kernel_id_arch %{kernel_version}-%{kernel_release}-%{kernel_arch}
20 %define kernel_id %{kernel_version}-%{kernel_release}
21
22 Summary: ipfw and dummynet for Linux
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: BSD
27 Group: System Environment/Kernel
28 Source0: %{name}-%{version}.tar.bz2
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
30
31 Vendor: unipi
32 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
33 Distribution: PlanetLab %{plrelease}
34 URL: %(echo %{url} | cut -d ' ' -f 2)
35
36 %description
37 the frontend part of the ipfw planetlab package
38
39 %prep
40 %setup
41
42 %build
43 rm -rf $RPM_BUILD_ROOT
44
45 %install
46 install -D -m 755 planetlab/netconfig $RPM_BUILD_ROOT/sbin/netconfig
47 install -D -m 755 planetlab/ipfw.8.gz $RPM_BUILD_ROOT/%{_mandir}/man8/ipfw.8.gz
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 # here there is a list of the final installation directories
53 %files
54 %defattr(-,root,root)
55 /sbin/netconfig
56 %{_mandir}/man8/ipfw.8*
57
58 %changelog
59 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-16
60 - tagging ipfw to test module-tools on (pure) git
61
62 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-15
63 - tagging for obsoletes
64
65 * Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-13
66 - Update to the ipfw3 version of the dummynet code.
67
68 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-11
69 - add ipfw initialization script to chkconfig
70
71 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
72 - - Load module at installation - Marta
73
74 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
75 - consistent with vsys-scripts-0.95-13
76
77 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-8
78 - builds on 2.6.22 & 2.6.27 - for 32 and 64 bits
79
80 * Tue Dec 15 2009 Marta Carbone <marta.carbone@iet.unipi.it>
81 - more work on the radix code, added sysctl read/write support
82
83 * Sun Nov 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-7
84 - added missing qsort.c - tag 0.9-6 was broken
85
86 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-6
87 - root: removed goto into the main ipfw switch, enabled slice_id matching
88 - slice: completely move netconfig checks into the backend
89
90 * Mon Nov 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-5
91 - additional features on matching packets, including uid match
92
93 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-4
94 - on behalf of Marta Carbone, more options and features
95
96 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-3
97 - fixed memory usage issue
98
99 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-2
100 - patch for building on x86_64
101
102 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
103 - Initial release