Setting tag ipfw-20120610-1
[ipfw.git] / planetlab / ipfwslice.spec
1 #
2 # TODO:
3 # restart crond
4 # modprobe ipfw_mod.ko (depmod ?)
5 #
6
7 # Marta Carbone <marta.carbone@iet.unipi.it>
8 # 2009 - Universita` di Pisa
9 # License is BSD.
10
11 # this release was pulled from http://info.iet.unipi.it/~marta/dummynet/ipfw3-20120610.tar.gz
12 %define name ipfwslice
13 %define version 20120610
14 %define taglevel 1
15
16 %define release %{kernel_version}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
17 %define kernel_id_arch %{kernel_version}-%{kernel_release}-%{kernel_arch}
18 %define kernel_id %{kernel_version}-%{kernel_release}
19
20 Summary: ipfw and dummynet for Linux
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: BSD
25 Group: System Environment/Kernel
26 Source0: %{name}-%{version}.tar.bz2
27 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
28
29 Vendor: unipi
30 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
31 Distribution: PlanetLab %{plrelease}
32 URL: %{SCMURL}
33
34 %description
35 the frontend part of the ipfw planetlab package
36
37 %prep
38 %setup
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 %install
44 install -D -m 755 planetlab/netconfig $RPM_BUILD_ROOT/sbin/netconfig
45 install -D -m 755 planetlab/ipfw.8.gz $RPM_BUILD_ROOT/%{_mandir}/man8/ipfw.8.gz
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 # here there is a list of the final installation directories
51 %files
52 %defattr(-,root,root)
53 /sbin/netconfig
54 %{_mandir}/man8/ipfw.8*
55
56 %changelog
57 * Fri Jun 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-20120610-1
58 - integrated ipfw3 as of 20120610 from upstream
59
60 * Mon Oct 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-23
61 - for building against k32 on f8
62
63 * Sun Oct 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-22
64 - rpm version number has the kernel taglevel embedded
65
66 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-21
67 - build tweaks for gcc-4.6 on f15
68
69 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-20
70 - tweaks for compiling on k32/64 bits
71
72 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-19
73 - fix detection of kernel conventions
74
75 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-18
76 - guess conventions for either <=k27 or >=k32
77
78 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-17
79 - testing git only module-tag
80
81 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-16
82 - tagging ipfw to test module-tools on (pure) git
83
84 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-15
85 - tagging for obsoletes
86
87 * Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-13
88 - Update to the ipfw3 version of the dummynet code.
89
90 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-11
91 - add ipfw initialization script to chkconfig
92
93 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
94 - - Load module at installation - Marta
95
96 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
97 - consistent with vsys-scripts-0.95-13
98
99 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-8
100 - builds on 2.6.22 & 2.6.27 - for 32 and 64 bits
101
102 * Tue Dec 15 2009 Marta Carbone <marta.carbone@iet.unipi.it>
103 - more work on the radix code, added sysctl read/write support
104
105 * Sun Nov 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-7
106 - added missing qsort.c - tag 0.9-6 was broken
107
108 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-6
109 - root: removed goto into the main ipfw switch, enabled slice_id matching
110 - slice: completely move netconfig checks into the backend
111
112 * Mon Nov 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-5
113 - additional features on matching packets, including uid match
114
115 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-4
116 - on behalf of Marta Carbone, more options and features
117
118 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-3
119 - fixed memory usage issue
120
121 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-2
122 - patch for building on x86_64
123
124 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
125 - Initial release