Setting tag ipfw-0.9-22
[ipfw.git] / planetlab / ipfwslice.spec
1 #
2 # $Id: ipfwslice.spec 16174 2009-12-15 13:38:15Z marta $
3 #
4 # TODO:
5 # restart crond
6 # modprobe ipfw_mod.ko (depmod ?)
7 #
8 %define url $URL$
9
10 # Marta Carbone <marta.carbone@iet.unipi.it>
11 # 2009 - Universita` di Pisa
12 # License is BSD.
13
14 %define name ipfwslice
15 %define version 0.9
16 %define taglevel 22
17
18 %define release %{kernel_version}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
19 %define kernel_id_arch %{kernel_version}-%{kernel_release}-%{kernel_arch}
20 %define kernel_id %{kernel_version}-%{kernel_release}
21
22 Summary: ipfw and dummynet for Linux
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: BSD
27 Group: System Environment/Kernel
28 Source0: %{name}-%{version}.tar.bz2
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
30
31 Vendor: unipi
32 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
33 Distribution: PlanetLab %{plrelease}
34 URL: %(echo %{url} | cut -d ' ' -f 2)
35
36 %description
37 the frontend part of the ipfw planetlab package
38
39 %prep
40 %setup
41
42 %build
43 rm -rf $RPM_BUILD_ROOT
44
45 %install
46 install -D -m 755 planetlab/netconfig $RPM_BUILD_ROOT/sbin/netconfig
47 install -D -m 755 planetlab/ipfw.8.gz $RPM_BUILD_ROOT/%{_mandir}/man8/ipfw.8.gz
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 # here there is a list of the final installation directories
53 %files
54 %defattr(-,root,root)
55 /sbin/netconfig
56 %{_mandir}/man8/ipfw.8*
57
58 %changelog
59 * Sun Oct 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-22
60 - rpm version number has the kernel taglevel embedded
61
62 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-21
63 - build tweaks for gcc-4.6 on f15
64
65 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-20
66 - tweaks for compiling on k32/64 bits
67
68 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-19
69 - fix detection of kernel conventions
70
71 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-18
72 - guess conventions for either <=k27 or >=k32
73
74 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-17
75 - testing git only module-tag
76
77 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-16
78 - tagging ipfw to test module-tools on (pure) git
79
80 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-15
81 - tagging for obsoletes
82
83 * Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-13
84 - Update to the ipfw3 version of the dummynet code.
85
86 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-11
87 - add ipfw initialization script to chkconfig
88
89 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
90 - - Load module at installation - Marta
91
92 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
93 - consistent with vsys-scripts-0.95-13
94
95 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-8
96 - builds on 2.6.22 & 2.6.27 - for 32 and 64 bits
97
98 * Tue Dec 15 2009 Marta Carbone <marta.carbone@iet.unipi.it>
99 - more work on the radix code, added sysctl read/write support
100
101 * Sun Nov 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-7
102 - added missing qsort.c - tag 0.9-6 was broken
103
104 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-6
105 - root: removed goto into the main ipfw switch, enabled slice_id matching
106 - slice: completely move netconfig checks into the backend
107
108 * Mon Nov 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-5
109 - additional features on matching packets, including uid match
110
111 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-4
112 - on behalf of Marta Carbone, more options and features
113
114 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-3
115 - fixed memory usage issue
116
117 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-2
118 - patch for building on x86_64
119
120 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
121 - Initial release