align version number with upstream number
[ipfw.git] / planetlab / ipfwslice.spec
1 #
2 # TODO:
3 # restart crond
4 # modprobe ipfw_mod.ko (depmod ?)
5 #
6 %define url $URL$
7
8 # Marta Carbone <marta.carbone@iet.unipi.it>
9 # 2009 - Universita` di Pisa
10 # License is BSD.
11
12 %define name ipfwslice
13 %define version 20120610
14 %define taglevel 1
15
16 %define release %{kernel_version}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
17 %define kernel_id_arch %{kernel_version}-%{kernel_release}-%{kernel_arch}
18 %define kernel_id %{kernel_version}-%{kernel_release}
19
20 Summary: ipfw and dummynet for Linux
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: BSD
25 Group: System Environment/Kernel
26 Source0: %{name}-%{version}.tar.bz2
27 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
28
29 Vendor: unipi
30 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
31 Distribution: PlanetLab %{plrelease}
32 URL: %(echo %{url} | cut -d ' ' -f 2)
33
34 %description
35 the frontend part of the ipfw planetlab package
36
37 %prep
38 %setup
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 %install
44 install -D -m 755 planetlab/netconfig $RPM_BUILD_ROOT/sbin/netconfig
45 install -D -m 755 planetlab/ipfw.8.gz $RPM_BUILD_ROOT/%{_mandir}/man8/ipfw.8.gz
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 # here there is a list of the final installation directories
51 %files
52 %defattr(-,root,root)
53 /sbin/netconfig
54 %{_mandir}/man8/ipfw.8*
55
56 %changelog
57 * Mon Oct 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-23
58 - for building against k32 on f8
59
60 * Sun Oct 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-22
61 - rpm version number has the kernel taglevel embedded
62
63 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-21
64 - build tweaks for gcc-4.6 on f15
65
66 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-20
67 - tweaks for compiling on k32/64 bits
68
69 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-19
70 - fix detection of kernel conventions
71
72 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-18
73 - guess conventions for either <=k27 or >=k32
74
75 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-17
76 - testing git only module-tag
77
78 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-16
79 - tagging ipfw to test module-tools on (pure) git
80
81 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-15
82 - tagging for obsoletes
83
84 * Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-13
85 - Update to the ipfw3 version of the dummynet code.
86
87 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-11
88 - add ipfw initialization script to chkconfig
89
90 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
91 - - Load module at installation - Marta
92
93 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
94 - consistent with vsys-scripts-0.95-13
95
96 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-8
97 - builds on 2.6.22 & 2.6.27 - for 32 and 64 bits
98
99 * Tue Dec 15 2009 Marta Carbone <marta.carbone@iet.unipi.it>
100 - more work on the radix code, added sysctl read/write support
101
102 * Sun Nov 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-7
103 - added missing qsort.c - tag 0.9-6 was broken
104
105 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-6
106 - root: removed goto into the main ipfw switch, enabled slice_id matching
107 - slice: completely move netconfig checks into the backend
108
109 * Mon Nov 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-5
110 - additional features on matching packets, including uid match
111
112 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-4
113 - on behalf of Marta Carbone, more options and features
114
115 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-3
116 - fixed memory usage issue
117
118 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-2
119 - patch for building on x86_64
120
121 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
122 - Initial release