1c2dcda0f1e6e08496f00fcf5d60759f295885cc
[iproute2.git] / iproute.spec
1 %define name iproute
2 %define version 2.6.37
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 %define cbq_version v0.7.3
8
9 Vendor: PlanetLab
10 Packager: PlanetLab Central <support@planet-lab.org>
11 Distribution: PlanetLab %{plrelease}
12 URL: %{SCMURL}
13
14 Summary: Advanced IP routing and network device configuration tools.
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Group: Applications/System
19 #Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}-050314.tar.gz
20 #URL:    http://developer.osdl.org/dev/iproute2/
21 Source: iproute2-%{version}.tar.bz2
22 Patch1: gre.patch
23 Patch2: compile.patch
24 License: GNU GPL
25 BuildRoot: %{_tmppath}/%{name}-%{version}-root
26 BuildRequires: tetex-latex tetex-dvips psutils linuxdoc-tools db4-devel bison flex
27
28 %description
29 The iproute package contains networking utilities (ip and rtmon, for
30 example) which are designed to use the advanced networking
31 capabilities of the Linux 2.4.x and 2.6.x kernel.
32
33 %prep
34 %setup -q -n iproute2-%{version}
35 %patch1 -p1
36 %patch2 -p1
37
38 %build
39 make
40 #make -C doc
41
42 %install
43 #rm -rf $RPM_BUILD_ROOT
44 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
45
46 mkdir -p $RPM_BUILD_ROOT/sbin \
47          $RPM_BUILD_ROOT%{_sbindir} \
48          $RPM_BUILD_ROOT%{_mandir}/man8 \
49          $RPM_BUILD_ROOT/etc/iproute2 \
50          $RPM_BUILD_ROOT%{_datadir}/tc \
51
52 install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
53 install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
54 install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_datadir}/tc
55 install -m 644 man/man8/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
56 rm -r $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
57 iconv -f latin1 -t utf8 < man/man8/ss.8 > $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
58 install -m 755 examples/cbq.init-%{cbq_version} $RPM_BUILD_ROOT/sbin/cbq
59 install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq
60
61 cp -f etc/iproute2/* $RPM_BUILD_ROOT/etc/iproute2
62 rm -rf $RPM_BUILD_ROOT/%{_libdir}/debug/*
63
64 %clean
65 #rm -rf $RPM_BUILD_ROOT
66 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(-,root,root)
70 %dir /etc/iproute2
71 %doc README.decnet README.iproute2+tc RELNOTES
72 #%doc doc/*.ps
73 %doc examples
74 /sbin/*
75 %{_mandir}/man8/*
76 %attr(644,root,root) %config(noreplace) /etc/iproute2/*
77 %{_sbindir}/*
78 %dir %{_datadir}/tc
79 %{_datadir}/tc/*
80
81 %changelog
82 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iproute2-2.6.37-1
83 - dont rebuild doc
84
85 * Fri Apr 16 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iproute2-2.6.33-2
86 - Fix taglevel
87
88 * Thu Jun 26 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - iproute2-2.6.16-2
89 - Should fix build error caused by new version of kernel headers.:
90
91 * Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
92 - update to iproute-2.6.11
93
94 * Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
95 - gcc4 rebuilt
96
97 * Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
98 - update to iproute-2.6.10
99
100 * Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
101 - added arpd into sbin
102
103 * Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
104 - debug info removed from makefile and from spec (#140891)
105
106 * Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
107 - source file updated from snapshot version
108 - endian patch adding <endian.h> 
109
110 * Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
111 - added installation of netem module for tc
112
113 * Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
114 - fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
115
116 * Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
117 - updated to iproute-2.6.9, spec file change, patches cleared
118
119 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
120 - rebuilt
121
122 * Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
123 - Took tons of manpages from debian, much more complete (#123952).
124
125 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
126 - rebuilt
127
128 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
129 - Built security errata version for FC1.
130
131 * Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
132 - Fixed -f option for ss (#118355).
133 - Small description fix (#110997).
134 - Added initialization of some vars (#74961). 
135 - Added patch to initialize "default" rule as well (#60693).
136
137 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
138 - rebuilt
139
140 * Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
141 - Security errata for netlink (CAN-2003-0856).
142
143 * Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
144 - Updated to latest version. Used by other distros, so seems stable. ;-)
145 - Quite a few patches needed updating in that turn.
146 - Added ss (#107363) and several other new nifty tools.
147
148 * Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
149 - rebuilt
150
151 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
152 - rebuilt
153
154 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
155 - rebuilt
156
157 * Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
158 - Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
159
160 * Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
161 - remove flags patch at author's request
162
163 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
164 - automated rebuild
165
166 * Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
167 - Don't forcibly strip binaries
168
169 * Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
170 - Fixed missing diffserv and atm support in config (#57278).
171 - Fixed inconsistent numeric base problem for command line (#65473).
172
173 * Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
174 - Added patch to fix crosscompiling by Adrian Linkins.
175
176 * Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
177 - Update to latest stable release 2.4.7-now-ss010824.
178 - Added simple man page for ip.
179
180 * Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
181 - allow setting of allmulti & promisc flags (#48669)
182
183 * Mon Jul 02 2001 Than Ngo <than@redhat.com>
184 - fix build problem in beehive if kernel-sources is not installed
185
186 * Fri May 25 2001 Helge Deller <hdeller@redhat.de>
187 - updated to iproute2-2.2.4-now-ss001007.tar.gz 
188 - bzip2 source tar file
189 - "License" replaces "Copyright"
190 - added "BuildPrereq: tetex-latex tetex-dvips psutils"
191 - rebuilt for 7.2
192
193 * Tue May  1 2001 Bill Nottingham <notting@redhat.com>
194 - use the system headers - the included ones are broken
195 - ETH_P_ECHO went away
196
197 * Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
198 - test for specific KERNEL_INCLUDE directories.
199
200 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
201 - rebuild for 7.1
202
203 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
204 - add default configuration files for iproute (Bug #10549, #18887)
205
206 * Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
207 - fix include-glibc/ to cope with glibc 2.2 new resolver headers
208
209 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
210 - automatic rebuild
211
212 * Sun Jun 18 2000 Than Ngo <than@redhat.de>
213 - rebuilt in the new build environment
214 - use RPM macros
215 - handle RPM_OPT_FLAGS
216
217 * Sat Jun 03 2000 Than Ngo <than@redhat.de>
218 - fix iproute to build with new glibc
219
220 * Fri May 26 2000 Ngo Than <than@redhat.de>
221 - update to 2.2.4-now-ss000305
222 - add configuration files
223
224 * Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
225 - strip binaries
226
227 * Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
228 - first build