Basic specfile taken from F10
[iproute2.git] / iproute.spec
index 5bc4aa8..1813ef4 100644 (file)
@@ -1,41 +1,19 @@
-#
-# $Id: myplc.spec 7268 2007-12-01 00:09:11Z dhozac $
-#
-%define url $URL$
-
-%define name iproute
-%define version 2.6.16
-%define subversion 1
-
-%define release %{subversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
-
-Vendor: PlanetLab
-Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
-
-Summary: Advanced IP routing and network device configuration tools.
-Name: %{name}
-Version: %{version}
-Release: %{release}
+##%define date_version 070710
+%define cbq_version v0.7.3
+
+Summary: Advanced IP routing and network device configuration tools
+Name: iproute
+Version: 2.6.28
+Release: 1.trellis
 Group: Applications/System
-#Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}-050314.tar.gz
-#URL:    http://developer.osdl.org/dev/iproute2/
-Source: %{name}-%{version}.tar.gz
-%define SOURCE1 ip.8
-%define SOURCE2 tc.8
-%define SOURCE3 tc-cbq.8
-%define SOURCE4 tc-cbq-details.8
-%define SOURCE5 tc-htb.8
-%define SOURCE6 tc-pbfifo.8
-%define SOURCE7 tc-pfifo_fast.8
-%define SOURCE8 tc-prio.8
-%define SOURCE9 tc-red.8
-%define SOURCE10 tc-sfq.8
-%define SOURCE11 tc-tbf.8
-License: GNU GPL
-BuildRoot: %{_tmppath}/%{name}-%{version}-root
-BuildPrereq: tetex-latex tetex-dvips psutils linuxdoc-tools db4-devel bison flex
+Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}.tar.bz2
+#Source1: iproute-doc-2.6.22.tar.gz
+URL:   http://linux-net.osdl.org/index.php/Iproute2
+
+License: GPLv2+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: tetex-latex tetex-dvips linuxdoc-tools
+BuildRequires: flex psutils db4-devel bison
 
 %description
 The iproute package contains networking utilities (ip and rtmon, for
@@ -43,192 +21,79 @@ example) which are designed to use the advanced networking
 capabilities of the Linux 2.4.x and 2.6.x kernel.
 
 %prep
-%setup -q
+%setup -q -c iproute-%{version}
 
 %build
-make
+export LIBDIR=%{_libdir}
+
+cd iproute2-%{version}
+make %{?_smp_mflags}
 make -C doc
 
 %install
-#rm -rf $RPM_BUILD_ROOT
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
 
 mkdir -p $RPM_BUILD_ROOT/sbin \
-        $RPM_BUILD_ROOT%{_sbindir} \
-         $RPM_BUILD_ROOT%{_mandir}/man8 \
-         $RPM_BUILD_ROOT/etc/iproute2 \
-        $RPM_BUILD_ROOT%{_libdir}/tc
+       $RPM_BUILD_ROOT%{_sbindir} \
+       $RPM_BUILD_ROOT%{_mandir}/man8 \
+       $RPM_BUILD_ROOT/%{_sysconfdir}/iproute2 \
+       $RPM_BUILD_ROOT%{_datadir}/tc \
+       $RPM_BUILD_ROOT%{_libdir}/tc
 
+cd iproute2-%{version}
 install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
 install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
-install -m 755 tc/q_netem.so $RPM_BUILD_ROOT%{_libdir}/tc
-install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_libdir}/tc
-install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_mandir}/man8
-install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_mandir}/man8
-install -m 644 %{SOURCE3} $RPM_BUILD_ROOT/%{_mandir}/man8
-install -m 644 %{SOURCE4} $RPM_BUILD_ROOT/%{_mandir}/man8
-install -m 644 %{SOURCE5} $RPM_BUILD_ROOT/%{_mandir}/man8
-install -m 644 %{SOURCE6} $RPM_BUILD_ROOT/%{_mandir}/man8
-install -m 644 %{SOURCE7} $RPM_BUILD_ROOT/%{_mandir}/man8
-install -m 644 %{SOURCE8} $RPM_BUILD_ROOT/%{_mandir}/man8
-install -m 644 %{SOURCE9} $RPM_BUILD_ROOT/%{_mandir}/man8
-install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/%{_mandir}/man8
-install -m 644 %{SOURCE11} $RPM_BUILD_ROOT/%{_mandir}/man8
-
-cp -f etc/iproute2/* $RPM_BUILD_ROOT/etc/iproute2
+#netem is static
+#install -m 755 tc/q_netem.so $RPM_BUILD_ROOT%{_libdir}/tc
+#install -m 755 tc/q_atm.so $RPM_BUILD_ROOT%{_libdir}/tc
+install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_datadir}/tc
+install -m 644 man/man8/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
+rm -r $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
+iconv -f latin1 -t utf8 < man/man8/ss.8 > $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
+install -m 755 examples/cbq.init-%{cbq_version} $RPM_BUILD_ROOT/sbin/cbq
+install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq
+
+cp -f etc/iproute2/* $RPM_BUILD_ROOT/%{_sysconfdir}/iproute2
 rm -rf $RPM_BUILD_ROOT/%{_libdir}/debug/*
 
+#copy the tex file from source for time when tex was broken
+#source1 was created from last functional version
+#tar -xvzf %{SOURCE1}
+#mkdir -p $RPM_BUILD_ROOT/%{_defaultdocdir}/%{name}-%{version}
+#cd %{name}-doc-2.6.22
+#cp -pR *.ps ../doc
+
+#create example avpkt file
+cat <<EOF > $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq/cbq-0000.example
+DEVICE=eth0,10Mbit,1Mbit
+RATE=128Kbit
+WEIGHT=10Kbit
+PRIO=5
+RULE=192.168.1.0/24
+EOF
+
+cat <<EOF > $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq/avpkt
+AVPKT=3000
+EOF
+
 %clean
-#rm -rf $RPM_BUILD_ROOT
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
 
 %files
-%defattr(-,root,root)
-%dir /etc/iproute2
-%doc README.decnet README.iproute2+tc RELNOTES
-%doc doc/*.ps examples
+%defattr(-,root,root,-)
+%dir %{_sysconfdir}/iproute2
+%doc iproute2-%{version}/README.decnet iproute2-%{version}/README.iproute2+tc iproute2-%{version}/RELNOTES iproute2-%{version}/examples/README.cbq
+%doc iproute2-%{version}/doc/*.ps 
+%doc iproute2-%{version}/examples
 /sbin/*
 %{_mandir}/man8/*
-%attr(644,root,root) %config(noreplace) /etc/iproute2/*
+%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/*
 %{_sbindir}/*
-%{_libdir}/tc/*
-
-%changelog
-* Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
-- update to iproute-2.6.11
-
-* Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
-- gcc4 rebuilt
-
-* Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
-- update to iproute-2.6.10
-
-* Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
-- added arpd into sbin
-
-* Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
-- debug info removed from makefile and from spec (#140891)
-
-* Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
-- source file updated from snapshot version
-- endian patch adding <endian.h> 
-
-* Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
-- added installation of netem module for tc
-
-* Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
-- fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
-
-* Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
-- updated to iproute-2.6.9, spec file change, patches cleared
-
-* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
-- rebuilt
-
-* Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
-- Took tons of manpages from debian, much more complete (#123952).
-
-* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
-- rebuilt
-
-* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
-- Built security errata version for FC1.
-
-* Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
-- Fixed -f option for ss (#118355).
-- Small description fix (#110997).
-- Added initialization of some vars (#74961). 
-- Added patch to initialize "default" rule as well (#60693).
-
-* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
-- rebuilt
-
-* Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
-- Security errata for netlink (CAN-2003-0856).
-
-* Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
-- Updated to latest version. Used by other distros, so seems stable. ;-)
-- Quite a few patches needed updating in that turn.
-- Added ss (#107363) and several other new nifty tools.
-
-* Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
-- rebuilt
-
-* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
-- rebuilt
-
-* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
-- rebuilt
-
-* Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
-- Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
-
-* Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
-- remove flags patch at author's request
-
-* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
-- automated rebuild
-
-* Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
-- Don't forcibly strip binaries
-
-* Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
-- Fixed missing diffserv and atm support in config (#57278).
-- Fixed inconsistent numeric base problem for command line (#65473).
-
-* Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
-- Added patch to fix crosscompiling by Adrian Linkins.
-
-* Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
-- Update to latest stable release 2.4.7-now-ss010824.
-- Added simple man page for ip.
-
-* Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
-- allow setting of allmulti & promisc flags (#48669)
-
-* Mon Jul 02 2001 Than Ngo <than@redhat.com>
-- fix build problem in beehive if kernel-sources is not installed
-
-* Fri May 25 2001 Helge Deller <hdeller@redhat.de>
-- updated to iproute2-2.2.4-now-ss001007.tar.gz 
-- bzip2 source tar file
-- "License" replaces "Copyright"
-- added "BuildPrereq: tetex-latex tetex-dvips psutils"
-- rebuilt for 7.2
-
-* Tue May  1 2001 Bill Nottingham <notting@redhat.com>
-- use the system headers - the included ones are broken
-- ETH_P_ECHO went away
-
-* Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
-- test for specific KERNEL_INCLUDE directories.
-
-* Thu Oct 12 2000 Than Ngo <than@redhat.com>
-- rebuild for 7.1
-
-* Thu Oct 12 2000 Than Ngo <than@redhat.com>
-- add default configuration files for iproute (Bug #10549, #18887)
-
-* Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
-- fix include-glibc/ to cope with glibc 2.2 new resolver headers
-
-* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
-- automatic rebuild
-
-* Sun Jun 18 2000 Than Ngo <than@redhat.de>
-- rebuilt in the new build environment
-- use RPM macros
-- handle RPM_OPT_FLAGS
-
-* Sat Jun 03 2000 Than Ngo <than@redhat.de>
-- fix iproute to build with new glibc
-
-* Fri May 26 2000 Ngo Than <than@redhat.de>
-- update to 2.2.4-now-ss000305
-- add configuration files
+%dir %{_datadir}/tc
+%{_datadir}/tc/*
+#%dir %{_libdir}/tc/
+#%{_libdir}/tc/*
+%dir %{_sysconfdir}/sysconfig/cbq
+%config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
 
-* Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
-- strip binaries
 
-* Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
-- first build