fix for f12, gcc4.4
[iptables.git] / iptables.spec
1 #
2 # $Id: iproute.spec 7668 2008-01-08 11:49:43Z thierry $
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/iproute2/trunk/iproute.spec $
5
6 %define name iptables
7 %define version 1.3.8
8 %define taglevel 9
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 %define build_devel 1
18 %define linux_header 0
19
20 Summary: Tools for managing Linux kernel packet filtering capabilities.
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 Source: http://www.netfilter.org/%{name}-%{version}.tar.bz2
25 %define SOURCE1 iptables.init
26 %define SOURCE2 iptables-config
27 %define SOURCE3 planetlab-config
28 Group: System Environment/Base
29 #URL: http://www.netfilter.org/
30 BuildRoot: %{_tmppath}/%{name}-buildroot
31 License: GPL
32 BuildPrereq: /usr/bin/perl
33 Requires: kernel >= 2.4.20
34 Requires(post,postun): chkconfig
35 Prefix: %{_prefix}
36 BuildRequires: kernel-devel
37
38 %package ipv6
39 Summary: IPv6 support for iptables.
40 Group: System Environment/Base
41 Requires: %{name} = %{version}
42
43 %if %{build_devel}
44 %package devel
45 Summary: Development package for iptables.
46 Group: System Environment/Base
47 Requires: %{name} = %{version}
48 %endif
49
50 %description
51 The iptables utility controls the network packet filtering code in the
52 Linux kernel. If you need to set up firewalls and/or IP masquerading,
53 you should install this package.
54
55 %description ipv6
56 The iptables package contains IPv6 (the next version of the IP
57 protocol) support for iptables. Iptables controls the Linux kernel
58 network packet filtering code, allowing you to set up firewalls and IP
59 masquerading. 
60
61 Install iptables-ipv6 if you need to set up firewalling for your
62 network and you are using ipv6.
63
64 %if %{build_devel}
65 %description devel
66 The iptables utility controls the network packet filtering code in the
67 Linux kernel. If you need to set up firewalls and/or IP masquerading,
68 you should install this package.
69 %endif
70
71 %prep
72 rm -rf %{buildroot}
73
74 %setup -q
75
76 # Put it to a reasonable place
77 find . -type f -exec perl -pi -e "s,/usr,%{prefix},g" {} \;
78
79 %build
80 TOPDIR=`pwd`
81 OPT="$RPM_OPT_FLAGS -I$TOPDIR/include"
82
83 %define KERNEL %(rpm -q --qf '%%{VERSION}-%%{RELEASE}-%%{ARCH}\\n' kernel-devel | tail -n 1 )
84 count=$(rpm -q kernel-devel| wc -l)
85 if [ $count -gt 1 ] ; then
86         echo "WARNING: choosing kernel-devel-%{KERNEL}"
87         echo "  but there are other kernel-devel packages installed: $(rpm -q kernel-devel)"
88 fi
89         
90 %define KERNEL_DIR "/usr/src/kernels/%{KERNEL}"
91
92 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib}
93 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib} iptables-save iptables-restore
94 make COPT_FLAGS="$OPT" KERNEL_DIR=%{KERNEL_DIR} LIBDIR=/%{_lib} ip6tables-save ip6tables-restore
95
96 %install
97 make install DESTDIR=%{buildroot} KERNEL_DIR=%{KERNEL_DIR} BINDIR=/sbin LIBDIR=/%{_lib} MANDIR=%{_mandir}
98 %if %{build_devel}
99 make install-devel DESTDIR=%{buildroot} KERNEL_DIR=%{KERNEL_DIR} BINDIR=/sbin LIBDIR=%{_libdir} MANDIR=%{_mandir} INCDIR=%{_includedir}
100 %endif
101 cp ip{6,}tables-{save,restore} $RPM_BUILD_ROOT/sbin
102 cp iptables-*.8 $RPM_BUILD_ROOT%{_mandir}/man8
103 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
104 install -c -m755 %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/iptables
105 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
106 install -c -m755 ip6tables.init $RPM_BUILD_ROOT/etc/rc.d/init.d/ip6tables
107 mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
108 install -c -m755 %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/iptables-config
109 install -c -m755 %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/iptables
110 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
111 install -c -m755 ip6tables-config $RPM_BUILD_ROOT/etc/sysconfig/ip6tables-config
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT 
115
116 %post
117 /sbin/chkconfig --add iptables
118 if [ "$PL_BOOTCD" != "1" ] ; then
119     /sbin/service iptables restart
120 fi
121
122 %preun
123 if [ "$1" = 0 ]; then
124     /sbin/chkconfig --del iptables
125 fi
126
127 %post ipv6
128 /sbin/chkconfig --add ip6tables
129 if [ "$PL_BOOTCD" != "1" ] ; then
130     /sbin/service ip6tables restart
131 fi
132
133 %preun ipv6
134 if [ "$1" = 0 ]; then
135     /sbin/chkconfig --del ip6tables
136 fi
137
138 %files
139 %defattr(-,root,root,0755)
140 %doc COPYING INSTALL INCOMPATIBILITIES
141 %config %attr(0755,root,root) /etc/rc.d/init.d/iptables
142 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
143 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
144 /sbin/iptables*
145 %{_mandir}/man8/iptables*
146 %dir /%{_lib}/iptables
147 /%{_lib}/iptables/libipt*
148 /sbin/ipset*
149 %{_mandir}/man8/ipset*
150 %dir /%{_lib}/ipset
151 /%{_lib}/ipset/libipset*
152
153 %files ipv6
154 %defattr(-,root,root,0755)
155 %config %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
156 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
157 /sbin/ip6tables*
158 %{_mandir}/man8/ip6tables*
159 /%{_lib}/iptables/libip6t*
160
161 %if %{build_devel}
162 %files devel
163 %defattr(-,root,root,0755)
164 %{_includedir}/libipq.h
165 %{_libdir}/libipq.a
166 #%{_libdir}/libiptc.a
167 %{_mandir}/man3/*
168 %endif
169
170 %changelog
171 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.3.8-9
172 - fixes for building on f9/gcc-4.3 - no functional change
173
174 * Sat Aug 30 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.3.8-8
175 - use PL_BOOTCD to prevent the service from getting started at build-time
176
177 * Mon Aug 04 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.3.8-7
178 - Codemux/PF change
179
180 * Mon Jul 28 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - iptables-1.3.8-6
181 - Syntax error in the spec file prevented this package from installing.  Fixed.
182
183 * Fri Jul 25 2008 Andy Bavier <acb@cs.princeton.edu> - iptables-1.3.8-5
184 - * --add-mark action in CLASSIFY target
185 - * Remove chkconfig from .spec file
186 - * Fix iptables-save/-restore bug for MARK with --copy-xid
187 - * Fix default PlanetLab iptables config
188
189 * Mon Jul 21 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.3.8-4
190 - Load tun/tap
191
192 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.3.8-3
193 - * Load required kernel modules before configuring tun/tap devices
194
195 * Wed Jul 09 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.3.8-2
196 - Added tuntap support. Let's start it in the iptables initscripts for now.
197
198 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - iptables-1.3.8-1
199 - Commit for latest fixes in trunk for the iptables config.  This one in
200 - particular loads ip_conntrack in order to have the new vnet support ping right
201 - away.
202
203
204 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
205 - rebuilt
206
207 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
208 - fixed iptables-restore -c fault if there are no counters (#116421)
209
210 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
211 - rebuilt
212
213 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
214 - Close File descriptors to prevent SELinux error message
215
216 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
217 - rebuild
218
219 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
220 - vew version 1.2.9
221 - new config options in ipXtables-config:
222   IPTABLES_MODULES_UNLOAD
223 - more documentation in ipXtables-config
224 - fix for netlink security issue in libipq (devel package)
225 - print fix for libipt_icmp (#109546)
226
227 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
228 - marked all messages in iptables init script for translation (#107462)
229 - enabled devel package (#105884, #106101)
230 - bumped build for fedora for libipt_recent.so (#106002)
231
232 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
233 - fixed lost udp port range in ip6tables-save (#104484)
234 - fixed non numeric multiport port output in ipXtables-savs
235
236 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
237 - do not link against -lnsl
238
239 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
240 - made variables in rmmod_r local
241
242 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
243 - fixed permission for init script
244
245 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
246 - fixed save when iptables file is missing and iptables-config permissions
247
248 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
249 - fixes for ip6tables: module unloading, setting policy only for existing 
250   tables
251
252 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
253 - IPTABLES_SAVE_COUNTER defaults to no, now
254 - install config file in /etc/sysconfig
255 - exchange unload of ip_tables and ip_conntrack
256 - fixed start function
257
258 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
259 - new config option IPTABLES_SAVE_ON_RESTART
260 - init script: new status, save and restart
261 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
262
263 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
264 - new config option IPTABLES_STATUS_NUMERIC
265 - cleared IPTABLES_MODULES in iptables-config
266
267 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
268 - new init scripts
269
270 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
271 - remove check for very old kernel versions in init scripts
272 - sync up both init scripts and remove some further ugly things
273 - add some docu into rpm
274
275 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
276 - rebuild
277
278 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
279 - update to 1.2.8
280
281 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
282 - rebuilt
283
284 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
285 - update to 1.2.7a
286 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
287
288 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
289 - Fix multilib
290
291 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
292 - fixed iptables and ip6tables initscript output, based on #70511
293 - check return status of all iptables calls, not just the last one
294   in a 'for' loop.
295
296 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
297 - 1.2.6a (bugfix release, #69747)
298
299 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
300 - automated rebuild
301
302 * Thu May 23 2002 Tim Powers <timp@redhat.com>
303 - automated rebuild
304
305 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
306 - Add some fixes from CVS, fixing bug #60465
307
308 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
309 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
310   #59402
311 - Update URL (#59354)
312 - Use /sbin/chkconfig rather than chkconfig in %postun script
313
314 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
315 - 1.2.5
316
317 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
318 - automated rebuild
319
320 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
321 - Fix %preun script
322
323 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
324 - Update to 1.2.4 (various fixes, including security fixes; among others:
325   #42990, #50500, #53325, #54280)
326 - Fix init script (#31133)
327
328 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
329 - 1.2.3 (5 security fixes, some other fixes)
330 - Fix updating (#53032)
331
332 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
333 - Fix #50990
334 - Add some fixes from current CVS; should fix #52620
335
336 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
337 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
338   issues
339
340 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
341 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
342   <mschwendt@yahoo.com>
343
344 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
345 - 1.2.2
346
347 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
348 - 1.2.1a, fixes #28412, #31136, #31460, #31133
349
350 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
351 - Yet another initscript fix (#30173)
352 - Fix the fixes; they fixed some issues but broke more important
353   stuff :/ (#30176)
354
355 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
356 - Fix up initscript (#27962)
357 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
358
359 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
360 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
361
362 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
363 - fix bugzilla #25986 (initscript not marked as config file)
364 - fix bugzilla #25962 (iptables-restore)
365 - mv chkconfig --del from postun to preun
366
367 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
368 - Fix check for ipchains
369
370 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
371 - Some fixes to init scripts
372
373 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
374 - Add some fixes from CVS, fixes among other things Bug #24732
375
376 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
377 - Add missing man pages, fix up init script (Bug #17676)
378
379 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
380 - add init script
381
382 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
383 - 1.2
384 - fix up ipv6 split
385 - add init script
386 - Move the plugins from /usr/lib/iptables to /lib/iptables.
387   This needs to work before /usr is mounted...
388 - Use -O1 on alpha (compiler bug)
389
390 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
391 - 1.1.2
392 - Add IPv6 support (in separate package)
393
394 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
395 - build everywhere
396
397 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
398 - 1.1.1
399
400 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
401 - automatic rebuild
402
403 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
404 - move iptables to /sbin.
405 - excludearch alpha for now, not building there because of compiler bug(?)
406
407 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
408 - don't obsolete ipchains either
409 - update to 1.1.0
410
411 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
412 - remove explicit kernel requirement
413
414 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
415 - initial package