bugfixes in build - still can't build as the patch file is not right
[iptables.git] / iptables.spec
1 %define name iptables
2 %define version 1.4.12
3 %define subversion .1
4 %define taglevel 0
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7 %define actual_name %{name}-%{version}%{subversion}
8
9 Vendor: PlanetLab
10 Packager: PlanetLab Central <support@planet-lab.org>
11 Distribution: PlanetLab %{plrelease}
12 URL: %{SCMURL}
13
14 Summary: Tools for managing Linux kernel packet filtering capabilities
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source: http://www.netfilter.org/projects/iptables/files/%{actual_name}.tar.bz2
19 Source1: iptables.init
20 Source2: iptables-config
21 Source3: planetlab-config
22 Patch1: copy-xid.patch
23 Group: System Environment/Base
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25 License: GPLv2
26 BuildRequires: libselinux-devel
27 BuildRequires: kernel-headers
28 Conflicts: kernel < 2.4.20
29 Requires(post): chkconfig
30 Requires(post): initscripts
31 Requires(preun): chkconfig
32
33 %description
34 The iptables utility controls the network packet filtering code in the
35 Linux kernel. If you need to set up firewalls and/or IP masquerading,
36 you should install this package.
37
38 %package ipv6
39 Summary: IPv6 support for iptables
40 Group: System Environment/Base
41 Requires: %{name} = %{version}-%{release}
42 Requires(post): chkconfig
43 Requires(preun): chkconfig
44
45 %description ipv6
46 The iptables package contains IPv6 (the next version of the IP
47 protocol) support for iptables. Iptables controls the Linux kernel
48 network packet filtering code, allowing you to set up firewalls and IP
49 masquerading. 
50
51 Install iptables-ipv6 if you need to set up firewalling for your
52 network and you are using ipv6.
53
54 %package devel
55 Summary: Development package for iptables
56 Group: System Environment/Base
57 Requires: %{name} = %{version}-%{release}
58 Requires: pkgconfig
59
60 %description devel
61 iptables development headers and libraries.
62
63 The iptc interface is upstream marked as not public. The interface is not 
64 stable and may change with every new version. It is therefore unsupported.
65
66 %prep
67 %setup -q -n %{actual_name}
68 %patch1 -p1 
69
70 %build
71 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
72 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
73
74 # do not use rpath
75 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
76 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
77
78 make
79
80 %install
81 rm -rf %{buildroot}
82
83 make install DESTDIR=%{buildroot} 
84 # remove la file(s)
85 rm -f %{buildroot}/%{_lib}/*.la
86
87 # install ip*tables.h header files
88 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
89 install -d -m 755 %{buildroot}%{_includedir}/iptables
90 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
91
92 # install ipulog header file
93 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
94 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
95
96 # create symlinks for devel so libs
97 install -d -m 755 %{buildroot}%{_libdir}
98 for i in %{buildroot}/%{_lib}/*.so; do
99     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
100 done
101
102 # move pkgconfig to %{_libdir}
103 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
104
105 # install init scripts and configuration files
106 install -d -m 755 %{buildroot}/etc/rc.d/init.d
107 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
108 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
109 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
110 install -d -m 755 %{buildroot}/etc/sysconfig
111 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
112 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
113 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
114 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
115
116 %clean
117 rm -rf %{buildroot}
118
119 %post
120 /sbin/ldconfig
121 /sbin/chkconfig --add iptables
122 DEFAULT_IFACE=$(ip route show default | awk '/default/ {print $5}')
123 sed -i -e "s;__eth;$DEFAULT_IFACE;g" /etc/sysconfig/iptables 
124 [ "$PL_BOOTCD" = "1" ] || service iptables restart
125
126 %postun -p /sbin/ldconfig
127
128 %preun
129 if [ "$1" = 0 ]; then
130         /sbin/chkconfig --del iptables
131 fi
132
133 %post ipv6
134 /sbin/chkconfig --add ip6tables
135
136 %preun ipv6
137 if [ "$1" = 0 ]; then
138         /sbin/chkconfig --del ip6tables
139 fi
140
141 %files
142 %defattr(-,root,root)
143 %doc COPYING INSTALL INCOMPATIBILITIES
144 %attr(0755,root,root) /etc/rc.d/init.d/iptables
145 %config %attr(0600,root,root) /etc/sysconfig/iptables-config
146 %config %attr(0600,root,root) /etc/sysconfig/iptables
147 /sbin/iptables*
148 /bin/iptables-xml
149 %{_mandir}/man8/iptables*
150 %dir /%{_lib}/xtables
151 /%{_lib}/xtables/libipt*
152 /%{_lib}/xtables/libxt*
153 /%{_lib}/libip*tc.so.*
154 /%{_lib}/libipq.so.*
155 /%{_lib}/libxtables.so.*
156
157 %files ipv6
158 %defattr(-,root,root)
159 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
160 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
161 /sbin/ip6tables*
162 %{_mandir}/man8/ip6tables*
163 /%{_lib}/xtables/libip6t*
164
165 %files devel
166 %defattr(-,root,root)
167 %dir %{_includedir}/iptables
168 %{_includedir}/iptables/*.h
169 %{_includedir}/*.h
170 %dir %{_includedir}/libiptc
171 %{_includedir}/libiptc/*.h
172 %dir %{_includedir}/libipulog
173 %{_includedir}/libipulog/*.h
174 %{_mandir}/man3/*
175 /%{_lib}/libip*tc.so
176 /%{_lib}/libipq.so
177 /%{_lib}/libxtables.so
178 %{_libdir}/libip*tc.so
179 %{_libdir}/libipq.so
180 %{_libdir}/libxtables.so
181 %{_libdir}/pkgconfig/libiptc.pc
182 %{_libdir}/pkgconfig/xtables.pc
183
184 %changelog
185 * Tue Aug 09 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.4.10-5
186 - Adding a recently abused (=received experimental traffic from planetlab) node to a global iptables blacklist. I will be
187 - implementing this mechanism more formally
188 - using
189 - iptables in the coming days. Unfortunately, because of the complexity of the recipient network we are unable to
190 - determine a comprehensive set of the slices responsible in this case, so I am adding this temporary hack for now.
191
192 * Thu Mar 24 2011 S.Çağlar Onur <caglar@verivue.com> - iptables-1.4.10-4
193 - Don't start iptables service on build time
194
195 * Wed Feb 23 2011 S.Çağlar Onur <caglar@verivue.com> - iptables-1.4.10-3
196 - Remove ugly hack for config files
197
198 * Thu Jan 27 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-2
199 - Fix the patch
200
201 * Wed Jan 26 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-1
202 - Fix incorrect sha1sum
203
204 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.9-1
205 - add requires initscripts in deps
206
207 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-5
208 - Restart iptables service after package upgrades
209
210 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
211 - Restore iIPTABLES_MODULES list
212
213 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
214 - drop backward compatibility with older iptables versions as new kernels only support v2
215 - remove unused modules from iptables-config file
216
217 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
218 - fixed specfile for duplicate URL
219
220 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
221 - added default values for IPTABLES_STATUS_VERBOSE and
222   IPTABLES_STATUS_LINENUMBERS in init script
223 - added missing lsb keywords Required-Start and Required-Stop to init script
224
225 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
226 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
227   - libip4tc: Add static qualifier to dump_entry()
228   - libipq: build as shared library
229   - recent: reorder cases in code (cosmetic cleanup)
230   - several man page and documentation fixes
231   - policy: fix error message showing wrong option
232   - includes: header updates
233   - Lift restrictions on interface names
234 - fixed license and moved iptables-xml into base package according to review
235
236 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
237 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
238   to /usr/lib[64] for compatibility (rhbz#558796)
239
240 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
241 - new version 1.4.6 with support for all new features of 2.6.32
242   - several man page fixes
243   - Support for nommu arches
244   - realm: remove static initializations
245   - libiptc: remove unused functions
246   - libiptc: avoid strict-aliasing warnings
247   - iprange: do accept non-ranges for xt_iprange v1
248   - iprange: warn on reverse range
249   - iprange: roll address parsing into a loop
250   - iprange: do accept non-ranges for xt_iprange v1 (log)
251   - iprange: warn on reverse range (log)
252   - libiptc: fix wrong maptype of base chain counters on restore
253   - iptables: fix undersized deletion mask creation
254   - style: reduce indent in xtables_check_inverse
255   - libxtables: hand argv to xtables_check_inverse
256   - iptables/extensions: make bundled options work again
257   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
258   - iptables: take masks into consideration for replace command
259   - doc: explain experienced --hitcount limit
260   - doc: name resolution clarification
261   - iptables: expose option to zero packet/byte counters for a specific rule
262   - build: restore --disable-ipv6 functionality on system w/o v6 headers
263   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
264   - DNAT: fix incorrect check during parsing
265   - extensions: add osf extension
266   - conntrack: fix --expires parsing
267
268 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
269 - dropped nf_ext_init remains from cloexec patch
270
271 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
272 - new version 1.4.5 with support for all new features of 2.6.31
273   - libxt_NFQUEUE: add new v1 version with queue-balance option
274   - xt_conntrack: revision 2 for enlarged state_mask member
275   - libxt_helper: fix invalid passed option to check_inverse
276   - libiptc: split v4 and v6
277   - extensions: collapse registration structures
278   - iptables: allow for parse-less extensions
279   - iptables: allow for help-less extensions
280   - extensions: remove empty help and parse functions
281   - xtables: add multi-registration functions
282   - extensions: collapse data variables to use multi-reg calls
283   - xtables: warn of missing version identifier in extensions
284   - multi binary: allow subcommand via argv[1]
285   - iptables: accept multiple IP address specifications for -s, -d
286   - several build fixes
287   - several man page fixes
288 - fixed two leaked file descriptors on sockets (rhbz#521397)
289
290 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
291 - new version 1.4.4 with support for all new features of 2.6.30
292   - several man page fixes
293   - iptables: replace open-coded sizeof by ARRAY_SIZE
294   - libip6t_policy: remove redundant functions
295   - policy: use direct xt_policy_info instead of ipt/ip6t
296   - policy: merge ipv6 and ipv4 variant
297   - extensions: add `cluster' match support
298   - extensions: add const qualifiers in print/save functions
299   - extensions: use NFPROTO_UNSPEC for .family field
300   - extensions: remove redundant casts
301   - iptables: close open file descriptors
302   - fix segfault if incorrect protocol name is used
303   - replace open-coded sizeof by ARRAY_SIZE
304   - do not include v4-only modules in ip6tables manpage
305   - use direct xt_policy_info instead of ipt/ip6t
306   - xtables: fix segfault if incorrect protocol name is used
307   - libxt_connlimit: initialize v6_mask
308   - SNAT/DNAT: add support for persistent multi-range NAT mappings
309
310 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
311 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
312
313 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
314 - new version 1.4.3.2
315 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
316
317 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
318 - new version 1.4.3.1
319   - libiptc is now shared
320   - supports all new features of the 2.6.29 kernel
321 - dropped typo_latter patch
322
323 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
324 - still more review fixes (rhbz#225906)
325   - consistent macro usage
326   - use sed instead of perl for rpath removal
327   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
328
329 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
330 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
331
332 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
333 - new version 1.4.2
334 - removed TOS value mask patch (upstream)
335 - more review fixes (rhbz#225906)
336 - install all header files (rhbz#462207)
337 - dropped nf_ext_init (rhbz#472548)
338
339 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
340 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
341 - two more cloexec fixes
342
343 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
344 - upstream bug fix release 1.4.1.1
345 - dropped extra patch for 1.4.1 - not needed anymore
346
347 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
348 - new version 1.4.1 with new build environment
349 - additional ipv6 network mask patch from Jan Engelhardt
350 - spec file cleanup
351 - removed old patches
352
353 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
354 - use normal kernel headers, not linux/compiler.h
355 - change BuildRequires: kernel-devel to kernel-headers
356 - We need to do this to be able to build for both sparcv9 and sparc64 
357   (there is no kernel-devel.sparcv9)
358
359 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
360 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
361
362 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
363 - use the kernel headers from the build tree for iptables for now to be able to 
364   compile this package, but this makes the package more kernel dependant
365 - use s6_addr32 instead of in6_u.u6_addr32
366
367 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
368 - Autorebuild for GCC 4.3
369
370 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
371 - new version 1.4.0
372 - fixed condrestart (rhbz#428148)
373 - report the module in rmmod_r if there is an error
374 - use nf_ext_init instead of my_init for extension constructors
375
376 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
377 - fixed leaked file descriptor before fork/exec (rhbz#312191)
378 - blacklisting is not working, use "install X /bin/(true|false)" test instead
379 - return private exit code 150 for disabled ipv6 support
380 - use script name for output messages
381
382 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
383 - fixed error code for stopping a already stopped firewall (rhbz#321751)
384 - moved blacklist test into start
385
386 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
387 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
388 - use simpler fix for (rhbz#295611)
389   Thanks to Linus Torvalds for the patch.
390
391 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
392 - fixed IPv6 reject type (rhbz#295181)
393 - fixed init script: start, stop and status
394 - support netfilter compiled into kernel in init script (rhbz#295611)
395 - dropped inversion for limit modules from man pages (rhbz#220780)
396 - fixed typo in ip6tables man page (rhbz#236185)
397
398 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
399 - do not depend on local_fs in lsb header - this delayes start after network
400 - fixed exit code for initscript usage
401
402 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
403 - do not use lock file for condrestart test
404
405 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
406 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
407 - provide iptc interface again, but unsupported (rhbz#216733)
408 - compile all extension, which are supported by the kernel-headers package
409 - review fixes (rhbz#225906)
410
411 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
412 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
413
414 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
415 - New version 1.3.8
416
417 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
418 - fix error when ipv6 support isn't loaded in the kernel (#236888)
419
420 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
421 - fixed installation of secmark modules
422
423 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
424 - new verison 1.3.7
425 - iptc is not a public interface and therefore not installed anymore
426 - dropped upstream secmark patch
427
428 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
429 - added secmark iptables patches (#201573)
430
431 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
432 - rebuild
433
434 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
435 - bump again for double-long bug on ppc(64)
436
437 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
438 - rebuilt for new gcc4.1 snapshot and glibc changes
439
440 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
441 - new version 1.3.5
442 - fixed init script to set policy for raw tables, too (#179094)
443
444 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
445 - added important iptables header files to devel package
446
447 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
448 - rebuilt
449
450 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
451 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
452   replace "_init" with "__attribute((constructor)) my_init"
453
454 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
455 - rebuild due to unresolved symbols in shared libraries
456
457 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
458 - new version 1.3.4
459 - dropped free_opts patch (upstream fixed)
460 - made libipq PIC (#158623)
461 - additional configuration options for iptables startup script (#172929)
462   Thanks to Jan Gruenwald for the patch
463 - spec file cleanup (dropped linux_header define and usage)
464
465 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
466 - new version 1.3.2 with additional patch for the misplaced free_opts call
467   from Marcus Sundberg
468
469 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
470 - new version 1.3.1
471
472 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
473 - Remove unnecessary explicit kernel dep (#146142)
474 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
475   for the patch
476 - Adapted iptables-config to reference to modprobe.conf (#150143)
477 - Remove misleading message (#140154): Thanks to Ulrich Drepper
478   for the patch
479
480 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
481 - new version 1.3.0
482
483 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
484 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
485
486 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
487 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
488 - modified config file to match this change and un-commented variables with
489   default values
490
491 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
492 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
493   for the patch
494
495 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
496 - fixed free bug in iptables (#128322)
497
498 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
499 - new version 1.2.11
500
501 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
502 - new version 1.2.10
503
504 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
505 - rebuilt
506
507 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
508 - rebuilt
509
510 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
511 - fixed iptables-restore -c fault if there are no counters (#116421)
512
513 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
514 - rebuilt
515
516 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
517 - Close File descriptors to prevent SELinux error message
518
519 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
520 - rebuild
521
522 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
523 - vew version 1.2.9
524 - new config options in ipXtables-config:
525   IPTABLES_MODULES_UNLOAD
526 - more documentation in ipXtables-config
527 - fix for netlink security issue in libipq (devel package)
528 - print fix for libipt_icmp (#109546)
529
530 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
531 - marked all messages in iptables init script for translation (#107462)
532 - enabled devel package (#105884, #106101)
533 - bumped build for fedora for libipt_recent.so (#106002)
534
535 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
536 - fixed lost udp port range in ip6tables-save (#104484)
537 - fixed non numeric multiport port output in ipXtables-savs
538
539 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
540 - do not link against -lnsl
541
542 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
543 - made variables in rmmod_r local
544
545 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
546 - fixed permission for init script
547
548 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
549 - fixed save when iptables file is missing and iptables-config permissions
550
551 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
552 - fixes for ip6tables: module unloading, setting policy only for existing 
553   tables
554
555 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
556 - IPTABLES_SAVE_COUNTER defaults to no, now
557 - install config file in /etc/sysconfig
558 - exchange unload of ip_tables and ip_conntrack
559 - fixed start function
560
561 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
562 - new config option IPTABLES_SAVE_ON_RESTART
563 - init script: new status, save and restart
564 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
565
566 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
567 - new config option IPTABLES_STATUS_NUMERIC
568 - cleared IPTABLES_MODULES in iptables-config
569
570 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
571 - new init scripts
572
573 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
574 - remove check for very old kernel versions in init scripts
575 - sync up both init scripts and remove some further ugly things
576 - add some docu into rpm
577
578 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
579 - rebuild
580
581 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
582 - update to 1.2.8
583
584 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
585 - rebuilt
586
587 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
588 - update to 1.2.7a
589 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
590
591 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
592 - Fix multilib
593
594 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
595 - fixed iptables and ip6tables initscript output, based on #70511
596 - check return status of all iptables calls, not just the last one
597   in a 'for' loop.
598
599 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
600 - 1.2.6a (bugfix release, #69747)
601
602 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
603 - automated rebuild
604
605 * Thu May 23 2002 Tim Powers <timp@redhat.com>
606 - automated rebuild
607
608 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
609 - Add some fixes from CVS, fixing bug #60465
610
611 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
612 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
613   #59402
614 - Update URL (#59354)
615 - Use /sbin/chkconfig rather than chkconfig in %%postun script
616
617 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
618 - 1.2.5
619
620 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
621 - automated rebuild
622
623 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
624 - Fix %%preun script
625
626 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
627 - Update to 1.2.4 (various fixes, including security fixes; among others:
628   #42990, #50500, #53325, #54280)
629 - Fix init script (#31133)
630
631 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
632 - 1.2.3 (5 security fixes, some other fixes)
633 - Fix updating (#53032)
634
635 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
636 - Fix #50990
637 - Add some fixes from current CVS; should fix #52620
638
639 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
640 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
641   issues
642
643 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
644 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
645   <mschwendt@yahoo.com>
646
647 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
648 - 1.2.2
649
650 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
651 - 1.2.1a, fixes #28412, #31136, #31460, #31133
652
653 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
654 - Yet another initscript fix (#30173)
655 - Fix the fixes; they fixed some issues but broke more important
656   stuff :/ (#30176)
657
658 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
659 - Fix up initscript (#27962)
660 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
661
662 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
663 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
664
665 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
666 - fix bugzilla #25986 (initscript not marked as config file)
667 - fix bugzilla #25962 (iptables-restore)
668 - mv chkconfig --del from postun to preun
669
670 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
671 - Fix check for ipchains
672
673 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
674 - Some fixes to init scripts
675
676 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
677 - Add some fixes from CVS, fixes among other things Bug #24732
678
679 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
680 - Add missing man pages, fix up init script (Bug #17676)
681
682 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
683 - add init script
684
685 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
686 - 1.2
687 - fix up ipv6 split
688 - add init script
689 - Move the plugins from /usr/lib/iptables to /lib/iptables.
690   This needs to work before /usr is mounted...
691 - Use -O1 on alpha (compiler bug)
692
693 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
694 - 1.1.2
695 - Add IPv6 support (in separate package)
696
697 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
698 - build everywhere
699
700 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
701 - 1.1.1
702
703 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
704 - automatic rebuild
705
706 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
707 - move iptables to /sbin.
708 - excludearch alpha for now, not building there because of compiler bug(?)
709
710 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
711 - don't obsolete ipchains either
712 - update to 1.1.0
713
714 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
715 - remove explicit kernel requirement
716
717 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
718 - initial package