Setting tag iptables-1.4.7-3
[iptables.git] / iptables.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name iptables
7 %define version 1.4.7
8 %define taglevel 3
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: Tools for managing Linux kernel packet filtering capabilities
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
22 Source1: iptables.init
23 Source2: iptables-config
24 Source3: planetlab-config
25 Patch1: copy-xid.patch
26 Group: System Environment/Base
27 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28 License: GPLv2
29 BuildRequires: libselinux-devel
30 BuildRequires: kernel-headers
31 Conflicts: kernel < 2.4.20
32 Requires(post): chkconfig
33 Requires(preun): chkconfig
34
35 %description
36 The iptables utility controls the network packet filtering code in the
37 Linux kernel. If you need to set up firewalls and/or IP masquerading,
38 you should install this package.
39
40 %package ipv6
41 Summary: IPv6 support for iptables
42 Group: System Environment/Base
43 Requires: %{name} = %{version}-%{release}
44 Requires(post): chkconfig
45 Requires(preun): chkconfig
46
47 %description ipv6
48 The iptables package contains IPv6 (the next version of the IP
49 protocol) support for iptables. Iptables controls the Linux kernel
50 network packet filtering code, allowing you to set up firewalls and IP
51 masquerading. 
52
53 Install iptables-ipv6 if you need to set up firewalling for your
54 network and you are using ipv6.
55
56 %package devel
57 Summary: Development package for iptables
58 Group: System Environment/Base
59 Requires: %{name} = %{version}-%{release}
60 Requires: pkgconfig
61
62 %description devel
63 iptables development headers and libraries.
64
65 The iptc interface is upstream marked as not public. The interface is not 
66 stable and may change with every new version. It is therefore unsupported.
67
68 %prep
69 %setup -q
70 %patch1 -p1 
71
72 %build
73 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
74 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
75
76 # do not use rpath
77 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
78 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
79
80 make
81
82 %install
83 rm -rf %{buildroot}
84
85 make install DESTDIR=%{buildroot} 
86 # remove la file(s)
87 rm -f %{buildroot}/%{_lib}/*.la
88
89 # install ip*tables.h header files
90 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
91 install -d -m 755 %{buildroot}%{_includedir}/iptables
92 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
93
94 # install ipulog header file
95 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
96 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
97
98 # create symlinks for devel so libs
99 install -d -m 755 %{buildroot}%{_libdir}
100 for i in %{buildroot}/%{_lib}/*.so; do
101     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
102 done
103
104 # move pkgconfig to %{_libdir}
105 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
106
107 # install init scripts and configuration files
108 install -d -m 755 %{buildroot}/etc/rc.d/init.d
109 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
110 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
111 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
112 install -d -m 755 %{buildroot}/etc/sysconfig
113 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
114 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
115 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
116 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
117
118 %clean
119 rm -rf %{buildroot}
120
121 %post
122 /sbin/ldconfig
123 /sbin/chkconfig --add iptables
124
125 %postun -p /sbin/ldconfig
126
127 %preun
128 if [ "$1" = 0 ]; then
129         /sbin/chkconfig --del iptables
130 fi
131
132 %post ipv6
133 /sbin/chkconfig --add ip6tables
134
135 %preun ipv6
136 if [ "$1" = 0 ]; then
137         /sbin/chkconfig --del ip6tables
138 fi
139
140 %files
141 %defattr(-,root,root)
142 %doc COPYING INSTALL INCOMPATIBILITIES
143 %attr(0755,root,root) /etc/rc.d/init.d/iptables
144 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
145 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
146 /sbin/iptables*
147 /bin/iptables-xml
148 %{_mandir}/man8/iptables*
149 %dir /%{_lib}/xtables
150 /%{_lib}/xtables/libipt*
151 /%{_lib}/xtables/libxt*
152 /%{_lib}/libip*tc.so.*
153 /%{_lib}/libipq.so.*
154 /%{_lib}/libxtables.so.*
155
156 %files ipv6
157 %defattr(-,root,root)
158 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
159 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
160 /sbin/ip6tables*
161 %{_mandir}/man8/ip6tables*
162 /%{_lib}/xtables/libip6t*
163
164 %files devel
165 %defattr(-,root,root)
166 %dir %{_includedir}/iptables
167 %{_includedir}/iptables/*.h
168 %{_includedir}/*.h
169 %dir %{_includedir}/libiptc
170 %{_includedir}/libiptc/*.h
171 %dir %{_includedir}/libipulog
172 %{_includedir}/libipulog/*.h
173 %{_mandir}/man3/*
174 /%{_lib}/libip*tc.so
175 /%{_lib}/libipq.so
176 /%{_lib}/libxtables.so
177 %{_libdir}/libip*tc.so
178 %{_libdir}/libipq.so
179 %{_libdir}/libxtables.so
180 %{_libdir}/pkgconfig/libiptc.pc
181 %{_libdir}/pkgconfig/xtables.pc
182
183 %changelog
184 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
185 - drop backward compatibility with older iptables versions as new kernels only support v2
186 - remove unused modules from iptables-config file
187
188 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
189 - fixed specfile for duplicate URL
190
191 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
192 - added default values for IPTABLES_STATUS_VERBOSE and
193   IPTABLES_STATUS_LINENUMBERS in init script
194 - added missing lsb keywords Required-Start and Required-Stop to init script
195
196 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
197 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
198   - libip4tc: Add static qualifier to dump_entry()
199   - libipq: build as shared library
200   - recent: reorder cases in code (cosmetic cleanup)
201   - several man page and documentation fixes
202   - policy: fix error message showing wrong option
203   - includes: header updates
204   - Lift restrictions on interface names
205 - fixed license and moved iptables-xml into base package according to review
206
207 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
208 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
209   to /usr/lib[64] for compatibility (rhbz#558796)
210
211 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
212 - new version 1.4.6 with support for all new features of 2.6.32
213   - several man page fixes
214   - Support for nommu arches
215   - realm: remove static initializations
216   - libiptc: remove unused functions
217   - libiptc: avoid strict-aliasing warnings
218   - iprange: do accept non-ranges for xt_iprange v1
219   - iprange: warn on reverse range
220   - iprange: roll address parsing into a loop
221   - iprange: do accept non-ranges for xt_iprange v1 (log)
222   - iprange: warn on reverse range (log)
223   - libiptc: fix wrong maptype of base chain counters on restore
224   - iptables: fix undersized deletion mask creation
225   - style: reduce indent in xtables_check_inverse
226   - libxtables: hand argv to xtables_check_inverse
227   - iptables/extensions: make bundled options work again
228   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
229   - iptables: take masks into consideration for replace command
230   - doc: explain experienced --hitcount limit
231   - doc: name resolution clarification
232   - iptables: expose option to zero packet/byte counters for a specific rule
233   - build: restore --disable-ipv6 functionality on system w/o v6 headers
234   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
235   - DNAT: fix incorrect check during parsing
236   - extensions: add osf extension
237   - conntrack: fix --expires parsing
238
239 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
240 - dropped nf_ext_init remains from cloexec patch
241
242 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
243 - new version 1.4.5 with support for all new features of 2.6.31
244   - libxt_NFQUEUE: add new v1 version with queue-balance option
245   - xt_conntrack: revision 2 for enlarged state_mask member
246   - libxt_helper: fix invalid passed option to check_inverse
247   - libiptc: split v4 and v6
248   - extensions: collapse registration structures
249   - iptables: allow for parse-less extensions
250   - iptables: allow for help-less extensions
251   - extensions: remove empty help and parse functions
252   - xtables: add multi-registration functions
253   - extensions: collapse data variables to use multi-reg calls
254   - xtables: warn of missing version identifier in extensions
255   - multi binary: allow subcommand via argv[1]
256   - iptables: accept multiple IP address specifications for -s, -d
257   - several build fixes
258   - several man page fixes
259 - fixed two leaked file descriptors on sockets (rhbz#521397)
260
261 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
262 - new version 1.4.4 with support for all new features of 2.6.30
263   - several man page fixes
264   - iptables: replace open-coded sizeof by ARRAY_SIZE
265   - libip6t_policy: remove redundant functions
266   - policy: use direct xt_policy_info instead of ipt/ip6t
267   - policy: merge ipv6 and ipv4 variant
268   - extensions: add `cluster' match support
269   - extensions: add const qualifiers in print/save functions
270   - extensions: use NFPROTO_UNSPEC for .family field
271   - extensions: remove redundant casts
272   - iptables: close open file descriptors
273   - fix segfault if incorrect protocol name is used
274   - replace open-coded sizeof by ARRAY_SIZE
275   - do not include v4-only modules in ip6tables manpage
276   - use direct xt_policy_info instead of ipt/ip6t
277   - xtables: fix segfault if incorrect protocol name is used
278   - libxt_connlimit: initialize v6_mask
279   - SNAT/DNAT: add support for persistent multi-range NAT mappings
280
281 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
282 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
283
284 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
285 - new version 1.4.3.2
286 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
287
288 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
289 - new version 1.4.3.1
290   - libiptc is now shared
291   - supports all new features of the 2.6.29 kernel
292 - dropped typo_latter patch
293
294 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
295 - still more review fixes (rhbz#225906)
296   - consistent macro usage
297   - use sed instead of perl for rpath removal
298   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
299
300 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
301 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
302
303 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
304 - new version 1.4.2
305 - removed TOS value mask patch (upstream)
306 - more review fixes (rhbz#225906)
307 - install all header files (rhbz#462207)
308 - dropped nf_ext_init (rhbz#472548)
309
310 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
311 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
312 - two more cloexec fixes
313
314 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
315 - upstream bug fix release 1.4.1.1
316 - dropped extra patch for 1.4.1 - not needed anymore
317
318 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
319 - new version 1.4.1 with new build environment
320 - additional ipv6 network mask patch from Jan Engelhardt
321 - spec file cleanup
322 - removed old patches
323
324 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
325 - use normal kernel headers, not linux/compiler.h
326 - change BuildRequires: kernel-devel to kernel-headers
327 - We need to do this to be able to build for both sparcv9 and sparc64 
328   (there is no kernel-devel.sparcv9)
329
330 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
331 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
332
333 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
334 - use the kernel headers from the build tree for iptables for now to be able to 
335   compile this package, but this makes the package more kernel dependant
336 - use s6_addr32 instead of in6_u.u6_addr32
337
338 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
339 - Autorebuild for GCC 4.3
340
341 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
342 - new version 1.4.0
343 - fixed condrestart (rhbz#428148)
344 - report the module in rmmod_r if there is an error
345 - use nf_ext_init instead of my_init for extension constructors
346
347 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
348 - fixed leaked file descriptor before fork/exec (rhbz#312191)
349 - blacklisting is not working, use "install X /bin/(true|false)" test instead
350 - return private exit code 150 for disabled ipv6 support
351 - use script name for output messages
352
353 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
354 - fixed error code for stopping a already stopped firewall (rhbz#321751)
355 - moved blacklist test into start
356
357 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
358 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
359 - use simpler fix for (rhbz#295611)
360   Thanks to Linus Torvalds for the patch.
361
362 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
363 - fixed IPv6 reject type (rhbz#295181)
364 - fixed init script: start, stop and status
365 - support netfilter compiled into kernel in init script (rhbz#295611)
366 - dropped inversion for limit modules from man pages (rhbz#220780)
367 - fixed typo in ip6tables man page (rhbz#236185)
368
369 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
370 - do not depend on local_fs in lsb header - this delayes start after network
371 - fixed exit code for initscript usage
372
373 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
374 - do not use lock file for condrestart test
375
376 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
377 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
378 - provide iptc interface again, but unsupported (rhbz#216733)
379 - compile all extension, which are supported by the kernel-headers package
380 - review fixes (rhbz#225906)
381
382 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
383 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
384
385 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
386 - New version 1.3.8
387
388 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
389 - fix error when ipv6 support isn't loaded in the kernel (#236888)
390
391 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
392 - fixed installation of secmark modules
393
394 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
395 - new verison 1.3.7
396 - iptc is not a public interface and therefore not installed anymore
397 - dropped upstream secmark patch
398
399 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
400 - added secmark iptables patches (#201573)
401
402 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
403 - rebuild
404
405 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
406 - bump again for double-long bug on ppc(64)
407
408 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
409 - rebuilt for new gcc4.1 snapshot and glibc changes
410
411 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
412 - new version 1.3.5
413 - fixed init script to set policy for raw tables, too (#179094)
414
415 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
416 - added important iptables header files to devel package
417
418 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
419 - rebuilt
420
421 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
422 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
423   replace "_init" with "__attribute((constructor)) my_init"
424
425 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
426 - rebuild due to unresolved symbols in shared libraries
427
428 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
429 - new version 1.3.4
430 - dropped free_opts patch (upstream fixed)
431 - made libipq PIC (#158623)
432 - additional configuration options for iptables startup script (#172929)
433   Thanks to Jan Gruenwald for the patch
434 - spec file cleanup (dropped linux_header define and usage)
435
436 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
437 - new version 1.3.2 with additional patch for the misplaced free_opts call
438   from Marcus Sundberg
439
440 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
441 - new version 1.3.1
442
443 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
444 - Remove unnecessary explicit kernel dep (#146142)
445 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
446   for the patch
447 - Adapted iptables-config to reference to modprobe.conf (#150143)
448 - Remove misleading message (#140154): Thanks to Ulrich Drepper
449   for the patch
450
451 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
452 - new version 1.3.0
453
454 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
455 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
456
457 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
458 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
459 - modified config file to match this change and un-commented variables with
460   default values
461
462 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
463 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
464   for the patch
465
466 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
467 - fixed free bug in iptables (#128322)
468
469 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
470 - new version 1.2.11
471
472 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
473 - new version 1.2.10
474
475 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
476 - rebuilt
477
478 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
479 - rebuilt
480
481 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
482 - fixed iptables-restore -c fault if there are no counters (#116421)
483
484 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
485 - rebuilt
486
487 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
488 - Close File descriptors to prevent SELinux error message
489
490 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
491 - rebuild
492
493 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
494 - vew version 1.2.9
495 - new config options in ipXtables-config:
496   IPTABLES_MODULES_UNLOAD
497 - more documentation in ipXtables-config
498 - fix for netlink security issue in libipq (devel package)
499 - print fix for libipt_icmp (#109546)
500
501 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
502 - marked all messages in iptables init script for translation (#107462)
503 - enabled devel package (#105884, #106101)
504 - bumped build for fedora for libipt_recent.so (#106002)
505
506 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
507 - fixed lost udp port range in ip6tables-save (#104484)
508 - fixed non numeric multiport port output in ipXtables-savs
509
510 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
511 - do not link against -lnsl
512
513 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
514 - made variables in rmmod_r local
515
516 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
517 - fixed permission for init script
518
519 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
520 - fixed save when iptables file is missing and iptables-config permissions
521
522 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
523 - fixes for ip6tables: module unloading, setting policy only for existing 
524   tables
525
526 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
527 - IPTABLES_SAVE_COUNTER defaults to no, now
528 - install config file in /etc/sysconfig
529 - exchange unload of ip_tables and ip_conntrack
530 - fixed start function
531
532 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
533 - new config option IPTABLES_SAVE_ON_RESTART
534 - init script: new status, save and restart
535 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
536
537 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
538 - new config option IPTABLES_STATUS_NUMERIC
539 - cleared IPTABLES_MODULES in iptables-config
540
541 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
542 - new init scripts
543
544 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
545 - remove check for very old kernel versions in init scripts
546 - sync up both init scripts and remove some further ugly things
547 - add some docu into rpm
548
549 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
550 - rebuild
551
552 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
553 - update to 1.2.8
554
555 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
556 - rebuilt
557
558 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
559 - update to 1.2.7a
560 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
561
562 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
563 - Fix multilib
564
565 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
566 - fixed iptables and ip6tables initscript output, based on #70511
567 - check return status of all iptables calls, not just the last one
568   in a 'for' loop.
569
570 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
571 - 1.2.6a (bugfix release, #69747)
572
573 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
574 - automated rebuild
575
576 * Thu May 23 2002 Tim Powers <timp@redhat.com>
577 - automated rebuild
578
579 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
580 - Add some fixes from CVS, fixing bug #60465
581
582 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
583 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
584   #59402
585 - Update URL (#59354)
586 - Use /sbin/chkconfig rather than chkconfig in %%postun script
587
588 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
589 - 1.2.5
590
591 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
592 - automated rebuild
593
594 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
595 - Fix %%preun script
596
597 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
598 - Update to 1.2.4 (various fixes, including security fixes; among others:
599   #42990, #50500, #53325, #54280)
600 - Fix init script (#31133)
601
602 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
603 - 1.2.3 (5 security fixes, some other fixes)
604 - Fix updating (#53032)
605
606 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
607 - Fix #50990
608 - Add some fixes from current CVS; should fix #52620
609
610 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
611 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
612   issues
613
614 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
615 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
616   <mschwendt@yahoo.com>
617
618 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
619 - 1.2.2
620
621 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
622 - 1.2.1a, fixes #28412, #31136, #31460, #31133
623
624 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
625 - Yet another initscript fix (#30173)
626 - Fix the fixes; they fixed some issues but broke more important
627   stuff :/ (#30176)
628
629 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
630 - Fix up initscript (#27962)
631 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
632
633 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
634 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
635
636 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
637 - fix bugzilla #25986 (initscript not marked as config file)
638 - fix bugzilla #25962 (iptables-restore)
639 - mv chkconfig --del from postun to preun
640
641 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
642 - Fix check for ipchains
643
644 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
645 - Some fixes to init scripts
646
647 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
648 - Add some fixes from CVS, fixes among other things Bug #24732
649
650 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
651 - Add missing man pages, fix up init script (Bug #17676)
652
653 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
654 - add init script
655
656 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
657 - 1.2
658 - fix up ipv6 split
659 - add init script
660 - Move the plugins from /usr/lib/iptables to /lib/iptables.
661   This needs to work before /usr is mounted...
662 - Use -O1 on alpha (compiler bug)
663
664 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
665 - 1.1.2
666 - Add IPv6 support (in separate package)
667
668 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
669 - build everywhere
670
671 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
672 - 1.1.1
673
674 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
675 - automatic rebuild
676
677 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
678 - move iptables to /sbin.
679 - excludearch alpha for now, not building there because of compiler bug(?)
680
681 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
682 - don't obsolete ipchains either
683 - update to 1.1.0
684
685 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
686 - remove explicit kernel requirement
687
688 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
689 - initial package