Setting tag iptables-1.4.10-5
[iptables.git] / iptables.spec
1 %define name iptables
2 %define version 1.4.10
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Vendor: PlanetLab
8 Packager: PlanetLab Central <support@planet-lab.org>
9 Distribution: PlanetLab %{plrelease}
10 URL: %{SCMURL}
11
12 Summary: Tools for managing Linux kernel packet filtering capabilities
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
17 Source1: iptables.init
18 Source2: iptables-config
19 Source3: planetlab-config
20 Patch1: copy-xid.patch
21 Group: System Environment/Base
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23 License: GPLv2
24 BuildRequires: libselinux-devel
25 BuildRequires: kernel-headers
26 Conflicts: kernel < 2.4.20
27 Requires(post): chkconfig
28 Requires(post): initscripts
29 Requires(preun): chkconfig
30
31 %description
32 The iptables utility controls the network packet filtering code in the
33 Linux kernel. If you need to set up firewalls and/or IP masquerading,
34 you should install this package.
35
36 %package ipv6
37 Summary: IPv6 support for iptables
38 Group: System Environment/Base
39 Requires: %{name} = %{version}-%{release}
40 Requires(post): chkconfig
41 Requires(preun): chkconfig
42
43 %description ipv6
44 The iptables package contains IPv6 (the next version of the IP
45 protocol) support for iptables. Iptables controls the Linux kernel
46 network packet filtering code, allowing you to set up firewalls and IP
47 masquerading. 
48
49 Install iptables-ipv6 if you need to set up firewalling for your
50 network and you are using ipv6.
51
52 %package devel
53 Summary: Development package for iptables
54 Group: System Environment/Base
55 Requires: %{name} = %{version}-%{release}
56 Requires: pkgconfig
57
58 %description devel
59 iptables development headers and libraries.
60
61 The iptc interface is upstream marked as not public. The interface is not 
62 stable and may change with every new version. It is therefore unsupported.
63
64 %prep
65 %setup -q
66 %patch1 -p1 
67
68 %build
69 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
70 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
71
72 # do not use rpath
73 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
74 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
75
76 make
77
78 %install
79 rm -rf %{buildroot}
80
81 make install DESTDIR=%{buildroot} 
82 # remove la file(s)
83 rm -f %{buildroot}/%{_lib}/*.la
84
85 # install ip*tables.h header files
86 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
87 install -d -m 755 %{buildroot}%{_includedir}/iptables
88 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
89
90 # install ipulog header file
91 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
92 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
93
94 # create symlinks for devel so libs
95 install -d -m 755 %{buildroot}%{_libdir}
96 for i in %{buildroot}/%{_lib}/*.so; do
97     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
98 done
99
100 # move pkgconfig to %{_libdir}
101 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
102
103 # install init scripts and configuration files
104 install -d -m 755 %{buildroot}/etc/rc.d/init.d
105 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
106 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
107 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
108 install -d -m 755 %{buildroot}/etc/sysconfig
109 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
110 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
111 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
112 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
113
114 %clean
115 rm -rf %{buildroot}
116
117 %post
118 /sbin/ldconfig
119 /sbin/chkconfig --add iptables
120 DEFAULT_IFACE=$(ip route show default | awk '/default/ {print $5}')
121 sed -i -e "s;__eth;$DEFAULT_IFACE;g" /etc/sysconfig/iptables 
122 [ "$PL_BOOTCD" = "1" ] || service iptables restart
123
124 %postun -p /sbin/ldconfig
125
126 %preun
127 if [ "$1" = 0 ]; then
128         /sbin/chkconfig --del iptables
129 fi
130
131 %post ipv6
132 /sbin/chkconfig --add ip6tables
133
134 %preun ipv6
135 if [ "$1" = 0 ]; then
136         /sbin/chkconfig --del ip6tables
137 fi
138
139 %files
140 %defattr(-,root,root)
141 %doc COPYING INSTALL INCOMPATIBILITIES
142 %attr(0755,root,root) /etc/rc.d/init.d/iptables
143 %config %attr(0600,root,root) /etc/sysconfig/iptables-config
144 %config %attr(0600,root,root) /etc/sysconfig/iptables
145 /sbin/iptables*
146 /bin/iptables-xml
147 %{_mandir}/man8/iptables*
148 %dir /%{_lib}/xtables
149 /%{_lib}/xtables/libipt*
150 /%{_lib}/xtables/libxt*
151 /%{_lib}/libip*tc.so.*
152 /%{_lib}/libipq.so.*
153 /%{_lib}/libxtables.so.*
154
155 %files ipv6
156 %defattr(-,root,root)
157 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
158 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
159 /sbin/ip6tables*
160 %{_mandir}/man8/ip6tables*
161 /%{_lib}/xtables/libip6t*
162
163 %files devel
164 %defattr(-,root,root)
165 %dir %{_includedir}/iptables
166 %{_includedir}/iptables/*.h
167 %{_includedir}/*.h
168 %dir %{_includedir}/libiptc
169 %{_includedir}/libiptc/*.h
170 %dir %{_includedir}/libipulog
171 %{_includedir}/libipulog/*.h
172 %{_mandir}/man3/*
173 /%{_lib}/libip*tc.so
174 /%{_lib}/libipq.so
175 /%{_lib}/libxtables.so
176 %{_libdir}/libip*tc.so
177 %{_libdir}/libipq.so
178 %{_libdir}/libxtables.so
179 %{_libdir}/pkgconfig/libiptc.pc
180 %{_libdir}/pkgconfig/xtables.pc
181
182 %changelog
183 * Tue Aug 09 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.4.10-5
184 - Adding a recently abused (=received experimental traffic from planetlab) node to a global iptables blacklist. I will be
185 - implementing this mechanism more formally
186 - using
187 - iptables in the coming days. Unfortunately, because of the complexity of the recipient network we are unable to
188 - determine a comprehensive set of the slices responsible in this case, so I am adding this temporary hack for now.
189
190 * Thu Mar 24 2011 S.Çağlar Onur <caglar@verivue.com> - iptables-1.4.10-4
191 - Don't start iptables service on build time
192
193 * Wed Feb 23 2011 S.Çağlar Onur <caglar@verivue.com> - iptables-1.4.10-3
194 - Remove ugly hack for config files
195
196 * Thu Jan 27 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-2
197 - Fix the patch
198
199 * Wed Jan 26 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-1
200 - Fix incorrect sha1sum
201
202 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.9-1
203 - add requires initscripts in deps
204
205 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-5
206 - Restart iptables service after package upgrades
207
208 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
209 - Restore iIPTABLES_MODULES list
210
211 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
212 - drop backward compatibility with older iptables versions as new kernels only support v2
213 - remove unused modules from iptables-config file
214
215 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
216 - fixed specfile for duplicate URL
217
218 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
219 - added default values for IPTABLES_STATUS_VERBOSE and
220   IPTABLES_STATUS_LINENUMBERS in init script
221 - added missing lsb keywords Required-Start and Required-Stop to init script
222
223 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
224 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
225   - libip4tc: Add static qualifier to dump_entry()
226   - libipq: build as shared library
227   - recent: reorder cases in code (cosmetic cleanup)
228   - several man page and documentation fixes
229   - policy: fix error message showing wrong option
230   - includes: header updates
231   - Lift restrictions on interface names
232 - fixed license and moved iptables-xml into base package according to review
233
234 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
235 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
236   to /usr/lib[64] for compatibility (rhbz#558796)
237
238 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
239 - new version 1.4.6 with support for all new features of 2.6.32
240   - several man page fixes
241   - Support for nommu arches
242   - realm: remove static initializations
243   - libiptc: remove unused functions
244   - libiptc: avoid strict-aliasing warnings
245   - iprange: do accept non-ranges for xt_iprange v1
246   - iprange: warn on reverse range
247   - iprange: roll address parsing into a loop
248   - iprange: do accept non-ranges for xt_iprange v1 (log)
249   - iprange: warn on reverse range (log)
250   - libiptc: fix wrong maptype of base chain counters on restore
251   - iptables: fix undersized deletion mask creation
252   - style: reduce indent in xtables_check_inverse
253   - libxtables: hand argv to xtables_check_inverse
254   - iptables/extensions: make bundled options work again
255   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
256   - iptables: take masks into consideration for replace command
257   - doc: explain experienced --hitcount limit
258   - doc: name resolution clarification
259   - iptables: expose option to zero packet/byte counters for a specific rule
260   - build: restore --disable-ipv6 functionality on system w/o v6 headers
261   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
262   - DNAT: fix incorrect check during parsing
263   - extensions: add osf extension
264   - conntrack: fix --expires parsing
265
266 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
267 - dropped nf_ext_init remains from cloexec patch
268
269 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
270 - new version 1.4.5 with support for all new features of 2.6.31
271   - libxt_NFQUEUE: add new v1 version with queue-balance option
272   - xt_conntrack: revision 2 for enlarged state_mask member
273   - libxt_helper: fix invalid passed option to check_inverse
274   - libiptc: split v4 and v6
275   - extensions: collapse registration structures
276   - iptables: allow for parse-less extensions
277   - iptables: allow for help-less extensions
278   - extensions: remove empty help and parse functions
279   - xtables: add multi-registration functions
280   - extensions: collapse data variables to use multi-reg calls
281   - xtables: warn of missing version identifier in extensions
282   - multi binary: allow subcommand via argv[1]
283   - iptables: accept multiple IP address specifications for -s, -d
284   - several build fixes
285   - several man page fixes
286 - fixed two leaked file descriptors on sockets (rhbz#521397)
287
288 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
289 - new version 1.4.4 with support for all new features of 2.6.30
290   - several man page fixes
291   - iptables: replace open-coded sizeof by ARRAY_SIZE
292   - libip6t_policy: remove redundant functions
293   - policy: use direct xt_policy_info instead of ipt/ip6t
294   - policy: merge ipv6 and ipv4 variant
295   - extensions: add `cluster' match support
296   - extensions: add const qualifiers in print/save functions
297   - extensions: use NFPROTO_UNSPEC for .family field
298   - extensions: remove redundant casts
299   - iptables: close open file descriptors
300   - fix segfault if incorrect protocol name is used
301   - replace open-coded sizeof by ARRAY_SIZE
302   - do not include v4-only modules in ip6tables manpage
303   - use direct xt_policy_info instead of ipt/ip6t
304   - xtables: fix segfault if incorrect protocol name is used
305   - libxt_connlimit: initialize v6_mask
306   - SNAT/DNAT: add support for persistent multi-range NAT mappings
307
308 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
309 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
310
311 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
312 - new version 1.4.3.2
313 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
314
315 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
316 - new version 1.4.3.1
317   - libiptc is now shared
318   - supports all new features of the 2.6.29 kernel
319 - dropped typo_latter patch
320
321 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
322 - still more review fixes (rhbz#225906)
323   - consistent macro usage
324   - use sed instead of perl for rpath removal
325   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
326
327 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
328 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
329
330 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
331 - new version 1.4.2
332 - removed TOS value mask patch (upstream)
333 - more review fixes (rhbz#225906)
334 - install all header files (rhbz#462207)
335 - dropped nf_ext_init (rhbz#472548)
336
337 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
338 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
339 - two more cloexec fixes
340
341 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
342 - upstream bug fix release 1.4.1.1
343 - dropped extra patch for 1.4.1 - not needed anymore
344
345 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
346 - new version 1.4.1 with new build environment
347 - additional ipv6 network mask patch from Jan Engelhardt
348 - spec file cleanup
349 - removed old patches
350
351 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
352 - use normal kernel headers, not linux/compiler.h
353 - change BuildRequires: kernel-devel to kernel-headers
354 - We need to do this to be able to build for both sparcv9 and sparc64 
355   (there is no kernel-devel.sparcv9)
356
357 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
358 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
359
360 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
361 - use the kernel headers from the build tree for iptables for now to be able to 
362   compile this package, but this makes the package more kernel dependant
363 - use s6_addr32 instead of in6_u.u6_addr32
364
365 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
366 - Autorebuild for GCC 4.3
367
368 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
369 - new version 1.4.0
370 - fixed condrestart (rhbz#428148)
371 - report the module in rmmod_r if there is an error
372 - use nf_ext_init instead of my_init for extension constructors
373
374 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
375 - fixed leaked file descriptor before fork/exec (rhbz#312191)
376 - blacklisting is not working, use "install X /bin/(true|false)" test instead
377 - return private exit code 150 for disabled ipv6 support
378 - use script name for output messages
379
380 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
381 - fixed error code for stopping a already stopped firewall (rhbz#321751)
382 - moved blacklist test into start
383
384 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
385 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
386 - use simpler fix for (rhbz#295611)
387   Thanks to Linus Torvalds for the patch.
388
389 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
390 - fixed IPv6 reject type (rhbz#295181)
391 - fixed init script: start, stop and status
392 - support netfilter compiled into kernel in init script (rhbz#295611)
393 - dropped inversion for limit modules from man pages (rhbz#220780)
394 - fixed typo in ip6tables man page (rhbz#236185)
395
396 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
397 - do not depend on local_fs in lsb header - this delayes start after network
398 - fixed exit code for initscript usage
399
400 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
401 - do not use lock file for condrestart test
402
403 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
404 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
405 - provide iptc interface again, but unsupported (rhbz#216733)
406 - compile all extension, which are supported by the kernel-headers package
407 - review fixes (rhbz#225906)
408
409 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
410 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
411
412 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
413 - New version 1.3.8
414
415 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
416 - fix error when ipv6 support isn't loaded in the kernel (#236888)
417
418 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
419 - fixed installation of secmark modules
420
421 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
422 - new verison 1.3.7
423 - iptc is not a public interface and therefore not installed anymore
424 - dropped upstream secmark patch
425
426 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
427 - added secmark iptables patches (#201573)
428
429 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
430 - rebuild
431
432 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
433 - bump again for double-long bug on ppc(64)
434
435 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
436 - rebuilt for new gcc4.1 snapshot and glibc changes
437
438 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
439 - new version 1.3.5
440 - fixed init script to set policy for raw tables, too (#179094)
441
442 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
443 - added important iptables header files to devel package
444
445 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
446 - rebuilt
447
448 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
449 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
450   replace "_init" with "__attribute((constructor)) my_init"
451
452 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
453 - rebuild due to unresolved symbols in shared libraries
454
455 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
456 - new version 1.3.4
457 - dropped free_opts patch (upstream fixed)
458 - made libipq PIC (#158623)
459 - additional configuration options for iptables startup script (#172929)
460   Thanks to Jan Gruenwald for the patch
461 - spec file cleanup (dropped linux_header define and usage)
462
463 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
464 - new version 1.3.2 with additional patch for the misplaced free_opts call
465   from Marcus Sundberg
466
467 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
468 - new version 1.3.1
469
470 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
471 - Remove unnecessary explicit kernel dep (#146142)
472 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
473   for the patch
474 - Adapted iptables-config to reference to modprobe.conf (#150143)
475 - Remove misleading message (#140154): Thanks to Ulrich Drepper
476   for the patch
477
478 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
479 - new version 1.3.0
480
481 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
482 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
483
484 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
485 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
486 - modified config file to match this change and un-commented variables with
487   default values
488
489 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
490 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
491   for the patch
492
493 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
494 - fixed free bug in iptables (#128322)
495
496 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
497 - new version 1.2.11
498
499 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
500 - new version 1.2.10
501
502 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
503 - rebuilt
504
505 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
506 - rebuilt
507
508 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
509 - fixed iptables-restore -c fault if there are no counters (#116421)
510
511 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
512 - rebuilt
513
514 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
515 - Close File descriptors to prevent SELinux error message
516
517 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
518 - rebuild
519
520 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
521 - vew version 1.2.9
522 - new config options in ipXtables-config:
523   IPTABLES_MODULES_UNLOAD
524 - more documentation in ipXtables-config
525 - fix for netlink security issue in libipq (devel package)
526 - print fix for libipt_icmp (#109546)
527
528 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
529 - marked all messages in iptables init script for translation (#107462)
530 - enabled devel package (#105884, #106101)
531 - bumped build for fedora for libipt_recent.so (#106002)
532
533 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
534 - fixed lost udp port range in ip6tables-save (#104484)
535 - fixed non numeric multiport port output in ipXtables-savs
536
537 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
538 - do not link against -lnsl
539
540 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
541 - made variables in rmmod_r local
542
543 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
544 - fixed permission for init script
545
546 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
547 - fixed save when iptables file is missing and iptables-config permissions
548
549 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
550 - fixes for ip6tables: module unloading, setting policy only for existing 
551   tables
552
553 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
554 - IPTABLES_SAVE_COUNTER defaults to no, now
555 - install config file in /etc/sysconfig
556 - exchange unload of ip_tables and ip_conntrack
557 - fixed start function
558
559 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
560 - new config option IPTABLES_SAVE_ON_RESTART
561 - init script: new status, save and restart
562 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
563
564 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
565 - new config option IPTABLES_STATUS_NUMERIC
566 - cleared IPTABLES_MODULES in iptables-config
567
568 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
569 - new init scripts
570
571 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
572 - remove check for very old kernel versions in init scripts
573 - sync up both init scripts and remove some further ugly things
574 - add some docu into rpm
575
576 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
577 - rebuild
578
579 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
580 - update to 1.2.8
581
582 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
583 - rebuilt
584
585 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
586 - update to 1.2.7a
587 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
588
589 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
590 - Fix multilib
591
592 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
593 - fixed iptables and ip6tables initscript output, based on #70511
594 - check return status of all iptables calls, not just the last one
595   in a 'for' loop.
596
597 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
598 - 1.2.6a (bugfix release, #69747)
599
600 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
601 - automated rebuild
602
603 * Thu May 23 2002 Tim Powers <timp@redhat.com>
604 - automated rebuild
605
606 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
607 - Add some fixes from CVS, fixing bug #60465
608
609 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
610 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
611   #59402
612 - Update URL (#59354)
613 - Use /sbin/chkconfig rather than chkconfig in %%postun script
614
615 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
616 - 1.2.5
617
618 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
619 - automated rebuild
620
621 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
622 - Fix %%preun script
623
624 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
625 - Update to 1.2.4 (various fixes, including security fixes; among others:
626   #42990, #50500, #53325, #54280)
627 - Fix init script (#31133)
628
629 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
630 - 1.2.3 (5 security fixes, some other fixes)
631 - Fix updating (#53032)
632
633 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
634 - Fix #50990
635 - Add some fixes from current CVS; should fix #52620
636
637 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
638 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
639   issues
640
641 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
642 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
643   <mschwendt@yahoo.com>
644
645 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
646 - 1.2.2
647
648 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
649 - 1.2.1a, fixes #28412, #31136, #31460, #31133
650
651 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
652 - Yet another initscript fix (#30173)
653 - Fix the fixes; they fixed some issues but broke more important
654   stuff :/ (#30176)
655
656 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
657 - Fix up initscript (#27962)
658 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
659
660 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
661 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
662
663 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
664 - fix bugzilla #25986 (initscript not marked as config file)
665 - fix bugzilla #25962 (iptables-restore)
666 - mv chkconfig --del from postun to preun
667
668 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
669 - Fix check for ipchains
670
671 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
672 - Some fixes to init scripts
673
674 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
675 - Add some fixes from CVS, fixes among other things Bug #24732
676
677 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
678 - Add missing man pages, fix up init script (Bug #17676)
679
680 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
681 - add init script
682
683 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
684 - 1.2
685 - fix up ipv6 split
686 - add init script
687 - Move the plugins from /usr/lib/iptables to /lib/iptables.
688   This needs to work before /usr is mounted...
689 - Use -O1 on alpha (compiler bug)
690
691 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
692 - 1.1.2
693 - Add IPv6 support (in separate package)
694
695 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
696 - build everywhere
697
698 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
699 - 1.1.1
700
701 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
702 - automatic rebuild
703
704 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
705 - move iptables to /sbin.
706 - excludearch alpha for now, not building there because of compiler bug(?)
707
708 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
709 - don't obsolete ipchains either
710 - update to 1.1.0
711
712 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
713 - remove explicit kernel requirement
714
715 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
716 - initial package