error: Duplicate Url entries in package
[iptables.git] / iptables.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name iptables
7 %define version 1.4.7
8 %define taglevel 1
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: Tools for managing Linux kernel packet filtering capabilities
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
22 Source1: iptables.init
23 Source2: iptables-config
24 Source3: planetlab-config
25 Patch1: copy-xid.patch
26 Group: System Environment/Base
27 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28 License: GPLv2
29 BuildRequires: libselinux-devel
30 BuildRequires: kernel-headers
31 Conflicts: kernel < 2.4.20
32 Requires(post): chkconfig
33 Requires(preun): chkconfig
34
35 %description
36 The iptables utility controls the network packet filtering code in the
37 Linux kernel. If you need to set up firewalls and/or IP masquerading,
38 you should install this package.
39
40 %package ipv6
41 Summary: IPv6 support for iptables
42 Group: System Environment/Base
43 Requires: %{name} = %{version}-%{release}
44 Requires(post): chkconfig
45 Requires(preun): chkconfig
46
47 %description ipv6
48 The iptables package contains IPv6 (the next version of the IP
49 protocol) support for iptables. Iptables controls the Linux kernel
50 network packet filtering code, allowing you to set up firewalls and IP
51 masquerading. 
52
53 Install iptables-ipv6 if you need to set up firewalling for your
54 network and you are using ipv6.
55
56 %package devel
57 Summary: Development package for iptables
58 Group: System Environment/Base
59 Requires: %{name} = %{version}-%{release}
60 Requires: pkgconfig
61
62 %description devel
63 iptables development headers and libraries.
64
65 The iptc interface is upstream marked as not public. The interface is not 
66 stable and may change with every new version. It is therefore unsupported.
67
68 %prep
69 %setup -q
70 %patch1 -p1 
71
72 %build
73 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
74 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
75
76 # do not use rpath
77 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
78 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
79
80 make
81
82 %install
83 rm -rf %{buildroot}
84
85 make install DESTDIR=%{buildroot} 
86 # remove la file(s)
87 rm -f %{buildroot}/%{_lib}/*.la
88
89 # install ip*tables.h header files
90 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
91 install -d -m 755 %{buildroot}%{_includedir}/iptables
92 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
93
94 # install ipulog header file
95 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
96 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
97
98 # create symlinks for devel so libs
99 install -d -m 755 %{buildroot}%{_libdir}
100 for i in %{buildroot}/%{_lib}/*.so; do
101     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
102 done
103
104 # move pkgconfig to %{_libdir}
105 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
106
107 # install init scripts and configuration files
108 install -d -m 755 %{buildroot}/etc/rc.d/init.d
109 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
110 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
111 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
112 install -d -m 755 %{buildroot}/etc/sysconfig
113 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
114 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
115 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
116 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
117
118 %clean
119 rm -rf %{buildroot}
120
121 %post
122 /sbin/ldconfig
123 /sbin/chkconfig --add iptables
124
125 %postun -p /sbin/ldconfig
126
127 %preun
128 if [ "$1" = 0 ]; then
129         /sbin/chkconfig --del iptables
130 fi
131
132 %post ipv6
133 /sbin/chkconfig --add ip6tables
134
135 %preun ipv6
136 if [ "$1" = 0 ]; then
137         /sbin/chkconfig --del ip6tables
138 fi
139
140 %files
141 %defattr(-,root,root)
142 %doc COPYING INSTALL INCOMPATIBILITIES
143 %attr(0755,root,root) /etc/rc.d/init.d/iptables
144 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
145 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
146 /sbin/iptables*
147 /bin/iptables-xml
148 %{_mandir}/man8/iptables*
149 %dir /%{_lib}/xtables
150 /%{_lib}/xtables/libipt*
151 /%{_lib}/xtables/libxt*
152 /%{_lib}/libip*tc.so.*
153 /%{_lib}/libipq.so.*
154 /%{_lib}/libxtables.so.*
155
156 %files ipv6
157 %defattr(-,root,root)
158 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
159 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
160 /sbin/ip6tables*
161 %{_mandir}/man8/ip6tables*
162 /%{_lib}/xtables/libip6t*
163
164 %files devel
165 %defattr(-,root,root)
166 %dir %{_includedir}/iptables
167 %{_includedir}/iptables/*.h
168 %{_includedir}/*.h
169 %dir %{_includedir}/libiptc
170 %{_includedir}/libiptc/*.h
171 %dir %{_includedir}/libipulog
172 %{_includedir}/libipulog/*.h
173 %{_mandir}/man3/*
174 /%{_lib}/libip*tc.so
175 /%{_lib}/libipq.so
176 /%{_lib}/libxtables.so
177 %{_libdir}/libip*tc.so
178 %{_libdir}/libipq.so
179 %{_libdir}/libxtables.so
180 %{_libdir}/pkgconfig/libiptc.pc
181 %{_libdir}/pkgconfig/xtables.pc
182
183 %changelog
184 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
185 - added default values for IPTABLES_STATUS_VERBOSE and
186   IPTABLES_STATUS_LINENUMBERS in init script
187 - added missing lsb keywords Required-Start and Required-Stop to init script
188
189 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
190 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
191   - libip4tc: Add static qualifier to dump_entry()
192   - libipq: build as shared library
193   - recent: reorder cases in code (cosmetic cleanup)
194   - several man page and documentation fixes
195   - policy: fix error message showing wrong option
196   - includes: header updates
197   - Lift restrictions on interface names
198 - fixed license and moved iptables-xml into base package according to review
199
200 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
201 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
202   to /usr/lib[64] for compatibility (rhbz#558796)
203
204 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
205 - new version 1.4.6 with support for all new features of 2.6.32
206   - several man page fixes
207   - Support for nommu arches
208   - realm: remove static initializations
209   - libiptc: remove unused functions
210   - libiptc: avoid strict-aliasing warnings
211   - iprange: do accept non-ranges for xt_iprange v1
212   - iprange: warn on reverse range
213   - iprange: roll address parsing into a loop
214   - iprange: do accept non-ranges for xt_iprange v1 (log)
215   - iprange: warn on reverse range (log)
216   - libiptc: fix wrong maptype of base chain counters on restore
217   - iptables: fix undersized deletion mask creation
218   - style: reduce indent in xtables_check_inverse
219   - libxtables: hand argv to xtables_check_inverse
220   - iptables/extensions: make bundled options work again
221   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
222   - iptables: take masks into consideration for replace command
223   - doc: explain experienced --hitcount limit
224   - doc: name resolution clarification
225   - iptables: expose option to zero packet/byte counters for a specific rule
226   - build: restore --disable-ipv6 functionality on system w/o v6 headers
227   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
228   - DNAT: fix incorrect check during parsing
229   - extensions: add osf extension
230   - conntrack: fix --expires parsing
231
232 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
233 - dropped nf_ext_init remains from cloexec patch
234
235 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
236 - new version 1.4.5 with support for all new features of 2.6.31
237   - libxt_NFQUEUE: add new v1 version with queue-balance option
238   - xt_conntrack: revision 2 for enlarged state_mask member
239   - libxt_helper: fix invalid passed option to check_inverse
240   - libiptc: split v4 and v6
241   - extensions: collapse registration structures
242   - iptables: allow for parse-less extensions
243   - iptables: allow for help-less extensions
244   - extensions: remove empty help and parse functions
245   - xtables: add multi-registration functions
246   - extensions: collapse data variables to use multi-reg calls
247   - xtables: warn of missing version identifier in extensions
248   - multi binary: allow subcommand via argv[1]
249   - iptables: accept multiple IP address specifications for -s, -d
250   - several build fixes
251   - several man page fixes
252 - fixed two leaked file descriptors on sockets (rhbz#521397)
253
254 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
255 - new version 1.4.4 with support for all new features of 2.6.30
256   - several man page fixes
257   - iptables: replace open-coded sizeof by ARRAY_SIZE
258   - libip6t_policy: remove redundant functions
259   - policy: use direct xt_policy_info instead of ipt/ip6t
260   - policy: merge ipv6 and ipv4 variant
261   - extensions: add `cluster' match support
262   - extensions: add const qualifiers in print/save functions
263   - extensions: use NFPROTO_UNSPEC for .family field
264   - extensions: remove redundant casts
265   - iptables: close open file descriptors
266   - fix segfault if incorrect protocol name is used
267   - replace open-coded sizeof by ARRAY_SIZE
268   - do not include v4-only modules in ip6tables manpage
269   - use direct xt_policy_info instead of ipt/ip6t
270   - xtables: fix segfault if incorrect protocol name is used
271   - libxt_connlimit: initialize v6_mask
272   - SNAT/DNAT: add support for persistent multi-range NAT mappings
273
274 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
275 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
276
277 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
278 - new version 1.4.3.2
279 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
280
281 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
282 - new version 1.4.3.1
283   - libiptc is now shared
284   - supports all new features of the 2.6.29 kernel
285 - dropped typo_latter patch
286
287 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
288 - still more review fixes (rhbz#225906)
289   - consistent macro usage
290   - use sed instead of perl for rpath removal
291   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
292
293 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
294 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
295
296 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
297 - new version 1.4.2
298 - removed TOS value mask patch (upstream)
299 - more review fixes (rhbz#225906)
300 - install all header files (rhbz#462207)
301 - dropped nf_ext_init (rhbz#472548)
302
303 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
304 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
305 - two more cloexec fixes
306
307 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
308 - upstream bug fix release 1.4.1.1
309 - dropped extra patch for 1.4.1 - not needed anymore
310
311 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
312 - new version 1.4.1 with new build environment
313 - additional ipv6 network mask patch from Jan Engelhardt
314 - spec file cleanup
315 - removed old patches
316
317 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
318 - use normal kernel headers, not linux/compiler.h
319 - change BuildRequires: kernel-devel to kernel-headers
320 - We need to do this to be able to build for both sparcv9 and sparc64 
321   (there is no kernel-devel.sparcv9)
322
323 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
324 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
325
326 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
327 - use the kernel headers from the build tree for iptables for now to be able to 
328   compile this package, but this makes the package more kernel dependant
329 - use s6_addr32 instead of in6_u.u6_addr32
330
331 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
332 - Autorebuild for GCC 4.3
333
334 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
335 - new version 1.4.0
336 - fixed condrestart (rhbz#428148)
337 - report the module in rmmod_r if there is an error
338 - use nf_ext_init instead of my_init for extension constructors
339
340 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
341 - fixed leaked file descriptor before fork/exec (rhbz#312191)
342 - blacklisting is not working, use "install X /bin/(true|false)" test instead
343 - return private exit code 150 for disabled ipv6 support
344 - use script name for output messages
345
346 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
347 - fixed error code for stopping a already stopped firewall (rhbz#321751)
348 - moved blacklist test into start
349
350 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
351 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
352 - use simpler fix for (rhbz#295611)
353   Thanks to Linus Torvalds for the patch.
354
355 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
356 - fixed IPv6 reject type (rhbz#295181)
357 - fixed init script: start, stop and status
358 - support netfilter compiled into kernel in init script (rhbz#295611)
359 - dropped inversion for limit modules from man pages (rhbz#220780)
360 - fixed typo in ip6tables man page (rhbz#236185)
361
362 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
363 - do not depend on local_fs in lsb header - this delayes start after network
364 - fixed exit code for initscript usage
365
366 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
367 - do not use lock file for condrestart test
368
369 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
370 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
371 - provide iptc interface again, but unsupported (rhbz#216733)
372 - compile all extension, which are supported by the kernel-headers package
373 - review fixes (rhbz#225906)
374
375 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
376 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
377
378 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
379 - New version 1.3.8
380
381 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
382 - fix error when ipv6 support isn't loaded in the kernel (#236888)
383
384 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
385 - fixed installation of secmark modules
386
387 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
388 - new verison 1.3.7
389 - iptc is not a public interface and therefore not installed anymore
390 - dropped upstream secmark patch
391
392 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
393 - added secmark iptables patches (#201573)
394
395 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
396 - rebuild
397
398 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
399 - bump again for double-long bug on ppc(64)
400
401 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
402 - rebuilt for new gcc4.1 snapshot and glibc changes
403
404 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
405 - new version 1.3.5
406 - fixed init script to set policy for raw tables, too (#179094)
407
408 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
409 - added important iptables header files to devel package
410
411 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
412 - rebuilt
413
414 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
415 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
416   replace "_init" with "__attribute((constructor)) my_init"
417
418 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
419 - rebuild due to unresolved symbols in shared libraries
420
421 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
422 - new version 1.3.4
423 - dropped free_opts patch (upstream fixed)
424 - made libipq PIC (#158623)
425 - additional configuration options for iptables startup script (#172929)
426   Thanks to Jan Gruenwald for the patch
427 - spec file cleanup (dropped linux_header define and usage)
428
429 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
430 - new version 1.3.2 with additional patch for the misplaced free_opts call
431   from Marcus Sundberg
432
433 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
434 - new version 1.3.1
435
436 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
437 - Remove unnecessary explicit kernel dep (#146142)
438 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
439   for the patch
440 - Adapted iptables-config to reference to modprobe.conf (#150143)
441 - Remove misleading message (#140154): Thanks to Ulrich Drepper
442   for the patch
443
444 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
445 - new version 1.3.0
446
447 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
448 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
449
450 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
451 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
452 - modified config file to match this change and un-commented variables with
453   default values
454
455 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
456 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
457   for the patch
458
459 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
460 - fixed free bug in iptables (#128322)
461
462 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
463 - new version 1.2.11
464
465 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
466 - new version 1.2.10
467
468 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
469 - rebuilt
470
471 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
472 - rebuilt
473
474 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
475 - fixed iptables-restore -c fault if there are no counters (#116421)
476
477 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
478 - rebuilt
479
480 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
481 - Close File descriptors to prevent SELinux error message
482
483 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
484 - rebuild
485
486 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
487 - vew version 1.2.9
488 - new config options in ipXtables-config:
489   IPTABLES_MODULES_UNLOAD
490 - more documentation in ipXtables-config
491 - fix for netlink security issue in libipq (devel package)
492 - print fix for libipt_icmp (#109546)
493
494 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
495 - marked all messages in iptables init script for translation (#107462)
496 - enabled devel package (#105884, #106101)
497 - bumped build for fedora for libipt_recent.so (#106002)
498
499 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
500 - fixed lost udp port range in ip6tables-save (#104484)
501 - fixed non numeric multiport port output in ipXtables-savs
502
503 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
504 - do not link against -lnsl
505
506 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
507 - made variables in rmmod_r local
508
509 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
510 - fixed permission for init script
511
512 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
513 - fixed save when iptables file is missing and iptables-config permissions
514
515 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
516 - fixes for ip6tables: module unloading, setting policy only for existing 
517   tables
518
519 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
520 - IPTABLES_SAVE_COUNTER defaults to no, now
521 - install config file in /etc/sysconfig
522 - exchange unload of ip_tables and ip_conntrack
523 - fixed start function
524
525 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
526 - new config option IPTABLES_SAVE_ON_RESTART
527 - init script: new status, save and restart
528 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
529
530 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
531 - new config option IPTABLES_STATUS_NUMERIC
532 - cleared IPTABLES_MODULES in iptables-config
533
534 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
535 - new init scripts
536
537 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
538 - remove check for very old kernel versions in init scripts
539 - sync up both init scripts and remove some further ugly things
540 - add some docu into rpm
541
542 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
543 - rebuild
544
545 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
546 - update to 1.2.8
547
548 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
549 - rebuilt
550
551 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
552 - update to 1.2.7a
553 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
554
555 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
556 - Fix multilib
557
558 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
559 - fixed iptables and ip6tables initscript output, based on #70511
560 - check return status of all iptables calls, not just the last one
561   in a 'for' loop.
562
563 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
564 - 1.2.6a (bugfix release, #69747)
565
566 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
567 - automated rebuild
568
569 * Thu May 23 2002 Tim Powers <timp@redhat.com>
570 - automated rebuild
571
572 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
573 - Add some fixes from CVS, fixing bug #60465
574
575 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
576 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
577   #59402
578 - Update URL (#59354)
579 - Use /sbin/chkconfig rather than chkconfig in %%postun script
580
581 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
582 - 1.2.5
583
584 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
585 - automated rebuild
586
587 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
588 - Fix %%preun script
589
590 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
591 - Update to 1.2.4 (various fixes, including security fixes; among others:
592   #42990, #50500, #53325, #54280)
593 - Fix init script (#31133)
594
595 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
596 - 1.2.3 (5 security fixes, some other fixes)
597 - Fix updating (#53032)
598
599 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
600 - Fix #50990
601 - Add some fixes from current CVS; should fix #52620
602
603 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
604 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
605   issues
606
607 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
608 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
609   <mschwendt@yahoo.com>
610
611 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
612 - 1.2.2
613
614 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
615 - 1.2.1a, fixes #28412, #31136, #31460, #31133
616
617 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
618 - Yet another initscript fix (#30173)
619 - Fix the fixes; they fixed some issues but broke more important
620   stuff :/ (#30176)
621
622 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
623 - Fix up initscript (#27962)
624 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
625
626 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
627 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
628
629 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
630 - fix bugzilla #25986 (initscript not marked as config file)
631 - fix bugzilla #25962 (iptables-restore)
632 - mv chkconfig --del from postun to preun
633
634 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
635 - Fix check for ipchains
636
637 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
638 - Some fixes to init scripts
639
640 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
641 - Add some fixes from CVS, fixes among other things Bug #24732
642
643 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
644 - Add missing man pages, fix up init script (Bug #17676)
645
646 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
647 - add init script
648
649 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
650 - 1.2
651 - fix up ipv6 split
652 - add init script
653 - Move the plugins from /usr/lib/iptables to /lib/iptables.
654   This needs to work before /usr is mounted...
655 - Use -O1 on alpha (compiler bug)
656
657 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
658 - 1.1.2
659 - Add IPv6 support (in separate package)
660
661 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
662 - build everywhere
663
664 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
665 - 1.1.1
666
667 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
668 - automatic rebuild
669
670 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
671 - move iptables to /sbin.
672 - excludearch alpha for now, not building there because of compiler bug(?)
673
674 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
675 - don't obsolete ipchains either
676 - update to 1.1.0
677
678 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
679 - remove explicit kernel requirement
680
681 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
682 - initial package