decorations for module tools, + set svn-keywords on older branches
[iptables.git] / iptables.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name iptables
7 %define version 1.4.7
8 %define taglevel 1
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: Tools for managing Linux kernel packet filtering capabilities
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
22 Source1: iptables.init
23 Source2: iptables-config
24 Source3: planetlab-config
25 Patch1: copy-xid.patch
26 Group: System Environment/Base
27 URL: http://www.netfilter.org/
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29 License: GPLv2
30 BuildRequires: libselinux-devel
31 BuildRequires: kernel-headers
32 Conflicts: kernel < 2.4.20
33 Requires(post): chkconfig
34 Requires(preun): chkconfig
35
36 %description
37 The iptables utility controls the network packet filtering code in the
38 Linux kernel. If you need to set up firewalls and/or IP masquerading,
39 you should install this package.
40
41 %package ipv6
42 Summary: IPv6 support for iptables
43 Group: System Environment/Base
44 Requires: %{name} = %{version}-%{release}
45 Requires(post): chkconfig
46 Requires(preun): chkconfig
47
48 %description ipv6
49 The iptables package contains IPv6 (the next version of the IP
50 protocol) support for iptables. Iptables controls the Linux kernel
51 network packet filtering code, allowing you to set up firewalls and IP
52 masquerading. 
53
54 Install iptables-ipv6 if you need to set up firewalling for your
55 network and you are using ipv6.
56
57 %package devel
58 Summary: Development package for iptables
59 Group: System Environment/Base
60 Requires: %{name} = %{version}-%{release}
61 Requires: pkgconfig
62
63 %description devel
64 iptables development headers and libraries.
65
66 The iptc interface is upstream marked as not public. The interface is not 
67 stable and may change with every new version. It is therefore unsupported.
68
69 %prep
70 %setup -q
71 %patch1 -p1 
72
73 %build
74 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
75 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
76
77 # do not use rpath
78 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
79 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
80
81 make
82
83 %install
84 rm -rf %{buildroot}
85
86 make install DESTDIR=%{buildroot} 
87 # remove la file(s)
88 rm -f %{buildroot}/%{_lib}/*.la
89
90 # install ip*tables.h header files
91 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
92 install -d -m 755 %{buildroot}%{_includedir}/iptables
93 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
94
95 # install ipulog header file
96 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
97 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
98
99 # create symlinks for devel so libs
100 install -d -m 755 %{buildroot}%{_libdir}
101 for i in %{buildroot}/%{_lib}/*.so; do
102     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
103 done
104
105 # move pkgconfig to %{_libdir}
106 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
107
108 # install init scripts and configuration files
109 install -d -m 755 %{buildroot}/etc/rc.d/init.d
110 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
111 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
112 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
113 install -d -m 755 %{buildroot}/etc/sysconfig
114 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
115 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
116 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
117 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
118
119 %clean
120 rm -rf %{buildroot}
121
122 %post
123 /sbin/ldconfig
124 /sbin/chkconfig --add iptables
125
126 %postun -p /sbin/ldconfig
127
128 %preun
129 if [ "$1" = 0 ]; then
130         /sbin/chkconfig --del iptables
131 fi
132
133 %post ipv6
134 /sbin/chkconfig --add ip6tables
135
136 %preun ipv6
137 if [ "$1" = 0 ]; then
138         /sbin/chkconfig --del ip6tables
139 fi
140
141 %files
142 %defattr(-,root,root)
143 %doc COPYING INSTALL INCOMPATIBILITIES
144 %attr(0755,root,root) /etc/rc.d/init.d/iptables
145 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
146 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
147 /sbin/iptables*
148 /bin/iptables-xml
149 %{_mandir}/man8/iptables*
150 %dir /%{_lib}/xtables
151 /%{_lib}/xtables/libipt*
152 /%{_lib}/xtables/libxt*
153 /%{_lib}/libip*tc.so.*
154 /%{_lib}/libipq.so.*
155 /%{_lib}/libxtables.so.*
156
157 %files ipv6
158 %defattr(-,root,root)
159 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
160 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
161 /sbin/ip6tables*
162 %{_mandir}/man8/ip6tables*
163 /%{_lib}/xtables/libip6t*
164
165 %files devel
166 %defattr(-,root,root)
167 %dir %{_includedir}/iptables
168 %{_includedir}/iptables/*.h
169 %{_includedir}/*.h
170 %dir %{_includedir}/libiptc
171 %{_includedir}/libiptc/*.h
172 %dir %{_includedir}/libipulog
173 %{_includedir}/libipulog/*.h
174 %{_mandir}/man3/*
175 /%{_lib}/libip*tc.so
176 /%{_lib}/libipq.so
177 /%{_lib}/libxtables.so
178 %{_libdir}/libip*tc.so
179 %{_libdir}/libipq.so
180 %{_libdir}/libxtables.so
181 %{_libdir}/pkgconfig/libiptc.pc
182 %{_libdir}/pkgconfig/xtables.pc
183
184 %changelog
185 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
186 - added default values for IPTABLES_STATUS_VERBOSE and
187   IPTABLES_STATUS_LINENUMBERS in init script
188 - added missing lsb keywords Required-Start and Required-Stop to init script
189
190 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
191 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
192   - libip4tc: Add static qualifier to dump_entry()
193   - libipq: build as shared library
194   - recent: reorder cases in code (cosmetic cleanup)
195   - several man page and documentation fixes
196   - policy: fix error message showing wrong option
197   - includes: header updates
198   - Lift restrictions on interface names
199 - fixed license and moved iptables-xml into base package according to review
200
201 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
202 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
203   to /usr/lib[64] for compatibility (rhbz#558796)
204
205 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
206 - new version 1.4.6 with support for all new features of 2.6.32
207   - several man page fixes
208   - Support for nommu arches
209   - realm: remove static initializations
210   - libiptc: remove unused functions
211   - libiptc: avoid strict-aliasing warnings
212   - iprange: do accept non-ranges for xt_iprange v1
213   - iprange: warn on reverse range
214   - iprange: roll address parsing into a loop
215   - iprange: do accept non-ranges for xt_iprange v1 (log)
216   - iprange: warn on reverse range (log)
217   - libiptc: fix wrong maptype of base chain counters on restore
218   - iptables: fix undersized deletion mask creation
219   - style: reduce indent in xtables_check_inverse
220   - libxtables: hand argv to xtables_check_inverse
221   - iptables/extensions: make bundled options work again
222   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
223   - iptables: take masks into consideration for replace command
224   - doc: explain experienced --hitcount limit
225   - doc: name resolution clarification
226   - iptables: expose option to zero packet/byte counters for a specific rule
227   - build: restore --disable-ipv6 functionality on system w/o v6 headers
228   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
229   - DNAT: fix incorrect check during parsing
230   - extensions: add osf extension
231   - conntrack: fix --expires parsing
232
233 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
234 - dropped nf_ext_init remains from cloexec patch
235
236 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
237 - new version 1.4.5 with support for all new features of 2.6.31
238   - libxt_NFQUEUE: add new v1 version with queue-balance option
239   - xt_conntrack: revision 2 for enlarged state_mask member
240   - libxt_helper: fix invalid passed option to check_inverse
241   - libiptc: split v4 and v6
242   - extensions: collapse registration structures
243   - iptables: allow for parse-less extensions
244   - iptables: allow for help-less extensions
245   - extensions: remove empty help and parse functions
246   - xtables: add multi-registration functions
247   - extensions: collapse data variables to use multi-reg calls
248   - xtables: warn of missing version identifier in extensions
249   - multi binary: allow subcommand via argv[1]
250   - iptables: accept multiple IP address specifications for -s, -d
251   - several build fixes
252   - several man page fixes
253 - fixed two leaked file descriptors on sockets (rhbz#521397)
254
255 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
256 - new version 1.4.4 with support for all new features of 2.6.30
257   - several man page fixes
258   - iptables: replace open-coded sizeof by ARRAY_SIZE
259   - libip6t_policy: remove redundant functions
260   - policy: use direct xt_policy_info instead of ipt/ip6t
261   - policy: merge ipv6 and ipv4 variant
262   - extensions: add `cluster' match support
263   - extensions: add const qualifiers in print/save functions
264   - extensions: use NFPROTO_UNSPEC for .family field
265   - extensions: remove redundant casts
266   - iptables: close open file descriptors
267   - fix segfault if incorrect protocol name is used
268   - replace open-coded sizeof by ARRAY_SIZE
269   - do not include v4-only modules in ip6tables manpage
270   - use direct xt_policy_info instead of ipt/ip6t
271   - xtables: fix segfault if incorrect protocol name is used
272   - libxt_connlimit: initialize v6_mask
273   - SNAT/DNAT: add support for persistent multi-range NAT mappings
274
275 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
276 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
277
278 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
279 - new version 1.4.3.2
280 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
281
282 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
283 - new version 1.4.3.1
284   - libiptc is now shared
285   - supports all new features of the 2.6.29 kernel
286 - dropped typo_latter patch
287
288 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
289 - still more review fixes (rhbz#225906)
290   - consistent macro usage
291   - use sed instead of perl for rpath removal
292   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
293
294 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
295 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
296
297 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
298 - new version 1.4.2
299 - removed TOS value mask patch (upstream)
300 - more review fixes (rhbz#225906)
301 - install all header files (rhbz#462207)
302 - dropped nf_ext_init (rhbz#472548)
303
304 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
305 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
306 - two more cloexec fixes
307
308 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
309 - upstream bug fix release 1.4.1.1
310 - dropped extra patch for 1.4.1 - not needed anymore
311
312 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
313 - new version 1.4.1 with new build environment
314 - additional ipv6 network mask patch from Jan Engelhardt
315 - spec file cleanup
316 - removed old patches
317
318 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
319 - use normal kernel headers, not linux/compiler.h
320 - change BuildRequires: kernel-devel to kernel-headers
321 - We need to do this to be able to build for both sparcv9 and sparc64 
322   (there is no kernel-devel.sparcv9)
323
324 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
325 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
326
327 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
328 - use the kernel headers from the build tree for iptables for now to be able to 
329   compile this package, but this makes the package more kernel dependant
330 - use s6_addr32 instead of in6_u.u6_addr32
331
332 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
333 - Autorebuild for GCC 4.3
334
335 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
336 - new version 1.4.0
337 - fixed condrestart (rhbz#428148)
338 - report the module in rmmod_r if there is an error
339 - use nf_ext_init instead of my_init for extension constructors
340
341 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
342 - fixed leaked file descriptor before fork/exec (rhbz#312191)
343 - blacklisting is not working, use "install X /bin/(true|false)" test instead
344 - return private exit code 150 for disabled ipv6 support
345 - use script name for output messages
346
347 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
348 - fixed error code for stopping a already stopped firewall (rhbz#321751)
349 - moved blacklist test into start
350
351 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
352 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
353 - use simpler fix for (rhbz#295611)
354   Thanks to Linus Torvalds for the patch.
355
356 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
357 - fixed IPv6 reject type (rhbz#295181)
358 - fixed init script: start, stop and status
359 - support netfilter compiled into kernel in init script (rhbz#295611)
360 - dropped inversion for limit modules from man pages (rhbz#220780)
361 - fixed typo in ip6tables man page (rhbz#236185)
362
363 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
364 - do not depend on local_fs in lsb header - this delayes start after network
365 - fixed exit code for initscript usage
366
367 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
368 - do not use lock file for condrestart test
369
370 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
371 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
372 - provide iptc interface again, but unsupported (rhbz#216733)
373 - compile all extension, which are supported by the kernel-headers package
374 - review fixes (rhbz#225906)
375
376 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
377 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
378
379 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
380 - New version 1.3.8
381
382 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
383 - fix error when ipv6 support isn't loaded in the kernel (#236888)
384
385 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
386 - fixed installation of secmark modules
387
388 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
389 - new verison 1.3.7
390 - iptc is not a public interface and therefore not installed anymore
391 - dropped upstream secmark patch
392
393 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
394 - added secmark iptables patches (#201573)
395
396 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
397 - rebuild
398
399 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
400 - bump again for double-long bug on ppc(64)
401
402 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
403 - rebuilt for new gcc4.1 snapshot and glibc changes
404
405 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
406 - new version 1.3.5
407 - fixed init script to set policy for raw tables, too (#179094)
408
409 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
410 - added important iptables header files to devel package
411
412 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
413 - rebuilt
414
415 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
416 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
417   replace "_init" with "__attribute((constructor)) my_init"
418
419 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
420 - rebuild due to unresolved symbols in shared libraries
421
422 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
423 - new version 1.3.4
424 - dropped free_opts patch (upstream fixed)
425 - made libipq PIC (#158623)
426 - additional configuration options for iptables startup script (#172929)
427   Thanks to Jan Gruenwald for the patch
428 - spec file cleanup (dropped linux_header define and usage)
429
430 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
431 - new version 1.3.2 with additional patch for the misplaced free_opts call
432   from Marcus Sundberg
433
434 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
435 - new version 1.3.1
436
437 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
438 - Remove unnecessary explicit kernel dep (#146142)
439 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
440   for the patch
441 - Adapted iptables-config to reference to modprobe.conf (#150143)
442 - Remove misleading message (#140154): Thanks to Ulrich Drepper
443   for the patch
444
445 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
446 - new version 1.3.0
447
448 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
449 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
450
451 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
452 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
453 - modified config file to match this change and un-commented variables with
454   default values
455
456 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
457 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
458   for the patch
459
460 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
461 - fixed free bug in iptables (#128322)
462
463 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
464 - new version 1.2.11
465
466 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
467 - new version 1.2.10
468
469 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
470 - rebuilt
471
472 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
473 - rebuilt
474
475 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
476 - fixed iptables-restore -c fault if there are no counters (#116421)
477
478 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
479 - rebuilt
480
481 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
482 - Close File descriptors to prevent SELinux error message
483
484 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
485 - rebuild
486
487 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
488 - vew version 1.2.9
489 - new config options in ipXtables-config:
490   IPTABLES_MODULES_UNLOAD
491 - more documentation in ipXtables-config
492 - fix for netlink security issue in libipq (devel package)
493 - print fix for libipt_icmp (#109546)
494
495 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
496 - marked all messages in iptables init script for translation (#107462)
497 - enabled devel package (#105884, #106101)
498 - bumped build for fedora for libipt_recent.so (#106002)
499
500 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
501 - fixed lost udp port range in ip6tables-save (#104484)
502 - fixed non numeric multiport port output in ipXtables-savs
503
504 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
505 - do not link against -lnsl
506
507 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
508 - made variables in rmmod_r local
509
510 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
511 - fixed permission for init script
512
513 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
514 - fixed save when iptables file is missing and iptables-config permissions
515
516 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
517 - fixes for ip6tables: module unloading, setting policy only for existing 
518   tables
519
520 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
521 - IPTABLES_SAVE_COUNTER defaults to no, now
522 - install config file in /etc/sysconfig
523 - exchange unload of ip_tables and ip_conntrack
524 - fixed start function
525
526 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
527 - new config option IPTABLES_SAVE_ON_RESTART
528 - init script: new status, save and restart
529 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
530
531 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
532 - new config option IPTABLES_STATUS_NUMERIC
533 - cleared IPTABLES_MODULES in iptables-config
534
535 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
536 - new init scripts
537
538 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
539 - remove check for very old kernel versions in init scripts
540 - sync up both init scripts and remove some further ugly things
541 - add some docu into rpm
542
543 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
544 - rebuild
545
546 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
547 - update to 1.2.8
548
549 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
550 - rebuilt
551
552 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
553 - update to 1.2.7a
554 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
555
556 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
557 - Fix multilib
558
559 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
560 - fixed iptables and ip6tables initscript output, based on #70511
561 - check return status of all iptables calls, not just the last one
562   in a 'for' loop.
563
564 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
565 - 1.2.6a (bugfix release, #69747)
566
567 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
568 - automated rebuild
569
570 * Thu May 23 2002 Tim Powers <timp@redhat.com>
571 - automated rebuild
572
573 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
574 - Add some fixes from CVS, fixing bug #60465
575
576 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
577 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
578   #59402
579 - Update URL (#59354)
580 - Use /sbin/chkconfig rather than chkconfig in %%postun script
581
582 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
583 - 1.2.5
584
585 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
586 - automated rebuild
587
588 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
589 - Fix %%preun script
590
591 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
592 - Update to 1.2.4 (various fixes, including security fixes; among others:
593   #42990, #50500, #53325, #54280)
594 - Fix init script (#31133)
595
596 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
597 - 1.2.3 (5 security fixes, some other fixes)
598 - Fix updating (#53032)
599
600 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
601 - Fix #50990
602 - Add some fixes from current CVS; should fix #52620
603
604 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
605 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
606   issues
607
608 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
609 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
610   <mschwendt@yahoo.com>
611
612 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
613 - 1.2.2
614
615 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
616 - 1.2.1a, fixes #28412, #31136, #31460, #31133
617
618 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
619 - Yet another initscript fix (#30173)
620 - Fix the fixes; they fixed some issues but broke more important
621   stuff :/ (#30176)
622
623 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
624 - Fix up initscript (#27962)
625 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
626
627 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
628 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
629
630 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
631 - fix bugzilla #25986 (initscript not marked as config file)
632 - fix bugzilla #25962 (iptables-restore)
633 - mv chkconfig --del from postun to preun
634
635 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
636 - Fix check for ipchains
637
638 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
639 - Some fixes to init scripts
640
641 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
642 - Add some fixes from CVS, fixes among other things Bug #24732
643
644 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
645 - Add missing man pages, fix up init script (Bug #17676)
646
647 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
648 - add init script
649
650 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
651 - 1.2
652 - fix up ipv6 split
653 - add init script
654 - Move the plugins from /usr/lib/iptables to /lib/iptables.
655   This needs to work before /usr is mounted...
656 - Use -O1 on alpha (compiler bug)
657
658 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
659 - 1.1.2
660 - Add IPv6 support (in separate package)
661
662 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
663 - build everywhere
664
665 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
666 - 1.1.1
667
668 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
669 - automatic rebuild
670
671 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
672 - move iptables to /sbin.
673 - excludearch alpha for now, not building there because of compiler bug(?)
674
675 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
676 - don't obsolete ipchains either
677 - update to 1.1.0
678
679 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
680 - remove explicit kernel requirement
681
682 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
683 - initial package