192d0ae3c02f69aa47415d1bd90e61ea71c60da8
[libnl.git] / libnl.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name libnl
7 %define version 1.0
8 %define taglevel 11
9 %define preversion pre6
10
11 %define release %{taglevel}.%{preversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: Convenience library for kernel netlink sockets
14 Group: Development/Libraries
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: LGPL
19 Source: http://people.suug.ch/~tgr/libnl/files/libnl-%{version}-%{preversion}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26 #URL: http://people.suug.ch/~tgr/libnl/
27
28 BuildRequires: doxygen
29 #Patch3: libnl-1.0-pre6-static.patch
30 #Patch4: libnl-1.0-pre5-__u64_x86_64.patch
31 #Patch5: libnl-1.0-pre6-debuginfo.patch
32
33 %description
34 This package contains a convenience library to simplify
35 using the Linux kernel's netlink sockets interface for
36 network manipulation
37
38 %package devel
39 Summary: Libraries and headers for using libnl
40 Group: Development/Libraries
41 Requires: %{name} = %{version}-%{release}
42
43 %description devel
44 This package contains various headers for using libnl
45
46
47 %prep
48 %setup -q -n libnl-%{version}-%{preversion}
49 #%patch3 -p1
50 #%patch4 -p1
51 #%patch5 -p1
52
53 %build
54 %configure
55 make
56
57 %install
58 %{__rm} -rf $RPM_BUILD_ROOT
59 make install DESTDIR=$RPM_BUILD_ROOT
60
61 %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
62 cat >libnl-1.pc <<EOF
63 prefix=%{_prefix}
64 exec_prefix=%{_prefix}
65 libdir=%{_libdir}
66 includedir=%{_includedir}
67
68 Name: libnl
69 Description: Convenience library for netlink sockets
70 Version: %{version}-%{release}
71 Libs: -L%{_libdir} -lnl
72 Cflags:
73 EOF
74
75 %{__install} -m 644 libnl-1.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
76
77 %clean
78 %{__rm} -rf $RPM_BUILD_ROOT
79
80 %post -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(-,root,root)
85 %{_libdir}/%{name}.so.*
86 %doc COPYING
87
88 %files devel
89 %defattr(-,root,root,0755)
90 %{_includedir}/netlink/
91 %doc doc/*
92 %{_libdir}/%{name}.so
93 %{_libdir}/%{name}.a
94 %{_libdir}/pkgconfig/%{name}-1.pc
95
96 %changelog
97 * Thu Jul 26 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 1.0-0.11.pre6
98 - Upgrade to pre6
99
100 * Mon Aug 14 2006 Peter Jones <pjones@redhat.com> - 1.0-0.10.pre5.4
101 - Fix nl_recv() for ppc64
102
103 * Mon Jul 31 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.10.pre5.3
104 - unbreak the pkgconfig file
105
106 * Wed Jul 26 2006 Matthias Clasen <mclasen@redhat.com> - 1.0-0.10.pre5.2
107 - Fix the pkgconfig file on 64-bit systems (#197176)
108
109 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.10.pre5.1
110 - rebuild
111
112 * Thu Jun 15 2006 Peter Jones <pjones@redhat.com> 1.0-0.10.pre5
113 - Fix debuginfo generation.
114
115 * Fri May 26 2006 Jason Vas Dias <jvdias@redhat.com> 1.0-0.9.pre5
116 - Allow build to succeed with new gcc / glibc-kernheaders
117   (compile failed on __u64 redefinition on x86_64).
118 - Add a static %{_libdir}/libnl.a library to libnl-devel for
119   programs that might need to do a static link to libnl.
120   Added after consultation with Christopher Aillon.
121
122 * Tue Feb 12 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.8.pre5
123 - Rebuild
124
125 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0-0.7.pre5.1
126 - rebuilt for new gcc4.1 snapshot and glibc changes
127
128 * Mon Jan 16 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.7.pre5
129 - Add patch to not chown files to root.root during make install; it
130   happens normally.
131
132 * Mon Jan  9 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.6.pre5
133 - Correctly install the pkgconfig file
134
135 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
136 - rebuilt
137
138 * Wed Nov  2 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.5.pre5
139 - Fix 64bit LIBDIR issue; use $LIBDIR instead of $PREFIX/lib
140
141 * Wed Nov  2 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.4.pre5
142 - Update to 1.0-pre5
143
144 * Tue Nov  1 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.3.pre4
145 - Update to 1.0-pre4
146
147 * Tue Nov  1 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.2.pre3
148 - Minor specfile cleanup
149
150 * Thu Oct 27 2005 Dan Williams <dcbw@redhat.com> 1.0-0.1.pre3
151 - Split into main and devel packages
152
153 * Thu Oct 27 2005 Dan Williams <dcbw@redhat.com> 1.0-0.0.pre3
154 - initial build