removed unnecessary patch - autoreconf will do
[libvirt.git] / libvirt.spec
index 05d6499..6020d62 100644 (file)
@@ -17,7 +17,8 @@
 %define _without_polkit                true
 %define _without_sasl          true
 %define _without_audit         true
-%define _without_netcf         true
+#interface requires netcf
+#%define _without_netcf                true
 %define _without_avahi         true
 %define _without_sanlock       true
 %define _without_xen           true
@@ -27,6 +28,8 @@
 %define _without_esx           true
 %define _without_libxl         true
 
+%define enable_autotools       1
+
 # If neither fedora nor rhel was defined, try to guess them from %{dist}
 %if !0%{?rhel} && !0%{?fedora}
 %{expand:%(echo "%{?dist}" | \
@@ -379,6 +382,7 @@ URL: http://libvirt.org/
 %endif
 Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.gz
 Patch1: libcurl.patch
+Patch3: securityselinuxlabeltest.patch
 
 %if %{with_libvirtd}
 Requires: libvirt-daemon = %{version}-%{release}
@@ -405,7 +409,9 @@ Requires: libvirt-daemon-driver-uml = %{version}-%{release}
 Requires: libvirt-daemon-driver-xen = %{version}-%{release}
         %endif
 
+       %if %{with_interface}
 Requires: libvirt-daemon-driver-interface = %{version}-%{release}
+       %endif
 Requires: libvirt-daemon-driver-secret = %{version}-%{release}
 Requires: libvirt-daemon-driver-storage = %{version}-%{release}
 Requires: libvirt-daemon-driver-network = %{version}-%{release}
@@ -1107,6 +1113,7 @@ of recent versions of Linux (and other OSes).
 %prep
 %setup -q
 %patch1 -p1
+%patch3 -p1
 
 %build
 %if ! %{with_xen}