removed unnecessary patch - autoreconf will do
[libvirt.git] / libvirt.spec
index 8f9d986..6020d62 100644 (file)
@@ -4,6 +4,32 @@
 %define module_version_varname mainstream_version
 %define taglevel 0
 
+#libvirt-RPMFLAGS := --without storage-disk --without storage-iscsi --without storage-scsi \
+#                      --without storage-fs --without storage-lvm \
+#                      --without polkit --without sasl --without audit --with capng --with udev \
+#                      --without netcf --without avahi --without sanlock \
+#                      --without xen --without qemu --without hyperv --without phyp --without esx \
+#                      --without libxl \
+%define _without_storage_disk  true
+%define _without_storage_iscsi true
+%define _without_storage_fs    true
+%define _without_storage_lvm   true
+%define _without_polkit                true
+%define _without_sasl          true
+%define _without_audit         true
+#interface requires netcf
+#%define _without_netcf                true
+%define _without_avahi         true
+%define _without_sanlock       true
+%define _without_xen           true
+%define _without_qemu          true
+%define _without_hyperv                true
+%define _without_phyp          true
+%define _without_esx           true
+%define _without_libxl         true
+
+%define enable_autotools       1
+
 # If neither fedora nor rhel was defined, try to guess them from %{dist}
 %if !0%{?rhel} && !0%{?fedora}
 %{expand:%(echo "%{?dist}" | \
@@ -355,7 +381,8 @@ URL: http://libvirt.org/
     %define mainturl stable_updates/
 %endif
 Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.gz
-Patch1: selinux-mkdir.patch
+Patch1: libcurl.patch
+Patch3: securityselinuxlabeltest.patch
 
 %if %{with_libvirtd}
 Requires: libvirt-daemon = %{version}-%{release}
@@ -382,7 +409,9 @@ Requires: libvirt-daemon-driver-uml = %{version}-%{release}
 Requires: libvirt-daemon-driver-xen = %{version}-%{release}
         %endif
 
+       %if %{with_interface}
 Requires: libvirt-daemon-driver-interface = %{version}-%{release}
+       %endif
 Requires: libvirt-daemon-driver-secret = %{version}-%{release}
 Requires: libvirt-daemon-driver-storage = %{version}-%{release}
 Requires: libvirt-daemon-driver-network = %{version}-%{release}
@@ -1083,7 +1112,8 @@ of recent versions of Linux (and other OSes).
 
 %prep
 %setup -q
-%patch1 -p1 
+%patch1 -p1
+%patch3 -p1
 
 %build
 %if ! %{with_xen}