Setting tag libvirt-1.0.4-2
[libvirt.git] / libvirt.spec
index 05d6499..92e2f4c 100644 (file)
@@ -1,8 +1,8 @@
 # -*- rpm-spec -*-
 
-%define mainstream_version 1.0.2
+%define mainstream_version 1.0.4
 %define module_version_varname mainstream_version
-%define taglevel 0
+%define taglevel 2
 
 #libvirt-RPMFLAGS := --without storage-disk --without storage-iscsi --without storage-scsi \
 #                      --without storage-fs --without storage-lvm \
@@ -17,7 +17,8 @@
 %define _without_polkit                true
 %define _without_sasl          true
 %define _without_audit         true
-%define _without_netcf         true
+#interface requires netcf
+#%define _without_netcf                true
 %define _without_avahi         true
 %define _without_sanlock       true
 %define _without_xen           true
 %define _without_esx           true
 %define _without_libxl         true
 
+# turn this off even on f18 as an attempt to get back /proc/meminfo
+%define _without_fuse          true
+
+%define enable_autotools       1
+
 # If neither fedora nor rhel was defined, try to guess them from %{dist}
 %if !0%{?rhel} && !0%{?fedora}
 %{expand:%(echo "%{?dist}" | \
@@ -378,7 +384,7 @@ URL: http://libvirt.org/
     %define mainturl stable_updates/
 %endif
 Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.gz
-Patch1: libcurl.patch
+Patch1: virgetlasterror.patch
 
 %if %{with_libvirtd}
 Requires: libvirt-daemon = %{version}-%{release}
@@ -405,7 +411,9 @@ Requires: libvirt-daemon-driver-uml = %{version}-%{release}
 Requires: libvirt-daemon-driver-xen = %{version}-%{release}
         %endif
 
+       %if %{with_interface}
 Requires: libvirt-daemon-driver-interface = %{version}-%{release}
+       %endif
 Requires: libvirt-daemon-driver-secret = %{version}-%{release}
 Requires: libvirt-daemon-driver-storage = %{version}-%{release}
 Requires: libvirt-daemon-driver-network = %{version}-%{release}
@@ -553,6 +561,7 @@ BuildRequires: libcap-ng-devel >= 0.5.0
 %endif
 %if %{with_fuse}
 BuildRequires: fuse-devel >= 2.8.6
+Requires: fuse
 %endif
 %if %{with_phyp} || %{with_libssh2}
 BuildRequires: libssh2-devel >= 1.3.0
@@ -2019,6 +2028,15 @@ fi
 %endif
 
 %changelog
+* Sat Apr 13 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libvirt-1.0.4-2
+- path libvirt.py so virGetLastError gets found
+
+* Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libvirt-1.0.4-1
+- use upstream 1.0.4
+
+* Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libvirt-1.0.2-2
+- turn off fuse no matter what, as this conflicts with the way procprotect works
+
 * Wed Jan 30 2013 Daniel Veillard <veillard@redhat.com> - 1.0.2-1
 - LXC improvements
 - S390 architecture improvement