Setting tag libvirt-1.0.4-2
[libvirt.git] / libvirt.spec
index 8f9d986..92e2f4c 100644 (file)
@@ -1,8 +1,37 @@
 # -*- rpm-spec -*-
 
-%define mainstream_version 1.0.2
+%define mainstream_version 1.0.4
 %define module_version_varname mainstream_version
-%define taglevel 0
+%define taglevel 2
+
+#libvirt-RPMFLAGS := --without storage-disk --without storage-iscsi --without storage-scsi \
+#                      --without storage-fs --without storage-lvm \
+#                      --without polkit --without sasl --without audit --with capng --with udev \
+#                      --without netcf --without avahi --without sanlock \
+#                      --without xen --without qemu --without hyperv --without phyp --without esx \
+#                      --without libxl \
+%define _without_storage_disk  true
+%define _without_storage_iscsi true
+%define _without_storage_fs    true
+%define _without_storage_lvm   true
+%define _without_polkit                true
+%define _without_sasl          true
+%define _without_audit         true
+#interface requires netcf
+#%define _without_netcf                true
+%define _without_avahi         true
+%define _without_sanlock       true
+%define _without_xen           true
+%define _without_qemu          true
+%define _without_hyperv                true
+%define _without_phyp          true
+%define _without_esx           true
+%define _without_libxl         true
+
+# turn this off even on f18 as an attempt to get back /proc/meminfo
+%define _without_fuse          true
+
+%define enable_autotools       1
 
 # If neither fedora nor rhel was defined, try to guess them from %{dist}
 %if !0%{?rhel} && !0%{?fedora}
@@ -355,7 +384,7 @@ URL: http://libvirt.org/
     %define mainturl stable_updates/
 %endif
 Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.gz
-Patch1: selinux-mkdir.patch
+Patch1: virgetlasterror.patch
 
 %if %{with_libvirtd}
 Requires: libvirt-daemon = %{version}-%{release}
@@ -382,7 +411,9 @@ Requires: libvirt-daemon-driver-uml = %{version}-%{release}
 Requires: libvirt-daemon-driver-xen = %{version}-%{release}
         %endif
 
+       %if %{with_interface}
 Requires: libvirt-daemon-driver-interface = %{version}-%{release}
+       %endif
 Requires: libvirt-daemon-driver-secret = %{version}-%{release}
 Requires: libvirt-daemon-driver-storage = %{version}-%{release}
 Requires: libvirt-daemon-driver-network = %{version}-%{release}
@@ -530,6 +561,7 @@ BuildRequires: libcap-ng-devel >= 0.5.0
 %endif
 %if %{with_fuse}
 BuildRequires: fuse-devel >= 2.8.6
+Requires: fuse
 %endif
 %if %{with_phyp} || %{with_libssh2}
 BuildRequires: libssh2-devel >= 1.3.0
@@ -1083,7 +1115,7 @@ of recent versions of Linux (and other OSes).
 
 %prep
 %setup -q
-%patch1 -p1 
+%patch1 -p1
 
 %build
 %if ! %{with_xen}
@@ -1996,6 +2028,15 @@ fi
 %endif
 
 %changelog
+* Sat Apr 13 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libvirt-1.0.4-2
+- path libvirt.py so virGetLastError gets found
+
+* Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libvirt-1.0.4-1
+- use upstream 1.0.4
+
+* Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libvirt-1.0.2-2
+- turn off fuse no matter what, as this conflicts with the way procprotect works
+
 * Wed Jan 30 2013 Daniel Veillard <veillard@redhat.com> - 1.0.2-1
 - LXC improvements
 - S390 architecture improvement