Setting tag libvirt-1.0.4-2
[libvirt.git] / libvirt.spec
index e8f3529..92e2f4c 100644 (file)
@@ -1,8 +1,8 @@
 # -*- rpm-spec -*-
 
-%define mainstream_version 1.0.2
+%define mainstream_version 1.0.4
 %define module_version_varname mainstream_version
-%define taglevel 1
+%define taglevel 2
 
 #libvirt-RPMFLAGS := --without storage-disk --without storage-iscsi --without storage-scsi \
 #                      --without storage-fs --without storage-lvm \
@@ -28,6 +28,9 @@
 %define _without_esx           true
 %define _without_libxl         true
 
+# turn this off even on f18 as an attempt to get back /proc/meminfo
+%define _without_fuse          true
+
 %define enable_autotools       1
 
 # If neither fedora nor rhel was defined, try to guess them from %{dist}
     %define with_capng     0%{!?_without_capng:1}
 %endif
 
-### # fuse is used to provide virtualized /proc for LXC
-### %if 0%{?fedora} >= 17 || 0%{?rhel} >= 7
-###     %define with_fuse      0%{!?_without_fuse:1}
-### %endif
+# fuse is used to provide virtualized /proc for LXC
+%if 0%{?fedora} >= 17 || 0%{?rhel} >= 7
+    %define with_fuse      0%{!?_without_fuse:1}
+%endif
 
 # netcf is used to manage network interfaces in Fedora 12 / RHEL-6 or newer
 %if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
@@ -381,8 +384,7 @@ URL: http://libvirt.org/
     %define mainturl stable_updates/
 %endif
 Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.gz
-Patch1: libcurl.patch
-Patch3: securityselinuxlabeltest.patch
+Patch1: virgetlasterror.patch
 
 %if %{with_libvirtd}
 Requires: libvirt-daemon = %{version}-%{release}
@@ -1114,7 +1116,6 @@ of recent versions of Linux (and other OSes).
 %prep
 %setup -q
 %patch1 -p1
-%patch3 -p1
 
 %build
 %if ! %{with_xen}
@@ -2027,6 +2028,15 @@ fi
 %endif
 
 %changelog
+* Sat Apr 13 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libvirt-1.0.4-2
+- path libvirt.py so virGetLastError gets found
+
+* Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libvirt-1.0.4-1
+- use upstream 1.0.4
+
+* Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libvirt-1.0.2-2
+- turn off fuse no matter what, as this conflicts with the way procprotect works
+
 * Wed Jan 30 2013 Daniel Veillard <veillard@redhat.com> - 1.0.2-1
 - LXC improvements
 - S390 architecture improvement