redo previous change, objective is to turn off fuse on f18
[libvirt.git] / libvirt.spec
index 6020d62..d010754 100644 (file)
@@ -2,7 +2,7 @@
 
 %define mainstream_version 1.0.2
 %define module_version_varname mainstream_version
-%define taglevel 0
+%define taglevel 1
 
 #libvirt-RPMFLAGS := --without storage-disk --without storage-iscsi --without storage-scsi \
 #                      --without storage-fs --without storage-lvm \
@@ -28,6 +28,9 @@
 %define _without_esx           true
 %define _without_libxl         true
 
+# turn this off even on f18 as an attempt to get back /proc/meminfo
+%define _without_fuse          true
+
 %define enable_autotools       1
 
 # If neither fedora nor rhel was defined, try to guess them from %{dist}
@@ -559,6 +562,7 @@ BuildRequires: libcap-ng-devel >= 0.5.0
 %endif
 %if %{with_fuse}
 BuildRequires: fuse-devel >= 2.8.6
+Requires: fuse
 %endif
 %if %{with_phyp} || %{with_libssh2}
 BuildRequires: libssh2-devel >= 1.3.0