redo previous change, objective is to turn off fuse on f18
[libvirt.git] / libvirt.spec
index c7a81b3..d010754 100644 (file)
@@ -2,7 +2,7 @@
 
 %define mainstream_version 1.0.2
 %define module_version_varname mainstream_version
-%define taglevel 0
+%define taglevel 1
 
 #libvirt-RPMFLAGS := --without storage-disk --without storage-iscsi --without storage-scsi \
 #                      --without storage-fs --without storage-lvm \
@@ -17,7 +17,8 @@
 %define _without_polkit                true
 %define _without_sasl          true
 %define _without_audit         true
-%define _without_netcf         true
+#interface requires netcf
+#%define _without_netcf                true
 %define _without_avahi         true
 %define _without_sanlock       true
 %define _without_xen           true
 %define _without_esx           true
 %define _without_libxl         true
 
+# turn this off even on f18 as an attempt to get back /proc/meminfo
+%define _without_fuse          true
+
+%define enable_autotools       1
+
 # If neither fedora nor rhel was defined, try to guess them from %{dist}
 %if !0%{?rhel} && !0%{?fedora}
 %{expand:%(echo "%{?dist}" | \
@@ -378,7 +384,8 @@ URL: http://libvirt.org/
     %define mainturl stable_updates/
 %endif
 Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.gz
-Patch1: selinux-mkdir.patch
+Patch1: libcurl.patch
+Patch3: securityselinuxlabeltest.patch
 
 %if %{with_libvirtd}
 Requires: libvirt-daemon = %{version}-%{release}
@@ -405,7 +412,9 @@ Requires: libvirt-daemon-driver-uml = %{version}-%{release}
 Requires: libvirt-daemon-driver-xen = %{version}-%{release}
         %endif
 
+       %if %{with_interface}
 Requires: libvirt-daemon-driver-interface = %{version}-%{release}
+       %endif
 Requires: libvirt-daemon-driver-secret = %{version}-%{release}
 Requires: libvirt-daemon-driver-storage = %{version}-%{release}
 Requires: libvirt-daemon-driver-network = %{version}-%{release}
@@ -553,6 +562,7 @@ BuildRequires: libcap-ng-devel >= 0.5.0
 %endif
 %if %{with_fuse}
 BuildRequires: fuse-devel >= 2.8.6
+Requires: fuse
 %endif
 %if %{with_phyp} || %{with_libssh2}
 BuildRequires: libssh2-devel >= 1.3.0
@@ -1106,7 +1116,8 @@ of recent versions of Linux (and other OSes).
 
 %prep
 %setup -q
-%patch1 -p1 
+%patch1 -p1
+%patch3 -p1
 
 %build
 %if ! %{with_xen}