remove a file from packaging scope as we do not run tests
[libvirt.git] / libvirt.spec
index 661efd9..e7fc19b 100644 (file)
@@ -1,8 +1,9 @@
 # -*- rpm-spec -*-
 
-%define mainstream_version 1.2.1
+%define mainstream_version 1.2.3
 %define module_version_varname mainstream_version
-%define taglevel 0
+%define taglevel 1
+%define packager PlanetLab/OneLab
 
 #libvirt-RPMFLAGS := --without storage-disk --without storage-iscsi --without storage-scsi \
 ##                       --without storage-fs --without storage-lvm \
@@ -17,8 +18,6 @@
 %define _without_polkit         true
 %define _without_sasl           true
 %define _without_audit          true
-#interface requires netcf
-#%define _without_netcf         true
 %define _without_avahi          true
 %define _without_sanlock        true
 %define _without_xen            true
@@ -28,7 +27,7 @@
 %define _without_esx            true
 %define _without_libxl          true
 %define _without_vbox           true
-
+%define _without_uml           true
 
 #turn this off even on f18 as an attempt to get back /proc/meminfo
 %define _without_fuse           true
     %define with_hal       0%{!?_without_hal:%{server_drivers}}
 %endif
 
-# interface requires netcf
-%if ! 0%{?with_netcf}
-    %define with_interface     0
-%endif
-
 # Enable yajl library for JSON mode with QEMU
 %if 0%{?fedora} >= 13 || 0%{?rhel} >= 6
     %define with_yajl     0%{!?_without_yajl:%{server_drivers}}
@@ -1545,6 +1539,12 @@ rm -f $RPM_BUILD_ROOT%{_prefix}/lib/sysctl.d/libvirtd.conf
 rm -fr %{buildroot}
 
 %check
+# PlanetLab build
+# do not run tests, this is mainstream business, and more importantly
+# our own setup is ti build inside a container already and we've seen
+# occasional red herrings because of that
+exit
+#
 cd tests
 make
 # These tests don't current work in a mock build root
@@ -1854,7 +1854,8 @@ exit 0
 %{_datadir}/augeas/lenses/virtlockd.aug
 %{_datadir}/augeas/lenses/tests/test_virtlockd.aug
 %{_datadir}/augeas/lenses/libvirt_lockd.aug
-%{_datadir}/augeas/lenses/tests/test_libvirt_lockd.aug
+### planetlab: we do not run tests
+# %{_datadir}/augeas/lenses/tests/test_libvirt_lockd.aug
 
     %if %{with_polkit}
         %if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
@@ -2186,6 +2187,9 @@ exit 0
 %doc examples/systemtap
 
 %changelog
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libvirt-1.2.1-1
+- builds fine on f{18,20}
+
 * Mon Jan 27 2014 Cole Robinson <crobinso@redhat.com> - 1.2.1-2
 - Rebuild for openwsman soname bump