turn off fuse even on f18
[libvirt.git] / libvirt.spec
index 05d6499..e8f3529 100644 (file)
@@ -2,7 +2,7 @@
 
 %define mainstream_version 1.0.2
 %define module_version_varname mainstream_version
-%define taglevel 0
+%define taglevel 1
 
 #libvirt-RPMFLAGS := --without storage-disk --without storage-iscsi --without storage-scsi \
 #                      --without storage-fs --without storage-lvm \
@@ -17,7 +17,8 @@
 %define _without_polkit                true
 %define _without_sasl          true
 %define _without_audit         true
-%define _without_netcf         true
+#interface requires netcf
+#%define _without_netcf                true
 %define _without_avahi         true
 %define _without_sanlock       true
 %define _without_xen           true
@@ -27,6 +28,8 @@
 %define _without_esx           true
 %define _without_libxl         true
 
+%define enable_autotools       1
+
 # If neither fedora nor rhel was defined, try to guess them from %{dist}
 %if !0%{?rhel} && !0%{?fedora}
 %{expand:%(echo "%{?dist}" | \
     %define with_capng     0%{!?_without_capng:1}
 %endif
 
-# fuse is used to provide virtualized /proc for LXC
-%if 0%{?fedora} >= 17 || 0%{?rhel} >= 7
-    %define with_fuse      0%{!?_without_fuse:1}
-%endif
+### # fuse is used to provide virtualized /proc for LXC
+### %if 0%{?fedora} >= 17 || 0%{?rhel} >= 7
+###     %define with_fuse      0%{!?_without_fuse:1}
+### %endif
 
 # netcf is used to manage network interfaces in Fedora 12 / RHEL-6 or newer
 %if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
@@ -379,6 +382,7 @@ URL: http://libvirt.org/
 %endif
 Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.gz
 Patch1: libcurl.patch
+Patch3: securityselinuxlabeltest.patch
 
 %if %{with_libvirtd}
 Requires: libvirt-daemon = %{version}-%{release}
@@ -405,7 +409,9 @@ Requires: libvirt-daemon-driver-uml = %{version}-%{release}
 Requires: libvirt-daemon-driver-xen = %{version}-%{release}
         %endif
 
+       %if %{with_interface}
 Requires: libvirt-daemon-driver-interface = %{version}-%{release}
+       %endif
 Requires: libvirt-daemon-driver-secret = %{version}-%{release}
 Requires: libvirt-daemon-driver-storage = %{version}-%{release}
 Requires: libvirt-daemon-driver-network = %{version}-%{release}
@@ -553,6 +559,7 @@ BuildRequires: libcap-ng-devel >= 0.5.0
 %endif
 %if %{with_fuse}
 BuildRequires: fuse-devel >= 2.8.6
+Requires: fuse
 %endif
 %if %{with_phyp} || %{with_libssh2}
 BuildRequires: libssh2-devel >= 1.3.0
@@ -1107,6 +1114,7 @@ of recent versions of Linux (and other OSes).
 %prep
 %setup -q
 %patch1 -p1
+%patch3 -p1
 
 %build
 %if ! %{with_xen}