turn off fuse even on f18
[libvirt.git] / libvirt.spec
index a108d48..e8f3529 100644 (file)
@@ -2,7 +2,7 @@
 
 %define mainstream_version 1.0.2
 %define module_version_varname mainstream_version
-%define taglevel 0
+%define taglevel 1
 
 #libvirt-RPMFLAGS := --without storage-disk --without storage-iscsi --without storage-scsi \
 #                      --without storage-fs --without storage-lvm \
     %define with_capng     0%{!?_without_capng:1}
 %endif
 
-# fuse is used to provide virtualized /proc for LXC
-%if 0%{?fedora} >= 17 || 0%{?rhel} >= 7
-    %define with_fuse      0%{!?_without_fuse:1}
-%endif
+### # fuse is used to provide virtualized /proc for LXC
+### %if 0%{?fedora} >= 17 || 0%{?rhel} >= 7
+###     %define with_fuse      0%{!?_without_fuse:1}
+### %endif
 
 # netcf is used to manage network interfaces in Fedora 12 / RHEL-6 or newer
 %if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
@@ -382,7 +382,6 @@ URL: http://libvirt.org/
 %endif
 Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.gz
 Patch1: libcurl.patch
-Patch2: libcurl-daemon.patch
 Patch3: securityselinuxlabeltest.patch
 
 %if %{with_libvirtd}
@@ -560,6 +559,7 @@ BuildRequires: libcap-ng-devel >= 0.5.0
 %endif
 %if %{with_fuse}
 BuildRequires: fuse-devel >= 2.8.6
+Requires: fuse
 %endif
 %if %{with_phyp} || %{with_libssh2}
 BuildRequires: libssh2-devel >= 1.3.0
@@ -1114,7 +1114,6 @@ of recent versions of Linux (and other OSes).
 %prep
 %setup -q
 %patch1 -p1
-%patch2 -p1
 %patch3 -p1
 
 %build