1e6bfbdec0cb3b5759b33023ab21fb2b590c9c64
[linux-2.6.git] / kernel-2.6-planetlab.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define builduml 0
8 %define buildxen 0
9 %define builddoc 0
10
11 # Versions of various parts
12
13 %define _with_netns 1
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 22
22 %define patchlevel 14
23 %define kversion 2.6.%{sublevel}
24 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
25
26 %define vsversion 2.3.0.29
27
28 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
29 # updated every time the PL kernel is updated.
30 %define vini_pl_patch 561
31
32 %define specrelease 1
33
34 %define release vs%{vsversion}.%{specrelease}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
35
36 %{!?pldistro:%global pldistro planetlab}
37
38 %define signmodules 0
39 %define make_target bzImage
40 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
41
42 # Override generic defaults with per-arch defaults
43
44 %define image_install_path boot
45
46 #
47 # Three sets of minimum package version requirements in the form of Conflicts:
48 # to versions below the minimum
49 #
50
51 #
52 # First the general kernel 2.6 required versions as per
53 # Documentation/Changes
54 #
55 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
56
57
58 # Then a series of requirements that are distribution specific, either 
59 # because we add patches for something, or the older versions have 
60 # problems with the newer kernel or lack certain things that make 
61 # integration in the distro harder than needed.
62 #
63 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
64
65 #
66 # Several packages had bugs in them that became obvious when the NPTL
67 # threading code got integrated.
68 #
69 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
70
71 #
72 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
73 #
74
75 # MEF commented out
76 # %define xen_conflicts glibc < 2.3.5-1
77
78 #
79 # Packages that need to be installed before the kernel is, because the %post
80 # scripts use them.
81 #
82 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
83
84 URL: http://svn.planet-lab.org/wiki/linux-2.6
85
86 Name: kernel
87 Group: System Environment/Kernel
88 License: GPLv2
89 Version: %{rpmversion}
90 Release: %{release}
91 ExclusiveOS: Linux
92 Provides: kernel = %{version}
93 Provides: kernel-drm = 4.3.0
94 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
95 Provides: kernel-smp = %{rpmversion}-%{release}
96 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
97 Prereq: %{kernel_prereq}
98 Conflicts: %{kernel_dot_org_conflicts}
99 Conflicts: %{package_conflicts}
100 Conflicts: %{nptl_conflicts}
101 # We can't let RPM do the dependencies automatic because it'll then pick up
102 # a correct but undesirable perl dependency from the module headers which
103 # isn't required for the kernel proper to function
104 AutoReqProv: no
105
106 #
107 # List the packages used during the kernel build
108 #
109 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
110 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
111 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
112 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
113
114
115 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
116
117 Source10: kernel-%{kversion}-i586-%{pldistro}.config
118 Source11: kernel-%{kversion}-i686-%{pldistro}.config
119 Source12: kernel-%{kversion}-x86_64-%{pldistro}.config
120 %if %{builduml}
121 Source20: kernel-%{kversion}-i686-uml-%{pldidstro}.config
122 %endif
123 %if %{buildxen}
124 Source30: kernel-%{kversion}-i686-xenU-%{pldistro}.config
125 %endif
126
127 # Mainline patches
128 %if "0%{patchlevel}"
129 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
130 %endif
131
132 Patch010: linux-2.6-010-e1000e.patch
133 Patch020: linux-2.6-020-build-id.patch
134 Patch030: linux-2.6-030-netns.patch
135
136 # These are patches picked up from Fedora/RHEL
137 Patch100: linux-2.6-100-build-nonintconfig.patch
138
139 # Linux-VServer
140 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
141
142 # IP sets
143 Patch250: linux-2.6-250-ipsets.patch
144
145 # PlanetLab
146 Patch500: linux-2.6-500-vserver-filesharing.patch
147 Patch510: linux-2.6-510-ipod.patch
148 Patch520: linux-2.6-520-vnet+.patch
149 Patch530: linux-2.6-530-built-by-support.patch
150 Patch540: linux-2.6-540-oom-kill.patch
151 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
152 Patch560: linux-2.6-560-mmconf.patch
153 Patch570: linux-2.6-570-tagxid.patch
154 Patch590: linux-2.6-590-trellis-mm1-netns.patch
155 Patch591: linux-2.6-591-unshare-netns.patch
156 Patch592: linux-2.6-592-ztun-sb.patch
157 Patch593: linux-2.6-593-egre.patch
158
159 %description
160 The kernel package contains the Linux kernel (vmlinuz), the core of any
161 Linux operating system.  The kernel handles the basic functions
162 of the operating system:  memory allocation, process allocation, device
163 input and output, etc.
164
165 %package devel
166 Summary: Development package for building kernel modules to match the kernel.
167 Group: System Environment/Kernel
168 AutoReqProv: no
169 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
170 Provides: kernel-smp-devel = %{rpmversion}-%{release}
171 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
172 Prereq: /usr/bin/find
173
174 %description devel
175 This package provides kernel headers and makefiles sufficient to build modules
176 against the kernel package.
177
178
179 %package doc
180 Summary: Various documentation bits found in the kernel source.
181 Group: Documentation
182
183 %description doc
184 This package contains documentation files from the kernel
185 source. Various bits of information about the Linux kernel and the
186 device drivers shipped with it are documented in these files.
187
188 You'll want to install this package if you need a reference to the
189 options that can be passed to Linux kernel modules at load time.
190
191 %package xenU
192 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
193
194 Group: System Environment/Kernel
195 Provides: kernel = %{version}
196 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
197 Prereq: %{kernel_prereq}
198 Conflicts: %{kernel_dot_org_conflicts}
199 Conflicts: %{package_conflicts}
200 Conflicts: %{nptl_conflicts}
201
202 # MEF commented out 
203 # Conflicts: %{xen_conflicts}
204
205 # We can't let RPM do the dependencies automatic because it'll then pick up
206 # a correct but undesirable perl dependency from the module headers which
207 # isn't required for the kernel proper to function
208 AutoReqProv: no
209
210 %description xenU
211 This package includes a version of the Linux kernel which
212 runs in Xen unprivileged guest VMs.  This should be installed
213 both inside the unprivileged guest (for the modules) and in
214 the guest0 domain.
215
216 %package xenU-devel
217 Summary: Development package for building kernel modules to match the kernel.
218 Group: System Environment/Kernel
219 AutoReqProv: no
220 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
221 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
222 Provides: kernel-devel = %{rpmversion}-%{release}xenU
223 Prereq: /usr/sbin/hardlink, /usr/bin/find
224
225 %description xenU-devel
226 This package provides kernel headers and makefiles sufficient to build modules
227 against the kernel package.
228
229 %package uml
230 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
231
232 Group: System Environment/Kernel
233
234 %description uml
235 This package includes a user mode version of the Linux kernel.
236
237 %package uml-devel
238 Summary: Development package for building kernel modules to match the UML kernel.
239 Group: System Environment/Kernel
240 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
241 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
242 Provides: kernel-devel = %{rpmversion}-%{release}smp
243 AutoReqProv: no
244 Prereq: /usr/sbin/hardlink, /usr/bin/find
245
246 %description uml-devel
247 This package provides kernel headers and makefiles sufficient to build modules
248 against the User Mode Linux kernel package.
249
250 %package uml-modules
251 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
252
253 Group: System Environment/Kernel
254
255 %description uml-modules
256 This package includes a user mode version of the Linux kernel modules.
257
258 %package vserver
259 Summary: A placeholder RPM that provides kernel and kernel-drm
260
261 Group: System Environment/Kernel
262 Provides: kernel = %{version}
263 Provides: kernel-drm = 4.3.0
264 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
265
266 %description vserver
267 VServers do not require and cannot use kernels, but some RPMs have
268 implicit or explicit dependencies on the "kernel" package
269 (e.g. tcpdump). This package installs no files but provides the
270 necessary dependencies to make rpm and yum happy.
271
272
273 %prep
274 # First we unpack the kernel tarball.
275 # If this isn't the first make prep, we use links to the existing clean tarball
276 # which speeds things up quite a bit.
277 if [ ! -d kernel-%{kversion}/vanilla ]; then
278   # Ok, first time we do a make prep.
279   rm -f pax_global_header
280 %setup -q -n %{name}-%{kversion} -c
281   mv linux-%{kversion} vanilla
282 else
283   # We already have a vanilla dir.
284   cd kernel-%{kversion}
285 fi
286
287 KERNEL_PREVIOUS=vanilla
288 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
289 %define ApplyPatch() \
290   rm -fr linux-%{kversion}-%1                           \
291   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
292   patchflag=-p1                                         \
293   test "%2" != "%%2" && patchflag="%2"                  \
294   PATCH="%{expand:%{PATCH%1}}"                          \
295   if test ! -e "$PATCH"; then                           \
296     echo "Patch %1 does not exist!"                     \
297     exit 1                                              \
298   fi                                                    \
299   case "$PATCH" in                                      \
300     *.bz2)  bzcat "$PATCH";;                            \
301     *.gz)   zcat "$PATCH";;                             \
302     *)      cat "$PATCH";;                              \
303   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
304   KERNEL_PREVIOUS=linux-%{kversion}-%1
305
306 # This is where the patches get applied
307 %if "0%{patchlevel}"
308 %ApplyPatch 0
309 %endif
310
311 %ApplyPatch 10
312 %ApplyPatch 20
313
314 %ApplyPatch 100
315
316 %ApplyPatch 200
317
318 %ApplyPatch 250
319
320 %ApplyPatch 500
321 %ApplyPatch 510
322 %ApplyPatch 520
323 %ApplyPatch 530
324 %ApplyPatch 540
325 %ApplyPatch 550
326 %ApplyPatch 560
327 %ApplyPatch 570
328
329
330 %if 0%{?_with_netns}
331 %ApplyPatch 590
332 %ApplyPatch 591
333 %ApplyPatch 592
334 #%ApplyPatch 593
335 %endif
336
337 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
338 # break with later patches.
339
340 rm -fr linux-%{kversion}
341 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
342 cd linux-%{kversion}
343
344
345 # make sure the kernel has the sublevel we know it has. This looks weird
346 # but for -pre and -rc versions we need it since we only want to use
347 # the higher version when the final kernel is released.
348 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
349 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
350
351 # get rid of unwanted files resulting from patch fuzz
352 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
353
354
355 ###
356 ### build
357 ###
358 %build
359
360 BuildKernel() {
361     MakeTarget=$1
362     Arch=$2
363     Flavour=$3
364
365     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
366     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
367     cd linux-%{_target_cpu}-%{kversion}$Flavour
368
369     # Pick the right config file for the kernel we're building
370     if [ -n "$Flavour" ] ; then
371       Config=kernel-%{kversion}-%{_target_cpu}-$Flavour-%{pldistro}.config
372       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
373       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
374     else
375       Config=kernel-%{kversion}-%{_target_cpu}-%{pldistro}.config
376       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
377       DevelLink=
378     fi
379
380     KernelVer=%{version}-%{release}$Flavour
381     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
382
383     # make sure EXTRAVERSION says what we want it to say
384     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
385
386     # and now to start the build process
387
388     make -s mrproper
389     cp %{_sourcedir}/$Config .config
390
391     #Arch=`head -1 .config | cut -b 3-`
392     echo USING ARCH=$Arch
393
394     make -s ARCH=$Arch nonint_oldconfig > /dev/null
395     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
396     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
397
398     # Start installing the results
399
400 %if "%{_enable_debug_packages}" == "1"
401     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
402 %endif
403     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
404     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
405     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
406     if [ -f arch/$Arch/boot/bzImage ]; then
407       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
408     fi
409     if [ -f arch/$Arch/boot/zImage.stub ]; then
410       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
411     fi
412     if [ "$Flavour" = "uml" ] ; then
413         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
414     fi
415
416     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
417     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
418
419     # And save the headers/makefiles etc for building modules against
420     #
421     # This all looks scary, but the end result is supposed to be:
422     # * all arch relevant include/ files
423     # * all Makefile/Kconfig files
424     # * all script/ files
425
426     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
427     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
428     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
429     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
430     # dirs for additional modules per module-init-tools, kbuild/modules.txt
431     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
432     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
433     # first copy everything
434     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
435         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
436     if [ "$Flavour" = "uml" ] ; then
437       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
438     fi
439     # then drop all but the needed Makefiles/Kconfig files
440     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
441     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
442     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
443     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
444     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
445     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
446     if [ -d arch/%{_arch}/scripts ]; then
447       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
448     fi
449     if [ -f arch/%{_arch}/*lds ]; then
450       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
451     fi
452     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
453     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
454     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
455     cd include
456     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
457     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
458     if [ "$Arch" = "x86_64" ]; then
459       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
460     fi
461 %if %{buildxen}
462     if [ "$Flavour" = "xenU" ]; then
463       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
464       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
465     fi
466 %endif
467 %if %{builduml}
468     if [ "$Flavour" = "uml" ] ; then
469       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
470     fi
471 %endif
472     # While arch/powerpc/include/asm is still a symlink to the old
473     # include/asm-ppc{64,} directory, include that in kernel-devel too.
474     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
475       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
476       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
477       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
478       ln -sf ../../../include/asm-ppc* asm
479       popd
480     fi
481
482     # Make sure the Makefile and version.h have a matching timestamp so that
483     # external modules can be built
484     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
485     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
486     cd ..
487
488     #
489     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
490     #
491 %if "%{_enable_debug_packages}" == "1"
492     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
493     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
494 %endif
495 %if %{buildxen}
496     if [ -f vmlinuz ]; then
497       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
498     fi
499 %endif
500
501     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
502
503     # mark modules executable so that strip-to-file can strip them
504     cat modnames | xargs chmod u+x
505
506     # remove files that will be auto generated by depmod at rpm -i time
507     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
508
509     # Move the devel headers out of the root file system
510     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
511     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
512     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
513     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
514 }
515
516 ###
517 # DO it...
518 ###
519
520 # prepare directories
521 rm -rf $RPM_BUILD_ROOT
522 mkdir -p $RPM_BUILD_ROOT/boot
523
524 %if "%{_target_cpu}" == "x86_64"
525 %define kernel_arch %{_target_cpu}
526 %endif
527 %if "%{_target_cpu}" == "i586"
528 %define kernel_arch i386
529 %endif
530 %if "%{_target_cpu}" == "i686"
531 %define kernel_arch i386
532 %endif
533
534 %if %{buildup}
535 BuildKernel %make_target %kernel_arch
536 %endif
537
538 %ifarch i686
539 %if %{builduml}
540 BuildKernel linux um uml
541 %endif
542
543 %if %{buildxen}
544 BuildKernel vmlinuz %kernel_arch xenU
545 %endif
546 %endif
547
548 ###
549 ### install
550 ###
551
552 %install
553
554 cd vanilla
555
556 %if %{buildxen} && "%{_target_cpu}" == "i686"
557 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
558 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
559 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
560 # This directive teaches ldconfig to search in nosegneg subdirectories
561 # and cache the DSOs there with extra bit 0 set in their hwcap match
562 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
563 # search in nosegneg subdirectories and to match this extra hwcap bit
564 # in the ld.so.cache file.
565 hwcap 0 nosegneg
566 EOF
567 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
568 %endif
569
570 %if %{builddoc}
571 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
572
573 # sometimes non-world-readable files sneak into the kernel source tree
574 chmod -R a+r *
575 # copy the source over
576 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
577 %endif
578
579 ###
580 ### clean
581 ###
582
583 %clean
584 rm -rf $RPM_BUILD_ROOT
585
586 ###
587 ### scripts
588 ###
589
590 # load the loop module for upgrades...in case the old modules get removed we have
591 # loopback in the kernel so that mkinitrd will work.
592 %pre
593 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
594 exit 0
595
596 %post
597 if [ -f /etc/sysconfig/kernel ]; then
598   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
599 fi
600
601 # trick mkinitrd in case the current environment does not have device mapper
602 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
603 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
604     if [ ! -f $rootdev ]; then
605         fake_root_lvm=1
606         mkdir -p $(dirname $rootdev)
607         touch $rootdev
608     fi
609 fi
610
611 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
612 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
613 # Older modutils do not support --package option
614 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
615
616 # remove fake handle
617 if [ -n "$fake_root_lvm" ]; then
618     rm -f $rootdev
619 fi
620
621 # make some useful links
622 pushd /boot > /dev/null ; {
623         ln -sf config-%{KVERREL} config
624         ln -sf config-%{KVERREL} configsmp
625         ln -sf initrd-%{KVERREL}.img initrd-boot
626         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
627         ln -sf vmlinuz-%{KVERREL} kernel-boot
628         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
629 }
630 popd > /dev/null
631
632 # ask for a reboot
633 mkdir -p /etc/planetlab
634 touch /etc/planetlab/update-reboot
635
636 %post devel
637 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
638 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
639   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
640   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
641   popd > /dev/null
642 fi
643
644 %post xenU
645 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
646 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
647
648 %post xenU-devel
649 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
650 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
651   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
652   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
653   popd > /dev/null
654 fi
655
656 %post uml-modules
657 depmod -ae %{KVERREL}uml
658
659 %preun
660 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
661 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
662
663 %preun xenU
664 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
665 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
666
667 %preun uml-modules
668 rm -f /lib/modules/%{KVERREL}uml/modules.*
669
670
671 ###
672 ### file lists
673 ###
674
675 %if %{buildup}
676 %files 
677 %defattr(-,root,root)
678 /%{image_install_path}/vmlinuz-%{KVERREL}
679 /boot/System.map-%{KVERREL}
680 /boot/config-%{KVERREL}
681 %dir /lib/modules/%{KVERREL}
682 /lib/modules/%{KVERREL}/kernel
683 /lib/modules/%{KVERREL}/build
684 /lib/modules/%{KVERREL}/source
685 /lib/modules/%{KVERREL}/extra
686 /lib/modules/%{KVERREL}/updates
687
688 %files devel
689 %defattr(-,root,root)
690 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
691 %endif
692
693 %if %{builduml} && "%{_target_cpu}" == "i686"
694 %files uml
695 %defattr(-,root,root)
696 %{_bindir}/linux
697
698 %files uml-devel
699 %defattr(-,root,root)
700 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
701 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
702
703 %files uml-modules
704 %defattr(-,root,root)
705 /boot/System.map-%{KVERREL}uml
706 /boot/config-%{KVERREL}uml
707 %dir /lib/modules/%{KVERREL}uml
708 /lib/modules/%{KVERREL}uml/kernel
709 /lib/modules/%{KVERREL}uml/build
710 /lib/modules/%{KVERREL}uml/source
711 /lib/modules/%{KVERREL}uml/extra
712 /lib/modules/%{KVERREL}uml/updates
713 %endif
714
715 %if %{buildxen} && "%{_target_cpu}" == "i686"
716 %files xenU
717 %defattr(-,root,root)
718 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
719 /boot/System.map-%{KVERREL}xenU
720 /boot/config-%{KVERREL}xenU
721 %dir /lib/modules/%{KVERREL}xenU
722 /lib/modules/%{KVERREL}xenU/kernel
723 /lib/modules/%{KVERREL}xenU/build
724 /lib/modules/%{KVERREL}xenU/source
725 /lib/modules/%{KVERREL}xenU/extra
726 /lib/modules/%{KVERREL}xenU/updates
727 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
728
729 %files xenU-devel
730 %defattr(-,root,root)
731 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
732 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
733 %endif
734
735 %files vserver
736 %defattr(-,root,root)
737 # no files
738
739 # only some architecture builds need kernel-doc
740
741 %if %{builddoc}
742 %files doc
743 %defattr(-,root,root)
744 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
745 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
746 %dir %{_datadir}/doc/kernel-doc-%{kversion}
747 %endif
748
749 %changelog
750 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
751 - 2.6.17.4
752 - Disable split pagetable lock.
753
754 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
755 - Get rid of stack backtrace on panic, which in most
756   cases actually caused a loss of info instead of a gain.
757
758 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
759 - 2.6.17.3
760
761 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
762 - 2.6.17.2
763 - Fix up the alsa list_add bug.
764
765 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
766 - Fix up various stupidities incurred by the last big rebase.
767   - Reenable SMP x86-64 builds.
768   - Reenable SMBFS.
769 - Enable PCI fake hotplug driver.
770 - Enable gameport/joystick on i586 builds. (#196581)
771
772 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
773 - Enable profiling for 586 kernels.
774
775 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
776 - Rebuild with slab debug off.
777
778 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
779 - 2.6.17.1
780
781 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
782 - 2.6.16.20
783
784 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
785 - 2.6.16.19
786
787 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
788 - Improved list_head debugging.
789
790 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
791 - 2.6.16.18
792
793 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
794 - 2.6.16.17
795
796 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
797 - 2.6.16.16
798
799 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
800 - 2.6.16.15
801 - make 16C950 UARTs work (again). (#126403)
802 - Fix exec-shield default, which should fix a few programs that
803   stopped running.
804
805 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
806 - 2.6.16.14
807
808 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
809 - 2.6.16.13
810
811 * Mon May  1 2006 Dave Jones <davej@redhat.com>
812 - 2.6.16.12
813
814 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
815 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
816
817 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
818 - 2.6.16.11
819
820 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
821 - Enable PCI MSI support.
822
823 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
824 - 2.6.16.9
825
826 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
827 - 2.6.16.7
828
829 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
830 - 2.6.16.6
831
832 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
833 - 2.6.16.5
834
835 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
836 - 2.6.16.2
837
838 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
839 - Reenable non-standard serial ports. (#187466)
840 - Reenable snd-es18xx for x86-32 (#187733)
841
842 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
843 - ship the .kernelrelease file in -devel too.
844 - Disable EDAC debug.
845
846 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
847 - 2.6.16.1
848
849 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
850 - Include patches posted for review for inclusion in 2.6.16.1
851 - Updated new audit msg types.
852 - Reenable HDLC driver (#186257)
853 - Make acpi-cpufreq 'sticky'
854 - Fix broken x86-64 32bit vDSO (#186924)
855
856 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
857 - Improve spinlock scalability on big machines.
858
859 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
860 - Sync with FC5's 2.6.16 kernel.
861 - Update Tux & Exec-shield to latest.
862