eb06720bac81d47d59f7827fbbbddf68abeba4f3
[linux-2.6.git] / kernel-2.6-planetlab.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define builduml 0
8 %define buildxen 0
9 %define builddoc 0
10
11 # Versions of various parts
12
13 #
14 # Polite request for people who spin their own kernel rpms:
15 # please modify the "release" field in a way that identifies
16 # that the kernel isn't the stock distribution kernel, for example by
17 # adding some text to the end of the version number.
18 #
19 %define sublevel 22
20 %define patchlevel 14
21 %define kversion 2.6.%{sublevel}
22 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
23 %define with_netns 1
24
25 %define vsversion 2.3.0.29
26
27 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
28 # updated every time the PL kernel is updated.
29 %define vini_pl_patch 551
30
31 %define specrelease 1
32
33 %define release vs%{vsversion}.%{specrelease}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
34
35 %{!?pldistro:%global pldistro planetlab}
36
37 %define signmodules 0
38 %define make_target bzImage
39 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
40
41 # Override generic defaults with per-arch defaults
42
43 %define image_install_path boot
44
45 #
46 # Three sets of minimum package version requirements in the form of Conflicts:
47 # to versions below the minimum
48 #
49
50 #
51 # First the general kernel 2.6 required versions as per
52 # Documentation/Changes
53 #
54 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
55
56
57 # Then a series of requirements that are distribution specific, either 
58 # because we add patches for something, or the older versions have 
59 # problems with the newer kernel or lack certain things that make 
60 # integration in the distro harder than needed.
61 #
62 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
63
64 #
65 # Several packages had bugs in them that became obvious when the NPTL
66 # threading code got integrated.
67 #
68 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
69
70 #
71 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
72 #
73
74 # MEF commented out
75 # %define xen_conflicts glibc < 2.3.5-1
76
77 #
78 # Packages that need to be installed before the kernel is, because the %post
79 # scripts use them.
80 #
81 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
82
83 URL: http://svn.planet-lab.org/wiki/linux-2.6
84
85 Name: kernel
86 Group: System Environment/Kernel
87 License: GPLv2
88 Version: %{rpmversion}
89 Release: %{release}
90 ExclusiveOS: Linux
91 Provides: kernel = %{version}
92 Provides: kernel-drm = 4.3.0
93 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
94 Provides: kernel-smp = %{rpmversion}-%{release}
95 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
96 Prereq: %{kernel_prereq}
97 Conflicts: %{kernel_dot_org_conflicts}
98 Conflicts: %{package_conflicts}
99 Conflicts: %{nptl_conflicts}
100 # We can't let RPM do the dependencies automatic because it'll then pick up
101 # a correct but undesirable perl dependency from the module headers which
102 # isn't required for the kernel proper to function
103 AutoReqProv: no
104
105 #
106 # List the packages used during the kernel build
107 #
108 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
109 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
110 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
111 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
112
113
114 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
115
116 Source10: kernel-%{kversion}-i586-%{pldistro}.config
117 Source11: kernel-%{kversion}-i686-%{pldistro}.config
118 Source12: kernel-%{kversion}-x86_64-%{pldistro}.config
119 %if %{builduml}
120 Source20: kernel-%{kversion}-i686-uml-%{pldidstro}.config
121 %endif
122 %if %{buildxen}
123 Source30: kernel-%{kversion}-i686-xenU-%{pldistro}.config
124 %endif
125
126 # Mainline patches
127 %if "0%{patchlevel}"
128 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
129 %endif
130
131 Patch010: linux-2.6-010-e1000e.patch
132 Patch020: linux-2.6-020-build-id.patch
133 Patch030: linux-2.6-030-netns.patch
134
135 # These are patches picked up from Fedora/RHEL
136 Patch100: linux-2.6-100-build-nonintconfig.patch
137
138 # Linux-VServer
139 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
140
141 # IP sets
142 Patch250: linux-2.6-250-ipsets.patch
143
144 # PlanetLab
145 Patch500: linux-2.6-500-vserver-filesharing.patch
146 Patch510: linux-2.6-510-ipod.patch
147 Patch520: linux-2.6-520-vnet+.patch
148 Patch530: linux-2.6-530-built-by-support.patch
149 Patch540: linux-2.6-540-oom-kill.patch
150 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
151
152 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
153
154 %description
155 The kernel package contains the Linux kernel (vmlinuz), the core of any
156 Linux operating system.  The kernel handles the basic functions
157 of the operating system:  memory allocation, process allocation, device
158 input and output, etc.
159
160 %package devel
161 Summary: Development package for building kernel modules to match the kernel.
162 Group: System Environment/Kernel
163 AutoReqProv: no
164 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
165 Provides: kernel-smp-devel = %{rpmversion}-%{release}
166 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
167 Prereq: /usr/bin/find
168
169 %description devel
170 This package provides kernel headers and makefiles sufficient to build modules
171 against the kernel package.
172
173
174 %package doc
175 Summary: Various documentation bits found in the kernel source.
176 Group: Documentation
177
178 %description doc
179 This package contains documentation files from the kernel
180 source. Various bits of information about the Linux kernel and the
181 device drivers shipped with it are documented in these files.
182
183 You'll want to install this package if you need a reference to the
184 options that can be passed to Linux kernel modules at load time.
185
186 %package xenU
187 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
188
189 Group: System Environment/Kernel
190 Provides: kernel = %{version}
191 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
192 Prereq: %{kernel_prereq}
193 Conflicts: %{kernel_dot_org_conflicts}
194 Conflicts: %{package_conflicts}
195 Conflicts: %{nptl_conflicts}
196
197 # MEF commented out 
198 # Conflicts: %{xen_conflicts}
199
200 # We can't let RPM do the dependencies automatic because it'll then pick up
201 # a correct but undesirable perl dependency from the module headers which
202 # isn't required for the kernel proper to function
203 AutoReqProv: no
204
205 %description xenU
206 This package includes a version of the Linux kernel which
207 runs in Xen unprivileged guest VMs.  This should be installed
208 both inside the unprivileged guest (for the modules) and in
209 the guest0 domain.
210
211 %package xenU-devel
212 Summary: Development package for building kernel modules to match the kernel.
213 Group: System Environment/Kernel
214 AutoReqProv: no
215 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
216 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
217 Provides: kernel-devel = %{rpmversion}-%{release}xenU
218 Prereq: /usr/sbin/hardlink, /usr/bin/find
219
220 %description xenU-devel
221 This package provides kernel headers and makefiles sufficient to build modules
222 against the kernel package.
223
224 %package uml
225 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
226
227 Group: System Environment/Kernel
228
229 %description uml
230 This package includes a user mode version of the Linux kernel.
231
232 %package uml-devel
233 Summary: Development package for building kernel modules to match the UML kernel.
234 Group: System Environment/Kernel
235 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
236 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
237 Provides: kernel-devel = %{rpmversion}-%{release}smp
238 AutoReqProv: no
239 Prereq: /usr/sbin/hardlink, /usr/bin/find
240
241 %description uml-devel
242 This package provides kernel headers and makefiles sufficient to build modules
243 against the User Mode Linux kernel package.
244
245 %package uml-modules
246 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
247
248 Group: System Environment/Kernel
249
250 %description uml-modules
251 This package includes a user mode version of the Linux kernel modules.
252
253 %package vserver
254 Summary: A placeholder RPM that provides kernel and kernel-drm
255
256 Group: System Environment/Kernel
257 Provides: kernel = %{version}
258 Provides: kernel-drm = 4.3.0
259 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
260
261 %description vserver
262 VServers do not require and cannot use kernels, but some RPMs have
263 implicit or explicit dependencies on the "kernel" package
264 (e.g. tcpdump). This package installs no files but provides the
265 necessary dependencies to make rpm and yum happy.
266
267
268 %prep
269 # First we unpack the kernel tarball.
270 # If this isn't the first make prep, we use links to the existing clean tarball
271 # which speeds things up quite a bit.
272 if [ ! -d kernel-%{kversion}/vanilla ]; then
273   # Ok, first time we do a make prep.
274   rm -f pax_global_header
275 %setup -q -n %{name}-%{kversion} -c
276   mv linux-%{kversion} vanilla
277 else
278   # We already have a vanilla dir.
279   cd kernel-%{kversion}
280 fi
281
282 KERNEL_PREVIOUS=vanilla
283 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
284 %define ApplyPatch() \
285   rm -fr linux-%{kversion}-%1                           \
286   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
287   patchflag=-p1                                         \
288   test "%2" != "%%2" && patchflag="%2"                  \
289   PATCH="%{expand:%{PATCH%1}}"                          \
290   if test ! -e "$PATCH"; then                           \
291     echo "Patch %1 does not exist!"                     \
292     exit 1                                              \
293   fi                                                    \
294   case "$PATCH" in                                      \
295     *.bz2)  bzcat "$PATCH";;                            \
296     *.gz)   zcat "$PATCH";;                             \
297     *)      cat "$PATCH";;                              \
298   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
299   KERNEL_PREVIOUS=linux-%{kversion}-%1
300
301 # This is where the patches get applied
302 %if "0%{patchlevel}"
303 %ApplyPatch 0
304 %endif
305
306 %ApplyPatch 10
307 %ApplyPatch 20
308
309 # NetNS patch for VINI
310 %if 0%{?with_netns}
311 %ApplyPatch 30
312 %endif
313
314 %ApplyPatch 100
315
316 %ApplyPatch 200
317
318 %ApplyPatch 250
319
320 %ApplyPatch 500
321 %ApplyPatch 510
322 %ApplyPatch 520
323 %ApplyPatch 530
324 %ApplyPatch 540
325 %ApplyPatch 550
326
327 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
328 # break with later patches.
329
330 %if 0%{?with_netns}
331 %ApplyPatch %vini_pl_patch
332 %endif
333
334 rm -fr linux-%{kversion}
335 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
336 cd linux-%{kversion}
337
338
339 # make sure the kernel has the sublevel we know it has. This looks weird
340 # but for -pre and -rc versions we need it since we only want to use
341 # the higher version when the final kernel is released.
342 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
343 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
344
345 # get rid of unwanted files resulting from patch fuzz
346 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
347
348
349 ###
350 ### build
351 ###
352 %build
353
354 BuildKernel() {
355     MakeTarget=$1
356     Arch=$2
357     Flavour=$3
358
359     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
360     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
361     cd linux-%{_target_cpu}-%{kversion}$Flavour
362
363     # Pick the right config file for the kernel we're building
364     if [ -n "$Flavour" ] ; then
365       Config=kernel-%{kversion}-%{_target_cpu}-$Flavour-%{pldistro}.config
366       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
367       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
368     else
369       Config=kernel-%{kversion}-%{_target_cpu}-%{pldistro}.config
370       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
371       DevelLink=
372     fi
373
374     KernelVer=%{version}-%{release}$Flavour
375     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
376
377     # make sure EXTRAVERSION says what we want it to say
378     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
379
380     # and now to start the build process
381
382     make -s mrproper
383     cp %{_sourcedir}/$Config .config
384
385     #Arch=`head -1 .config | cut -b 3-`
386     echo USING ARCH=$Arch
387
388     make -s ARCH=$Arch nonint_oldconfig > /dev/null
389     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
390     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
391
392     # Start installing the results
393
394 %if "%{_enable_debug_packages}" == "1"
395     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
396 %endif
397     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
398     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
399     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
400     if [ -f arch/$Arch/boot/bzImage ]; then
401       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
402     fi
403     if [ -f arch/$Arch/boot/zImage.stub ]; then
404       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
405     fi
406     if [ "$Flavour" = "uml" ] ; then
407         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
408     fi
409
410     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
411     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
412
413     # And save the headers/makefiles etc for building modules against
414     #
415     # This all looks scary, but the end result is supposed to be:
416     # * all arch relevant include/ files
417     # * all Makefile/Kconfig files
418     # * all script/ files
419
420     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
421     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
422     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
423     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
424     # dirs for additional modules per module-init-tools, kbuild/modules.txt
425     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
426     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
427     # first copy everything
428     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
429         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
430     if [ "$Flavour" = "uml" ] ; then
431       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
432     fi
433     # then drop all but the needed Makefiles/Kconfig files
434     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
435     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
436     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
437     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
438     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
439     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
440     if [ -d arch/%{_arch}/scripts ]; then
441       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
442     fi
443     if [ -f arch/%{_arch}/*lds ]; then
444       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
445     fi
446     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
447     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
448     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
449     cd include
450     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
451     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
452     if [ "$Arch" = "x86_64" ]; then
453       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
454     fi
455 %if %{buildxen}
456     if [ "$Flavour" = "xenU" ]; then
457       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
458       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
459     fi
460 %endif
461 %if %{builduml}
462     if [ "$Flavour" = "uml" ] ; then
463       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
464     fi
465 %endif
466     # While arch/powerpc/include/asm is still a symlink to the old
467     # include/asm-ppc{64,} directory, include that in kernel-devel too.
468     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
469       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
470       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
471       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
472       ln -sf ../../../include/asm-ppc* asm
473       popd
474     fi
475
476     # Make sure the Makefile and version.h have a matching timestamp so that
477     # external modules can be built
478     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
479     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
480     cd ..
481
482     #
483     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
484     #
485 %if "%{_enable_debug_packages}" == "1"
486     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
487     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
488 %endif
489 %if %{buildxen}
490     if [ -f vmlinuz ]; then
491       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
492     fi
493 %endif
494
495     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
496
497     # mark modules executable so that strip-to-file can strip them
498     cat modnames | xargs chmod u+x
499
500     # remove files that will be auto generated by depmod at rpm -i time
501     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
502
503     # Move the devel headers out of the root file system
504     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
505     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
506     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
507     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
508 }
509
510 ###
511 # DO it...
512 ###
513
514 # prepare directories
515 rm -rf $RPM_BUILD_ROOT
516 mkdir -p $RPM_BUILD_ROOT/boot
517
518 %if "%{_target_cpu}" == "x86_64"
519 %define kernel_arch %{_target_cpu}
520 %endif
521 %if "%{_target_cpu}" == "i586"
522 %define kernel_arch i386
523 %endif
524 %if "%{_target_cpu}" == "i686"
525 %define kernel_arch i386
526 %endif
527
528 %if %{buildup}
529 BuildKernel %make_target %kernel_arch
530 %endif
531
532 %ifarch i686
533 %if %{builduml}
534 BuildKernel linux um uml
535 %endif
536
537 %if %{buildxen}
538 BuildKernel vmlinuz %kernel_arch xenU
539 %endif
540 %endif
541
542 ###
543 ### install
544 ###
545
546 %install
547
548 cd vanilla
549
550 %if %{buildxen} && "%{_target_cpu}" == "i686"
551 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
552 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
553 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
554 # This directive teaches ldconfig to search in nosegneg subdirectories
555 # and cache the DSOs there with extra bit 0 set in their hwcap match
556 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
557 # search in nosegneg subdirectories and to match this extra hwcap bit
558 # in the ld.so.cache file.
559 hwcap 0 nosegneg
560 EOF
561 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
562 %endif
563
564 %if %{builddoc}
565 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
566
567 # sometimes non-world-readable files sneak into the kernel source tree
568 chmod -R a+r *
569 # copy the source over
570 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
571 %endif
572
573 ###
574 ### clean
575 ###
576
577 %clean
578 rm -rf $RPM_BUILD_ROOT
579
580 ###
581 ### scripts
582 ###
583
584 # load the loop module for upgrades...in case the old modules get removed we have
585 # loopback in the kernel so that mkinitrd will work.
586 %pre
587 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
588 exit 0
589
590 %post
591 if [ -f /etc/sysconfig/kernel ]; then
592   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
593 fi
594
595 # trick mkinitrd in case the current environment does not have device mapper
596 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
597 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
598     if [ ! -f $rootdev ]; then
599         fake_root_lvm=1
600         mkdir -p $(dirname $rootdev)
601         touch $rootdev
602     fi
603 fi
604
605 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
606 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
607 # Older modutils do not support --package option
608 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
609
610 # remove fake handle
611 if [ -n "$fake_root_lvm" ]; then
612     rm -f $rootdev
613 fi
614
615 # make some useful links
616 pushd /boot > /dev/null ; {
617         ln -sf config-%{KVERREL} config
618         ln -sf config-%{KVERREL} configsmp
619         ln -sf initrd-%{KVERREL}.img initrd-boot
620         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
621         ln -sf vmlinuz-%{KVERREL} kernel-boot
622         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
623 }
624 popd > /dev/null
625
626 # ask for a reboot
627 mkdir -p /etc/planetlab
628 touch /etc/planetlab/update-reboot
629
630 %post devel
631 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
632 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
633   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
634   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
635   popd > /dev/null
636 fi
637
638 %post xenU
639 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
640 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
641
642 %post xenU-devel
643 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
644 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
645   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
646   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
647   popd > /dev/null
648 fi
649
650 %post uml-modules
651 depmod -ae %{KVERREL}uml
652
653 %preun
654 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
655 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
656
657 %preun xenU
658 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
659 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
660
661 %preun uml-modules
662 rm -f /lib/modules/%{KVERREL}uml/modules.*
663
664
665 ###
666 ### file lists
667 ###
668
669 %if %{buildup}
670 %files 
671 %defattr(-,root,root)
672 /%{image_install_path}/vmlinuz-%{KVERREL}
673 /boot/System.map-%{KVERREL}
674 /boot/config-%{KVERREL}
675 %dir /lib/modules/%{KVERREL}
676 /lib/modules/%{KVERREL}/kernel
677 /lib/modules/%{KVERREL}/build
678 /lib/modules/%{KVERREL}/source
679 /lib/modules/%{KVERREL}/extra
680 /lib/modules/%{KVERREL}/updates
681
682 %files devel
683 %defattr(-,root,root)
684 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
685 %endif
686
687 %if %{builduml} && "%{_target_cpu}" == "i686"
688 %files uml
689 %defattr(-,root,root)
690 %{_bindir}/linux
691
692 %files uml-devel
693 %defattr(-,root,root)
694 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
695 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
696
697 %files uml-modules
698 %defattr(-,root,root)
699 /boot/System.map-%{KVERREL}uml
700 /boot/config-%{KVERREL}uml
701 %dir /lib/modules/%{KVERREL}uml
702 /lib/modules/%{KVERREL}uml/kernel
703 /lib/modules/%{KVERREL}uml/build
704 /lib/modules/%{KVERREL}uml/source
705 /lib/modules/%{KVERREL}uml/extra
706 /lib/modules/%{KVERREL}uml/updates
707 %endif
708
709 %if %{buildxen} && "%{_target_cpu}" == "i686"
710 %files xenU
711 %defattr(-,root,root)
712 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
713 /boot/System.map-%{KVERREL}xenU
714 /boot/config-%{KVERREL}xenU
715 %dir /lib/modules/%{KVERREL}xenU
716 /lib/modules/%{KVERREL}xenU/kernel
717 /lib/modules/%{KVERREL}xenU/build
718 /lib/modules/%{KVERREL}xenU/source
719 /lib/modules/%{KVERREL}xenU/extra
720 /lib/modules/%{KVERREL}xenU/updates
721 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
722
723 %files xenU-devel
724 %defattr(-,root,root)
725 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
726 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
727 %endif
728
729 %files vserver
730 %defattr(-,root,root)
731 # no files
732
733 # only some architecture builds need kernel-doc
734
735 %if %{builddoc}
736 %files doc
737 %defattr(-,root,root)
738 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
739 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
740 %dir %{_datadir}/doc/kernel-doc-%{kversion}
741 %endif
742
743 %changelog
744 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
745 - 2.6.17.4
746 - Disable split pagetable lock.
747
748 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
749 - Get rid of stack backtrace on panic, which in most
750   cases actually caused a loss of info instead of a gain.
751
752 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
753 - 2.6.17.3
754
755 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
756 - 2.6.17.2
757 - Fix up the alsa list_add bug.
758
759 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
760 - Fix up various stupidities incurred by the last big rebase.
761   - Reenable SMP x86-64 builds.
762   - Reenable SMBFS.
763 - Enable PCI fake hotplug driver.
764 - Enable gameport/joystick on i586 builds. (#196581)
765
766 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
767 - Enable profiling for 586 kernels.
768
769 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
770 - Rebuild with slab debug off.
771
772 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
773 - 2.6.17.1
774
775 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
776 - 2.6.16.20
777
778 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
779 - 2.6.16.19
780
781 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
782 - Improved list_head debugging.
783
784 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
785 - 2.6.16.18
786
787 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
788 - 2.6.16.17
789
790 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
791 - 2.6.16.16
792
793 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
794 - 2.6.16.15
795 - make 16C950 UARTs work (again). (#126403)
796 - Fix exec-shield default, which should fix a few programs that
797   stopped running.
798
799 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
800 - 2.6.16.14
801
802 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
803 - 2.6.16.13
804
805 * Mon May  1 2006 Dave Jones <davej@redhat.com>
806 - 2.6.16.12
807
808 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
809 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
810
811 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
812 - 2.6.16.11
813
814 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
815 - Enable PCI MSI support.
816
817 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
818 - 2.6.16.9
819
820 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
821 - 2.6.16.7
822
823 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
824 - 2.6.16.6
825
826 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
827 - 2.6.16.5
828
829 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
830 - 2.6.16.2
831
832 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
833 - Reenable non-standard serial ports. (#187466)
834 - Reenable snd-es18xx for x86-32 (#187733)
835
836 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
837 - ship the .kernelrelease file in -devel too.
838 - Disable EDAC debug.
839
840 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
841 - 2.6.16.1
842
843 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
844 - Include patches posted for review for inclusion in 2.6.16.1
845 - Updated new audit msg types.
846 - Reenable HDLC driver (#186257)
847 - Make acpi-cpufreq 'sticky'
848 - Fix broken x86-64 32bit vDSO (#186924)
849
850 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
851 - Improve spinlock scalability on big machines.
852
853 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
854 - Sync with FC5's 2.6.16 kernel.
855 - Update Tux & Exec-shield to latest.
856