81e6fd0e54432a8f4627de88088fade8c5ab2185
[linux-2.6.git] / kernel-2.6.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 Summary: The Linux kernel (the core of the Linux operating system)
7
8 # What parts do we want to build?  We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
10
11 %define buildup 1
12 %define builduml 0
13 %define buildxen 0
14 %define builddoc 0
15
16 # Versions of various parts
17
18 # for module-tag.py - sublevel is used for the version (middle) part of tag names
19 %define name linux-2.6
20 %define module_version_varname sublevel
21 %define taglevel 1
22
23 #
24 # Polite request for people who spin their own kernel rpms:
25 # please modify the "release" field in a way that identifies
26 # that the kernel isn't the stock distribution kernel, for example by
27 # adding some text to the end of the version number.
28 #
29 %define sublevel 22
30 %define patchlevel 14
31 %define kversion 2.6.%{sublevel}
32 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
33
34 %define vsversion 2.3.0.29
35
36 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
37 # updated every time the PL kernel is updated.
38 %define vini_pl_patch 561
39
40 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
41
42 %{!?pldistro:%global pldistro planetlab}
43
44 %define signmodules 0
45 %define make_target bzImage
46 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
47
48 # Override generic defaults with per-arch defaults
49
50 %define image_install_path boot
51
52 #
53 # Three sets of minimum package version requirements in the form of Conflicts:
54 # to versions below the minimum
55 #
56
57 #
58 # First the general kernel 2.6 required versions as per
59 # Documentation/Changes
60 #
61 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
62
63
64 # Then a series of requirements that are distribution specific, either 
65 # because we add patches for something, or the older versions have 
66 # problems with the newer kernel or lack certain things that make 
67 # integration in the distro harder than needed.
68 #
69 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
70
71 #
72 # Several packages had bugs in them that became obvious when the NPTL
73 # threading code got integrated.
74 #
75 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
76
77 #
78 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
79 #
80
81 # MEF commented out
82 # %define xen_conflicts glibc < 2.3.5-1
83
84 #
85 # Packages that need to be installed before the kernel is, because the %post
86 # scripts use them.
87 #
88 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
89
90 Vendor: PlanetLab
91 Packager: PlanetLab Central <support@planet-lab.org>
92 Distribution: PlanetLab %{plrelease}
93 URL: %(echo %{url} | cut -d ' ' -f 2)
94
95 Name: kernel
96 Group: System Environment/Kernel
97 License: GPLv2
98 Version: %{rpmversion}
99 Release: %{release}
100 ExclusiveOS: Linux
101 Provides: kernel = %{version}
102 Provides: kernel-drm = 4.3.0
103 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
104 Provides: kernel-smp = %{rpmversion}-%{release}
105 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
106 Prereq: %{kernel_prereq}
107 Conflicts: %{kernel_dot_org_conflicts}
108 Conflicts: %{package_conflicts}
109 Conflicts: %{nptl_conflicts}
110 # We can't let RPM do the dependencies automatic because it'll then pick up
111 # a correct but undesirable perl dependency from the module headers which
112 # isn't required for the kernel proper to function
113 AutoReqProv: no
114
115 #
116 # List the packages used during the kernel build
117 #
118 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
119 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
120 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
121 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
122
123
124 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
125
126 Source10: %{pldistro}-%{kversion}-i586.config
127 Source11: %{pldistro}-%{kversion}-i686.config
128 Source12: %{pldistro}-%{kversion}-x86_64.config
129 %if %{builduml}
130 Source20: %{pldistro}-%{kversion}-i686-uml.config
131 %endif
132 %if %{buildxen}
133 Source30: %{pldistro}-%{kversion}-i686-xenU.config
134 %endif
135
136 # Mainline patches
137 %if "0%{patchlevel}"
138 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
139 %endif
140
141 Patch010: linux-2.6-010-e1000e.patch
142 Patch020: linux-2.6-020-build-id.patch
143 Patch030: linux-2.6-030-netns.patch
144
145 # These are patches picked up from Fedora/RHEL
146 Patch100: linux-2.6-100-build-nonintconfig.patch
147
148 # Linux-VServer
149 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
150
151 # IP sets
152 Patch250: linux-2.6-250-ipsets.patch
153
154 # PlanetLab
155 Patch500: linux-2.6-500-vserver-filesharing.patch
156 Patch510: linux-2.6-510-ipod.patch
157 Patch520: linux-2.6-520-vnet+.patch
158 Patch530: linux-2.6-530-built-by-support.patch
159 Patch540: linux-2.6-540-oom-kill.patch
160 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
161 Patch560: linux-2.6-560-mmconf.patch
162 Patch570: linux-2.6-570-tagxid.patch
163
164 # See also the file named 'sources' here for the related checksums
165 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
166 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
167 %define mac80211_version 10.0.4
168 Patch600: http://intellinuxwireless.org/mac80211/downloads/mac80211-%{mac80211_version}.tgz
169 %define iwlwifi_version 1.2.23
170 Patch601: http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-%{iwlwifi_version}.tgz
171
172 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
173
174 %description
175 The kernel package contains the Linux kernel (vmlinuz), the core of any
176 Linux operating system.  The kernel handles the basic functions
177 of the operating system:  memory allocation, process allocation, device
178 input and output, etc.
179
180 %package devel
181 Summary: Development package for building kernel modules to match the kernel.
182 Group: System Environment/Kernel
183 AutoReqProv: no
184 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
185 Provides: kernel-smp-devel = %{rpmversion}-%{release}
186 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
187 Prereq: /usr/bin/find
188
189 %description devel
190 This package provides kernel headers and makefiles sufficient to build modules
191 against the kernel package.
192
193
194 %package doc
195 Summary: Various documentation bits found in the kernel source.
196 Group: Documentation
197
198 %description doc
199 This package contains documentation files from the kernel
200 source. Various bits of information about the Linux kernel and the
201 device drivers shipped with it are documented in these files.
202
203 You'll want to install this package if you need a reference to the
204 options that can be passed to Linux kernel modules at load time.
205
206 %package xenU
207 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
208
209 Group: System Environment/Kernel
210 Provides: kernel = %{version}
211 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
212 Prereq: %{kernel_prereq}
213 Conflicts: %{kernel_dot_org_conflicts}
214 Conflicts: %{package_conflicts}
215 Conflicts: %{nptl_conflicts}
216
217 # MEF commented out 
218 # Conflicts: %{xen_conflicts}
219
220 # We can't let RPM do the dependencies automatic because it'll then pick up
221 # a correct but undesirable perl dependency from the module headers which
222 # isn't required for the kernel proper to function
223 AutoReqProv: no
224
225 %description xenU
226 This package includes a version of the Linux kernel which
227 runs in Xen unprivileged guest VMs.  This should be installed
228 both inside the unprivileged guest (for the modules) and in
229 the guest0 domain.
230
231 %package xenU-devel
232 Summary: Development package for building kernel modules to match the kernel.
233 Group: System Environment/Kernel
234 AutoReqProv: no
235 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
236 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
237 Provides: kernel-devel = %{rpmversion}-%{release}xenU
238 Prereq: /usr/sbin/hardlink, /usr/bin/find
239
240 %description xenU-devel
241 This package provides kernel headers and makefiles sufficient to build modules
242 against the kernel package.
243
244 %package uml
245 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
246
247 Group: System Environment/Kernel
248
249 %description uml
250 This package includes a user mode version of the Linux kernel.
251
252 %package uml-devel
253 Summary: Development package for building kernel modules to match the UML kernel.
254 Group: System Environment/Kernel
255 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
256 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
257 Provides: kernel-devel = %{rpmversion}-%{release}smp
258 AutoReqProv: no
259 Prereq: /usr/sbin/hardlink, /usr/bin/find
260
261 %description uml-devel
262 This package provides kernel headers and makefiles sufficient to build modules
263 against the User Mode Linux kernel package.
264
265 %package uml-modules
266 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
267
268 Group: System Environment/Kernel
269
270 %description uml-modules
271 This package includes a user mode version of the Linux kernel modules.
272
273 %package vserver
274 Summary: A placeholder RPM that provides kernel and kernel-drm
275
276 Group: System Environment/Kernel
277 Provides: kernel = %{version}
278 Provides: kernel-drm = 4.3.0
279 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
280
281 %description vserver
282 VServers do not require and cannot use kernels, but some RPMs have
283 implicit or explicit dependencies on the "kernel" package
284 (e.g. tcpdump). This package installs no files but provides the
285 necessary dependencies to make rpm and yum happy.
286
287
288 %prep
289 # First we unpack the kernel tarball.
290 # If this isn't the first make prep, we use links to the existing clean tarball
291 # which speeds things up quite a bit.
292 if [ ! -d kernel-%{kversion}/vanilla ]; then
293   # Ok, first time we do a make prep.
294   rm -f pax_global_header
295 %setup -q -n %{name}-%{kversion} -c
296   mv linux-%{kversion} vanilla
297 else
298   # We already have a vanilla dir.
299   cd kernel-%{kversion}
300 fi
301
302 KERNEL_PREVIOUS=vanilla
303 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
304 %define ApplyPatch() \
305   rm -fr linux-%{kversion}-%1                           \
306   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
307   patchflag=-p1                                         \
308   test "%2" != "%%2" && patchflag="%2"                  \
309   PATCH="%{expand:%{PATCH%1}}"                          \
310   if test ! -e "$PATCH"; then                           \
311     echo "Patch %1 does not exist!"                     \
312     exit 1                                              \
313   fi                                                    \
314   case "$PATCH" in                                      \
315     *.bz2)  bzcat "$PATCH";;                            \
316     *.gz)   zcat "$PATCH";;                             \
317     *)      cat "$PATCH";;                              \
318   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
319   KERNEL_PREVIOUS=linux-%{kversion}-%1
320
321 # This is where the patches get applied
322 %if "0%{patchlevel}"
323 %ApplyPatch 0
324 %endif
325
326 %ApplyPatch 10
327 %ApplyPatch 20
328
329 # NetNS patch for VINI
330 %if 0%{?with_netns}
331 %ApplyPatch 30
332 %endif
333
334 %ApplyPatch 100
335
336 %ApplyPatch 200
337
338 %ApplyPatch 250
339
340 %ApplyPatch 500
341 %ApplyPatch 510
342 %ApplyPatch 520
343 %ApplyPatch 530
344 %ApplyPatch 540
345 %ApplyPatch 550
346 %ApplyPatch 560
347 %ApplyPatch 570
348
349 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
350 # break with later patches.
351
352 %if 0%{?with_netns}
353 %ApplyPatch %vini_pl_patch
354 %endif
355
356 # Run the mac80211 stuff in the kernel tree holding the last patch
357 tar -xzf %{expand:%{PATCH600}}
358 pushd mac80211-%{mac80211_version}
359 mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
360 make $mac80211_makeflags modified
361 make $mac80211_makeflags source
362 make $mac80211_makeflags patch_kernel
363 popd
364
365 # Untar iwlwifi in the same place - needs to be compiled later
366 tar -xzf %{expand:%{PATCH601}}
367 # the install target is broken: first it does not pass the right -b flag to depmod
368 # second we do not need to invoke depmod at this stage anyway
369 # let's add our own patch/stuff in this Makefile for manual install later on
370 pushd iwlwifi-%{iwlwifi_version}
371 cat >> Makefile <<EOF
372 module-list:
373         @echo \$(addprefix \$(DIR),\$(addsuffix .ko,\$(list-m)))
374 EOF
375 popd
376
377 rm -fr linux-%{kversion}
378 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
379 cd linux-%{kversion}
380
381
382 # make sure the kernel has the sublevel we know it has. This looks weird
383 # but for -pre and -rc versions we need it since we only want to use
384 # the higher version when the final kernel is released.
385 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
386 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
387
388 # get rid of unwanted files resulting from patch fuzz
389 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
390
391
392 ###
393 ### build
394 ###
395 %build
396
397 BuildKernel() {
398     MakeTarget=$1
399     Arch=$2
400     Flavour=$3
401
402     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
403     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
404     cd linux-%{_target_cpu}-%{kversion}$Flavour
405
406     # Pick the right config file for the kernel we're building
407     if [ -n "$Flavour" ] ; then
408       Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
409       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
410       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
411     else
412       Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
413       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
414       DevelLink=
415     fi
416
417     KernelVer=%{version}-%{release}$Flavour
418     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
419
420     # make sure EXTRAVERSION says what we want it to say
421     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
422
423     # and now to start the build process
424
425     make -s mrproper
426     cp %{_sourcedir}/$Config .config
427
428     #Arch=`head -1 .config | cut -b 3-`
429     echo USING ARCH=$Arch
430
431     make -s ARCH=$Arch nonint_oldconfig > /dev/null
432     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
433     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
434
435     # build the iwlwifi driver
436     make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
437          KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour
438
439     # Start installing the results
440
441 %if "%{_enable_debug_packages}" == "1"
442     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
443 %endif
444     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
445     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
446     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
447     if [ -f arch/$Arch/boot/bzImage ]; then
448       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
449     fi
450     if [ -f arch/$Arch/boot/zImage.stub ]; then
451       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
452     fi
453     if [ "$Flavour" = "uml" ] ; then
454         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
455     fi
456
457     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
458     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
459
460     # install iwlwifi
461 #    make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
462 #         KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour \
463 #        KMISC=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless install
464     pushd %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version}
465     iwlwifi_dest=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless
466     # get the list and location of modules to install - no need to pass KSRC nor anything, let's keep it simple
467     iwlwifi_modules=$(make --no-print-directory module-list)
468     install -d $iwlwifi_dest
469     install -m 644 -c $iwlwifi_modules $iwlwifi_dest
470     popd
471
472     # And save the headers/makefiles etc for building modules against
473     #
474     # This all looks scary, but the end result is supposed to be:
475     # * all arch relevant include/ files
476     # * all Makefile/Kconfig files
477     # * all script/ files
478
479     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
480     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
481     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
482     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
483     # dirs for additional modules per module-init-tools, kbuild/modules.txt
484     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
485     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
486     # first copy everything
487     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
488         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
489     if [ "$Flavour" = "uml" ] ; then
490       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
491     fi
492     # then drop all but the needed Makefiles/Kconfig files
493     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
494     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
495     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
496     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
497     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
498     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
499     if [ -d arch/%{_arch}/scripts ]; then
500       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
501     fi
502     if [ -f arch/%{_arch}/*lds ]; then
503       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
504     fi
505     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
506     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
507     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
508     cd include
509     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
510     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
511     if [ "$Arch" = "x86_64" ]; then
512       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
513     fi
514 %if %{buildxen}
515     if [ "$Flavour" = "xenU" ]; then
516       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
517       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
518     fi
519 %endif
520 %if %{builduml}
521     if [ "$Flavour" = "uml" ] ; then
522       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
523     fi
524 %endif
525     # While arch/powerpc/include/asm is still a symlink to the old
526     # include/asm-ppc{64,} directory, include that in kernel-devel too.
527     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
528       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
529       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
530       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
531       ln -sf ../../../include/asm-ppc* asm
532       popd
533     fi
534
535     # Make sure the Makefile and version.h have a matching timestamp so that
536     # external modules can be built
537     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
538     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
539     cd ..
540
541     #
542     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
543     #
544 %if "%{_enable_debug_packages}" == "1"
545     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
546     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
547 %endif
548 %if %{buildxen}
549     if [ -f vmlinuz ]; then
550       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
551     fi
552 %endif
553
554     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
555
556     # mark modules executable so that strip-to-file can strip them
557     cat modnames | xargs chmod u+x
558
559     # remove files that will be auto generated by depmod at rpm -i time
560     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
561
562     # Move the devel headers out of the root file system
563     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
564     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
565     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
566     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
567 }
568
569 ###
570 # DO it...
571 ###
572
573 # prepare directories
574 rm -rf $RPM_BUILD_ROOT
575 mkdir -p $RPM_BUILD_ROOT/boot
576
577 %if "%{_target_cpu}" == "x86_64"
578 %define kernel_arch %{_target_cpu}
579 %endif
580 %if "%{_target_cpu}" == "i586"
581 %define kernel_arch i386
582 %endif
583 %if "%{_target_cpu}" == "i686"
584 %define kernel_arch i386
585 %endif
586
587 %if %{buildup}
588 BuildKernel %make_target %kernel_arch
589 %endif
590
591 %ifarch i686
592 %if %{builduml}
593 BuildKernel linux um uml
594 %endif
595
596 %if %{buildxen}
597 BuildKernel vmlinuz %kernel_arch xenU
598 %endif
599 %endif
600
601 ###
602 ### install
603 ###
604
605 %install
606
607 cd vanilla
608
609 %if %{buildxen} && "%{_target_cpu}" == "i686"
610 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
611 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
612 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
613 # This directive teaches ldconfig to search in nosegneg subdirectories
614 # and cache the DSOs there with extra bit 0 set in their hwcap match
615 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
616 # search in nosegneg subdirectories and to match this extra hwcap bit
617 # in the ld.so.cache file.
618 hwcap 0 nosegneg
619 EOF
620 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
621 %endif
622
623 %if %{builddoc}
624 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
625
626 # sometimes non-world-readable files sneak into the kernel source tree
627 chmod -R a+r *
628 # copy the source over
629 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
630 %endif
631
632 ###
633 ### clean
634 ###
635
636 %clean
637 rm -rf $RPM_BUILD_ROOT
638
639 ###
640 ### scripts
641 ###
642
643 # load the loop module for upgrades...in case the old modules get removed we have
644 # loopback in the kernel so that mkinitrd will work.
645 %pre
646 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
647 exit 0
648
649 %post
650 if [ -f /etc/sysconfig/kernel ]; then
651   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
652 fi
653
654 # trick mkinitrd in case the current environment does not have device mapper
655 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
656 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
657     if [ ! -f $rootdev ]; then
658         fake_root_lvm=1
659         mkdir -p $(dirname $rootdev)
660         touch $rootdev
661     fi
662 fi
663
664 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
665 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
666 # Older modutils do not support --package option
667 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
668
669 # remove fake handle
670 if [ -n "$fake_root_lvm" ]; then
671     rm -f $rootdev
672 fi
673
674 # make some useful links
675 pushd /boot > /dev/null ; {
676         ln -sf config-%{KVERREL} config
677         ln -sf config-%{KVERREL} configsmp
678         ln -sf initrd-%{KVERREL}.img initrd-boot
679         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
680         ln -sf vmlinuz-%{KVERREL} kernel-boot
681         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
682 }
683 popd > /dev/null
684
685 # ask for a reboot
686 mkdir -p /etc/planetlab
687 touch /etc/planetlab/update-reboot
688
689 %post devel
690 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
691 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
692   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
693   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
694   popd > /dev/null
695 fi
696
697 %post xenU
698 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
699 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
700
701 %post xenU-devel
702 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
703 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
704   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
705   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
706   popd > /dev/null
707 fi
708
709 %post uml-modules
710 depmod -ae %{KVERREL}uml
711
712 %preun
713 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
714 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
715
716 %preun xenU
717 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
718 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
719
720 %preun uml-modules
721 rm -f /lib/modules/%{KVERREL}uml/modules.*
722
723
724 ###
725 ### file lists
726 ###
727
728 %if %{buildup}
729 %files 
730 %defattr(-,root,root)
731 /%{image_install_path}/vmlinuz-%{KVERREL}
732 /boot/System.map-%{KVERREL}
733 /boot/config-%{KVERREL}
734 %dir /lib/modules/%{KVERREL}
735 /lib/modules/%{KVERREL}/kernel
736 /lib/modules/%{KVERREL}/build
737 /lib/modules/%{KVERREL}/source
738 /lib/modules/%{KVERREL}/extra
739 /lib/modules/%{KVERREL}/updates
740
741 %files devel
742 %defattr(-,root,root)
743 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
744 %endif
745
746 %if %{builduml} && "%{_target_cpu}" == "i686"
747 %files uml
748 %defattr(-,root,root)
749 %{_bindir}/linux
750
751 %files uml-devel
752 %defattr(-,root,root)
753 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
754 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
755
756 %files uml-modules
757 %defattr(-,root,root)
758 /boot/System.map-%{KVERREL}uml
759 /boot/config-%{KVERREL}uml
760 %dir /lib/modules/%{KVERREL}uml
761 /lib/modules/%{KVERREL}uml/kernel
762 /lib/modules/%{KVERREL}uml/build
763 /lib/modules/%{KVERREL}uml/source
764 /lib/modules/%{KVERREL}uml/extra
765 /lib/modules/%{KVERREL}uml/updates
766 %endif
767
768 %if %{buildxen} && "%{_target_cpu}" == "i686"
769 %files xenU
770 %defattr(-,root,root)
771 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
772 /boot/System.map-%{KVERREL}xenU
773 /boot/config-%{KVERREL}xenU
774 %dir /lib/modules/%{KVERREL}xenU
775 /lib/modules/%{KVERREL}xenU/kernel
776 /lib/modules/%{KVERREL}xenU/build
777 /lib/modules/%{KVERREL}xenU/source
778 /lib/modules/%{KVERREL}xenU/extra
779 /lib/modules/%{KVERREL}xenU/updates
780 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
781
782 %files xenU-devel
783 %defattr(-,root,root)
784 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
785 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
786 %endif
787
788 %files vserver
789 %defattr(-,root,root)
790 # no files
791
792 # only some architecture builds need kernel-doc
793
794 %if %{builddoc}
795 %files doc
796 %defattr(-,root,root)
797 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
798 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
799 %dir %{_datadir}/doc/kernel-doc-%{kversion}
800 %endif
801
802 %changelog
803 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
804 - 2.6.17.4
805 - Disable split pagetable lock.
806
807 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
808 - Get rid of stack backtrace on panic, which in most
809   cases actually caused a loss of info instead of a gain.
810
811 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
812 - 2.6.17.3
813
814 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
815 - 2.6.17.2
816 - Fix up the alsa list_add bug.
817
818 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
819 - Fix up various stupidities incurred by the last big rebase.
820   - Reenable SMP x86-64 builds.
821   - Reenable SMBFS.
822 - Enable PCI fake hotplug driver.
823 - Enable gameport/joystick on i586 builds. (#196581)
824
825 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
826 - Enable profiling for 586 kernels.
827
828 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
829 - Rebuild with slab debug off.
830
831 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
832 - 2.6.17.1
833
834 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
835 - 2.6.16.20
836
837 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
838 - 2.6.16.19
839
840 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
841 - Improved list_head debugging.
842
843 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
844 - 2.6.16.18
845
846 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
847 - 2.6.16.17
848
849 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
850 - 2.6.16.16
851
852 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
853 - 2.6.16.15
854 - make 16C950 UARTs work (again). (#126403)
855 - Fix exec-shield default, which should fix a few programs that
856   stopped running.
857
858 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
859 - 2.6.16.14
860
861 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
862 - 2.6.16.13
863
864 * Mon May  1 2006 Dave Jones <davej@redhat.com>
865 - 2.6.16.12
866
867 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
868 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
869
870 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
871 - 2.6.16.11
872
873 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
874 - Enable PCI MSI support.
875
876 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
877 - 2.6.16.9
878
879 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
880 - 2.6.16.7
881
882 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
883 - 2.6.16.6
884
885 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
886 - 2.6.16.5
887
888 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
889 - 2.6.16.2
890
891 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
892 - Reenable non-standard serial ports. (#187466)
893 - Reenable snd-es18xx for x86-32 (#187733)
894
895 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
896 - ship the .kernelrelease file in -devel too.
897 - Disable EDAC debug.
898
899 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
900 - 2.6.16.1
901
902 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
903 - Include patches posted for review for inclusion in 2.6.16.1
904 - Updated new audit msg types.
905 - Reenable HDLC driver (#186257)
906 - Make acpi-cpufreq 'sticky'
907 - Fix broken x86-64 32bit vDSO (#186924)
908
909 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
910 - Improve spinlock scalability on big machines.
911
912 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
913 - Sync with FC5's 2.6.16 kernel.
914 - Update Tux & Exec-shield to latest.
915