dd0e51d66a7d8c6211c38aee553bdda4445eea85
[linux-2.6.git] / kernel-2.6.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define builduml 0
8 %define buildxen 0
9 %define builddoc 0
10
11 # Versions of various parts
12
13 %define _with_netns 1
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 22
22 %define patchlevel 14
23 %define kversion 2.6.%{sublevel}
24 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
25
26 %define vsversion 2.3.0.32
27
28 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
29 # updated every time the PL kernel is updated.
30 %define vini_pl_patch 561
31
32 %define specrelease 1
33
34 %define release vs%{vsversion}.%{specrelease}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
35
36 %{!?pldistro:%global pldistro planetlab}
37
38 %define signmodules 0
39 %define make_target bzImage
40 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
41
42 # Override generic defaults with per-arch defaults
43
44 %define image_install_path boot
45
46 #
47 # Three sets of minimum package version requirements in the form of Conflicts:
48 # to versions below the minimum
49 #
50
51 #
52 # First the general kernel 2.6 required versions as per
53 # Documentation/Changes
54 #
55 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
56
57
58 # Then a series of requirements that are distribution specific, either 
59 # because we add patches for something, or the older versions have 
60 # problems with the newer kernel or lack certain things that make 
61 # integration in the distro harder than needed.
62 #
63 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
64
65 #
66 # Several packages had bugs in them that became obvious when the NPTL
67 # threading code got integrated.
68 #
69 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
70
71 #
72 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
73 #
74
75 # MEF commented out
76 # %define xen_conflicts glibc < 2.3.5-1
77
78 #
79 # Packages that need to be installed before the kernel is, because the %post
80 # scripts use them.
81 #
82 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
83
84 URL: http://svn.planet-lab.org/wiki/linux-2.6
85
86 Name: kernel
87 Group: System Environment/Kernel
88 License: GPLv2
89 Version: %{rpmversion}
90 Release: %{release}
91 ExclusiveOS: Linux
92 Provides: kernel = %{version}
93 Provides: kernel-drm = 4.3.0
94 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
95 Provides: kernel-smp = %{rpmversion}-%{release}
96 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
97 Prereq: %{kernel_prereq}
98 Conflicts: %{kernel_dot_org_conflicts}
99 Conflicts: %{package_conflicts}
100 Conflicts: %{nptl_conflicts}
101 # We can't let RPM do the dependencies automatic because it'll then pick up
102 # a correct but undesirable perl dependency from the module headers which
103 # isn't required for the kernel proper to function
104 AutoReqProv: no
105
106 #
107 # List the packages used during the kernel build
108 #
109 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
110 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
111 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
112 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
113
114
115 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
116
117 Source10: kernel-%{kversion}-i586-%{pldistro}.config
118 Source11: kernel-%{kversion}-i686-%{pldistro}.config
119 Source12: kernel-%{kversion}-x86_64-%{pldistro}.config
120 %if %{builduml}
121 Source20: kernel-%{kversion}-i686-uml-%{pldidstro}.config
122 %endif
123 %if %{buildxen}
124 Source30: kernel-%{kversion}-i686-xenU-%{pldistro}.config
125 %endif
126
127 # Mainline patches
128 %if "0%{patchlevel}"
129 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
130 %endif
131
132 Patch010: linux-2.6-010-e1000e.patch
133 Patch020: linux-2.6-020-build-id.patch
134 Patch030: linux-2.6-030-netns.patch
135
136 # These are patches picked up from Fedora/RHEL
137 Patch100: linux-2.6-100-build-nonintconfig.patch
138
139 # Linux-VServer
140 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
141 Patch210: linux-2.6-210-vserver-cpu-sched.patch
142 Patch220: linux-2.6-220-lback-feat02.diff
143
144 # IP sets
145 Patch250: linux-2.6-250-ipsets.patch
146
147 # PlanetLab
148 Patch500: linux-2.6-500-vserver-filesharing.patch
149 Patch510: linux-2.6-510-ipod.patch
150 Patch520: linux-2.6-520-vnet+.patch
151 Patch530: linux-2.6-530-built-by-support.patch
152 Patch540: linux-2.6-540-oom-kill.patch
153 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
154 Patch560: linux-2.6-560-mmconf.patch
155 Patch570: linux-2.6-570-tagxid.patch
156 Patch580: linux-2.6-580-show-proc-virt.patch 
157 Patch590: linux-2.6-590-chopstix-intern.patch
158
159 # VINI
160 Patch700: linux-2.6-700-trellis-mm1-netns.patch
161 Patch710: linux-2.6-710-unshare-netns.patch
162 Patch720: linux-2.6-720-ztun-sb.patch
163 Patch730: linux-2.6-730-egre.patch
164 Patch740: linux-2.6-740-new_ns_pid.patch
165 Patch750: linux-2.6-750-vserver-setspace.patch
166 Patch760: linux-2.6-760-unshare-netns-fix.patch
167
168 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
169
170 %description
171 The kernel package contains the Linux kernel (vmlinuz), the core of any
172 Linux operating system.  The kernel handles the basic functions
173 of the operating system:  memory allocation, process allocation, device
174 input and output, etc.
175
176 %package devel
177 Summary: Development package for building kernel modules to match the kernel.
178 Group: System Environment/Kernel
179 AutoReqProv: no
180 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
181 Provides: kernel-smp-devel = %{rpmversion}-%{release}
182 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
183 Prereq: /usr/bin/find
184
185 %description devel
186 This package provides kernel headers and makefiles sufficient to build modules
187 against the kernel package.
188
189
190 %package doc
191 Summary: Various documentation bits found in the kernel source.
192 Group: Documentation
193
194 %description doc
195 This package contains documentation files from the kernel
196 source. Various bits of information about the Linux kernel and the
197 device drivers shipped with it are documented in these files.
198
199 You'll want to install this package if you need a reference to the
200 options that can be passed to Linux kernel modules at load time.
201
202 %package xenU
203 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
204
205 Group: System Environment/Kernel
206 Provides: kernel = %{version}
207 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
208 Prereq: %{kernel_prereq}
209 Conflicts: %{kernel_dot_org_conflicts}
210 Conflicts: %{package_conflicts}
211 Conflicts: %{nptl_conflicts}
212
213 # MEF commented out 
214 # Conflicts: %{xen_conflicts}
215
216 # We can't let RPM do the dependencies automatic because it'll then pick up
217 # a correct but undesirable perl dependency from the module headers which
218 # isn't required for the kernel proper to function
219 AutoReqProv: no
220
221 %description xenU
222 This package includes a version of the Linux kernel which
223 runs in Xen unprivileged guest VMs.  This should be installed
224 both inside the unprivileged guest (for the modules) and in
225 the guest0 domain.
226
227 %package xenU-devel
228 Summary: Development package for building kernel modules to match the kernel.
229 Group: System Environment/Kernel
230 AutoReqProv: no
231 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
232 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
233 Provides: kernel-devel = %{rpmversion}-%{release}xenU
234 Prereq: /usr/sbin/hardlink, /usr/bin/find
235
236 %description xenU-devel
237 This package provides kernel headers and makefiles sufficient to build modules
238 against the kernel package.
239
240 %package uml
241 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
242
243 Group: System Environment/Kernel
244
245 %description uml
246 This package includes a user mode version of the Linux kernel.
247
248 %package uml-devel
249 Summary: Development package for building kernel modules to match the UML kernel.
250 Group: System Environment/Kernel
251 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
252 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
253 Provides: kernel-devel = %{rpmversion}-%{release}smp
254 AutoReqProv: no
255 Prereq: /usr/sbin/hardlink, /usr/bin/find
256
257 %description uml-devel
258 This package provides kernel headers and makefiles sufficient to build modules
259 against the User Mode Linux kernel package.
260
261 %package uml-modules
262 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
263
264 Group: System Environment/Kernel
265
266 %description uml-modules
267 This package includes a user mode version of the Linux kernel modules.
268
269 %package vserver
270 Summary: A placeholder RPM that provides kernel and kernel-drm
271
272 Group: System Environment/Kernel
273 Provides: kernel = %{version}
274 Provides: kernel-drm = 4.3.0
275 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
276
277 %description vserver
278 VServers do not require and cannot use kernels, but some RPMs have
279 implicit or explicit dependencies on the "kernel" package
280 (e.g. tcpdump). This package installs no files but provides the
281 necessary dependencies to make rpm and yum happy.
282
283
284 %prep
285 # First we unpack the kernel tarball.
286 # If this isn't the first make prep, we use links to the existing clean tarball
287 # which speeds things up quite a bit.
288 if [ ! -d kernel-%{kversion}/vanilla ]; then
289   # Ok, first time we do a make prep.
290   rm -f pax_global_header
291 %setup -q -n %{name}-%{kversion} -c
292   mv linux-%{kversion} vanilla
293 else
294   # We already have a vanilla dir.
295   cd kernel-%{kversion}
296 fi
297
298 KERNEL_PREVIOUS=vanilla
299 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
300 %define ApplyPatch() \
301   rm -fr linux-%{kversion}-%1                           \
302   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
303   patchflag=-p1                                         \
304   test "%2" != "%%2" && patchflag="%2"                  \
305   PATCH="%{expand:%{PATCH%1}}"                          \
306   if test ! -e "$PATCH"; then                           \
307     echo "Patch %1 does not exist!"                     \
308     exit 1                                              \
309   fi                                                    \
310   case "$PATCH" in                                      \
311     *.bz2)  bzcat "$PATCH";;                            \
312     *.gz)   zcat "$PATCH";;                             \
313     *)      cat "$PATCH";;                              \
314   esac | patch -s -d linux-%{kversion}-%1 $patchflag \
315   KERNEL_PREVIOUS=linux-%{kversion}-%1
316
317 # This is where the patches get applied
318 %if "0%{patchlevel}"
319 %ApplyPatch 0
320 %endif
321
322 %ApplyPatch 10
323 %ApplyPatch 20
324
325 %ApplyPatch 100
326
327 %ApplyPatch 200
328 %ApplyPatch 210
329 %ApplyPatch 220
330
331 %ApplyPatch 250
332
333 %ApplyPatch 500
334 %ApplyPatch 510
335 %ApplyPatch 520
336 %ApplyPatch 530
337 %ApplyPatch 540
338 %ApplyPatch 550
339 %ApplyPatch 560
340 %ApplyPatch 570
341 %ApplyPatch 580
342 %ApplyPatch 590
343
344
345 %if 0%{?_with_netns}
346 %ApplyPatch 700
347 %ApplyPatch 710
348 %ApplyPatch 720
349 %ApplyPatch 730
350 %ApplyPatch 740
351 %ApplyPatch 750
352 %ApplyPatch 760
353 %endif
354
355 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
356 # break with later patches.
357
358 rm -fr linux-%{kversion}
359 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
360 cd linux-%{kversion}
361
362
363 # make sure the kernel has the sublevel we know it has. This looks weird
364 # but for -pre and -rc versions we need it since we only want to use
365 # the higher version when the final kernel is released.
366 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
367 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
368
369 # get rid of unwanted files resulting from patch fuzz
370 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
371
372
373 ###
374 ### build
375 ###
376 %build
377
378 BuildKernel() {
379     MakeTarget=$1
380     Arch=$2
381     Flavour=$3
382
383     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
384     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
385     cd linux-%{_target_cpu}-%{kversion}$Flavour
386
387     # Pick the right config file for the kernel we're building
388     if [ -n "$Flavour" ] ; then
389       Config=kernel-%{kversion}-%{_target_cpu}-$Flavour-%{pldistro}.config
390       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
391       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
392     else
393       Config=kernel-%{kversion}-%{_target_cpu}-%{pldistro}.config
394       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
395       DevelLink=
396     fi
397
398     KernelVer=%{version}-%{release}$Flavour
399     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
400
401     # make sure EXTRAVERSION says what we want it to say
402     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
403
404     # and now to start the build process
405
406     make -s mrproper
407     cp %{_sourcedir}/$Config .config
408
409     #Arch=`head -1 .config | cut -b 3-`
410     echo USING ARCH=$Arch
411
412     make -s ARCH=$Arch nonint_oldconfig > /dev/null
413     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
414     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
415
416     # Start installing the results
417
418 %if "%{_enable_debug_packages}" == "1"
419     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
420 %endif
421     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
422     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
423     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
424     if [ -f arch/$Arch/boot/bzImage ]; then
425       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
426     fi
427     if [ -f arch/$Arch/boot/zImage.stub ]; then
428       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
429     fi
430     if [ "$Flavour" = "uml" ] ; then
431         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
432     fi
433
434     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
435     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
436
437     # And save the headers/makefiles etc for building modules against
438     #
439     # This all looks scary, but the end result is supposed to be:
440     # * all arch relevant include/ files
441     # * all Makefile/Kconfig files
442     # * all script/ files
443
444     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
445     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
446     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
447     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
448     # dirs for additional modules per module-init-tools, kbuild/modules.txt
449     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
450     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
451     # first copy everything
452     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
453         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
454     if [ "$Flavour" = "uml" ] ; then
455       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
456     fi
457     # then drop all but the needed Makefiles/Kconfig files
458     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
459     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
460     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
461     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
462     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
463     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
464     if [ -d arch/%{_arch}/scripts ]; then
465       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
466     fi
467     if [ -f arch/%{_arch}/*lds ]; then
468       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
469     fi
470     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
471     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
472     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
473     cd include
474     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
475     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
476     if [ "$Arch" = "x86_64" ]; then
477       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
478     fi
479 %if %{buildxen}
480     if [ "$Flavour" = "xenU" ]; then
481       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
482       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
483     fi
484 %endif
485 %if %{builduml}
486     if [ "$Flavour" = "uml" ] ; then
487       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
488     fi
489 %endif
490     # While arch/powerpc/include/asm is still a symlink to the old
491     # include/asm-ppc{64,} directory, include that in kernel-devel too.
492     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
493       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
494       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
495       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
496       ln -sf ../../../include/asm-ppc* asm
497       popd
498     fi
499
500     # Make sure the Makefile and version.h have a matching timestamp so that
501     # external modules can be built
502     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
503     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
504     cd ..
505
506     #
507     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
508     #
509 %if "%{_enable_debug_packages}" == "1"
510     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
511     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
512 %endif
513 %if %{buildxen}
514     if [ -f vmlinuz ]; then
515       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
516     fi
517 %endif
518
519     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
520
521     # mark modules executable so that strip-to-file can strip them
522     cat modnames | xargs chmod u+x
523
524     # remove files that will be auto generated by depmod at rpm -i time
525     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
526
527     # Move the devel headers out of the root file system
528     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
529     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
530     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
531     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
532 }
533
534 ###
535 # DO it...
536 ###
537
538 # prepare directories
539 rm -rf $RPM_BUILD_ROOT
540 mkdir -p $RPM_BUILD_ROOT/boot
541
542 %if "%{_target_cpu}" == "x86_64"
543 %define kernel_arch %{_target_cpu}
544 %endif
545 %if "%{_target_cpu}" == "i586"
546 %define kernel_arch i386
547 %endif
548 %if "%{_target_cpu}" == "i686"
549 %define kernel_arch i386
550 %endif
551
552 %if %{buildup}
553 BuildKernel %make_target %kernel_arch
554 %endif
555
556 %ifarch i686
557 %if %{builduml}
558 BuildKernel linux um uml
559 %endif
560
561 %if %{buildxen}
562 BuildKernel vmlinuz %kernel_arch xenU
563 %endif
564 %endif
565
566 ###
567 ### install
568 ###
569
570 %install
571
572 cd vanilla
573
574 %if %{buildxen} && "%{_target_cpu}" == "i686"
575 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
576 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
577 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
578 # This directive teaches ldconfig to search in nosegneg subdirectories
579 # and cache the DSOs there with extra bit 0 set in their hwcap match
580 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
581 # search in nosegneg subdirectories and to match this extra hwcap bit
582 # in the ld.so.cache file.
583 hwcap 0 nosegneg
584 EOF
585 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
586 %endif
587
588 %if %{builddoc}
589 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
590
591 # sometimes non-world-readable files sneak into the kernel source tree
592 chmod -R a+r *
593 # copy the source over
594 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
595 %endif
596
597 ###
598 ### clean
599 ###
600
601 %clean
602 rm -rf $RPM_BUILD_ROOT
603
604 ###
605 ### scripts
606 ###
607
608 # load the loop module for upgrades...in case the old modules get removed we have
609 # loopback in the kernel so that mkinitrd will work.
610 %pre
611 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
612 exit 0
613
614 %post
615 if [ -f /etc/sysconfig/kernel ]; then
616   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
617 fi
618
619 # trick mkinitrd in case the current environment does not have device mapper
620 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
621 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
622     if [ ! -f $rootdev ]; then
623         fake_root_lvm=1
624         mkdir -p $(dirname $rootdev)
625         touch $rootdev
626     fi
627 fi
628
629 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
630 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
631 # Older modutils do not support --package option
632 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
633
634 # remove fake handle
635 if [ -n "$fake_root_lvm" ]; then
636     rm -f $rootdev
637 fi
638
639 # make some useful links
640 pushd /boot > /dev/null ; {
641         ln -sf config-%{KVERREL} config
642         ln -sf config-%{KVERREL} configsmp
643         ln -sf initrd-%{KVERREL}.img initrd-boot
644         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
645         ln -sf vmlinuz-%{KVERREL} kernel-boot
646         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
647 }
648 popd > /dev/null
649
650 # ask for a reboot
651 mkdir -p /etc/planetlab
652 touch /etc/planetlab/update-reboot
653
654 %post devel
655 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
656 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
657   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
658   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
659   popd > /dev/null
660 fi
661
662 %post xenU
663 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
664 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
665
666 %post xenU-devel
667 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
668 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
669   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
670   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
671   popd > /dev/null
672 fi
673
674 %post uml-modules
675 depmod -ae %{KVERREL}uml
676
677 %preun
678 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
679 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
680
681 %preun xenU
682 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
683 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
684
685 %preun uml-modules
686 rm -f /lib/modules/%{KVERREL}uml/modules.*
687
688
689 ###
690 ### file lists
691 ###
692
693 %if %{buildup}
694 %files 
695 %defattr(-,root,root)
696 /%{image_install_path}/vmlinuz-%{KVERREL}
697 /boot/System.map-%{KVERREL}
698 /boot/config-%{KVERREL}
699 %dir /lib/modules/%{KVERREL}
700 /lib/modules/%{KVERREL}/kernel
701 /lib/modules/%{KVERREL}/build
702 /lib/modules/%{KVERREL}/source
703 /lib/modules/%{KVERREL}/extra
704 /lib/modules/%{KVERREL}/updates
705
706 %files devel
707 %defattr(-,root,root)
708 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
709 %endif
710
711 %if %{builduml} && "%{_target_cpu}" == "i686"
712 %files uml
713 %defattr(-,root,root)
714 %{_bindir}/linux
715
716 %files uml-devel
717 %defattr(-,root,root)
718 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
719 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
720
721 %files uml-modules
722 %defattr(-,root,root)
723 /boot/System.map-%{KVERREL}uml
724 /boot/config-%{KVERREL}uml
725 %dir /lib/modules/%{KVERREL}uml
726 /lib/modules/%{KVERREL}uml/kernel
727 /lib/modules/%{KVERREL}uml/build
728 /lib/modules/%{KVERREL}uml/source
729 /lib/modules/%{KVERREL}uml/extra
730 /lib/modules/%{KVERREL}uml/updates
731 %endif
732
733 %if %{buildxen} && "%{_target_cpu}" == "i686"
734 %files xenU
735 %defattr(-,root,root)
736 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
737 /boot/System.map-%{KVERREL}xenU
738 /boot/config-%{KVERREL}xenU
739 %dir /lib/modules/%{KVERREL}xenU
740 /lib/modules/%{KVERREL}xenU/kernel
741 /lib/modules/%{KVERREL}xenU/build
742 /lib/modules/%{KVERREL}xenU/source
743 /lib/modules/%{KVERREL}xenU/extra
744 /lib/modules/%{KVERREL}xenU/updates
745 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
746
747 %files xenU-devel
748 %defattr(-,root,root)
749 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
750 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
751 %endif
752
753 %files vserver
754 %defattr(-,root,root)
755 # no files
756
757 # only some architecture builds need kernel-doc
758
759 %if %{builddoc}
760 %files doc
761 %defattr(-,root,root)
762 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
763 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
764 %dir %{_datadir}/doc/kernel-doc-%{kversion}
765 %endif
766
767 %changelog
768 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
769 - 2.6.17.4
770 - Disable split pagetable lock.
771
772 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
773 - Get rid of stack backtrace on panic, which in most
774   cases actually caused a loss of info instead of a gain.
775
776 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
777 - 2.6.17.3
778
779 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
780 - 2.6.17.2
781 - Fix up the alsa list_add bug.
782
783 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
784 - Fix up various stupidities incurred by the last big rebase.
785   - Reenable SMP x86-64 builds.
786   - Reenable SMBFS.
787 - Enable PCI fake hotplug driver.
788 - Enable gameport/joystick on i586 builds. (#196581)
789
790 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
791 - Enable profiling for 586 kernels.
792
793 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
794 - Rebuild with slab debug off.
795
796 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
797 - 2.6.17.1
798
799 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
800 - 2.6.16.20
801
802 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
803 - 2.6.16.19
804
805 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
806 - Improved list_head debugging.
807
808 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
809 - 2.6.16.18
810
811 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
812 - 2.6.16.17
813
814 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
815 - 2.6.16.16
816
817 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
818 - 2.6.16.15
819 - make 16C950 UARTs work (again). (#126403)
820 - Fix exec-shield default, which should fix a few programs that
821   stopped running.
822
823 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
824 - 2.6.16.14
825
826 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
827 - 2.6.16.13
828
829 * Mon May  1 2006 Dave Jones <davej@redhat.com>
830 - 2.6.16.12
831
832 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
833 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
834
835 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
836 - 2.6.16.11
837
838 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
839 - Enable PCI MSI support.
840
841 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
842 - 2.6.16.9
843
844 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
845 - 2.6.16.7
846
847 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
848 - 2.6.16.6
849
850 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
851 - 2.6.16.5
852
853 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
854 - 2.6.16.2
855
856 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
857 - Reenable non-standard serial ports. (#187466)
858 - Reenable snd-es18xx for x86-32 (#187733)
859
860 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
861 - ship the .kernelrelease file in -devel too.
862 - Disable EDAC debug.
863
864 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
865 - 2.6.16.1
866
867 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
868 - Include patches posted for review for inclusion in 2.6.16.1
869 - Updated new audit msg types.
870 - Reenable HDLC driver (#186257)
871 - Make acpi-cpufreq 'sticky'
872 - Fix broken x86-64 32bit vDSO (#186924)
873
874 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
875 - Improve spinlock scalability on big machines.
876
877 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
878 - Sync with FC5's 2.6.16 kernel.
879 - Update Tux & Exec-shield to latest.
880