add patch to revert condition that can set RTT=0
[linux-2.6.git] / kernel-2.6.spec
index a68db4c..04dc109 100644 (file)
@@ -10,9 +10,10 @@ URL: %{SCMURL}
 
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 20
+# 131 borrowed from centos6.1, tg3 from 220 centos 6.2
+%define taglevel 131.vs230.web10027.xidmask.2
 
-%define sublevel 32
+%define sublevel 33
 
 %if ("%{distro}" == "Fedora" && %{distrorelease} >= 12) || ("%{distro}" == "SL" && %{distrorelease} >= 6) || ("%{distro}" == "CentOS" && %{distrorelease} >= 6)
 %define modern_distro 1
@@ -232,6 +233,8 @@ Summary: The Linux kernel
 %define pkg_release %{distro_build}%{?dist}%{?buildid}
 %endif
 #### Planet-Lab ####
+#%define pkg_release %{taglevel}%{?pldistro:.%{pldistro}}.mlab%{?date:.%{date}}
+# this branch is now unique to the mlab build. so pldistro==mlab
 %define pkg_release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 #### Planet-Lab ####
 %define KVERREL %{rpmversion}-%{pkg_release}.%{_target_cpu}
@@ -681,9 +684,17 @@ Patch17: linux-2.6-640-netlink-audit-hack.patch
 Patch18: linux-2.6-650-hangcheck-reboot.patch
 Patch19: linux-2.6-660-nmi-watchdog-default.patch
 Patch20: linux-2.6-680-htb-hysteresis-tso.patch
+Patch21: linux-2.6-690-web100.patch
+Patch22: linux-2.6-700-bcm5720.patch
+Patch23: linux-2.6-710-xidmask.patch
+Patch24: linux-2.6-720-undo-rttzero.patch
 
 Patch10000: linux-2.6-10000-gcc-4.5.patch
 Patch10001: linux-2.6-10001-gcc-4.6-warnoff.patch
+Patch10002: linux-2.6-10002-gcc-4.6-sense_buffer.patch
+Patch10003: linux-2.6-10003-gcc-4.6-vdso.patch
+Patch10004: linux-2.6-10004-gcc-4.6-perf.patch
+Patch10911: linux-2.6-10911-perftools-f8-build.patch
 # empty final patch file to facilitate testing of kernel patches
 Patch999999: linux-kernel-test.patch
 
@@ -996,8 +1007,16 @@ ApplyPatch linux-2.6-640-netlink-audit-hack.patch
 ApplyPatch linux-2.6-650-hangcheck-reboot.patch
 ApplyPatch linux-2.6-660-nmi-watchdog-default.patch
 ApplyPatch linux-2.6-680-htb-hysteresis-tso.patch
+ApplyPatch linux-2.6-690-web100.patch
+ApplyPatch linux-2.6-700-bcm5720.patch
+ApplyPatch linux-2.6-710-xidmask.patch
+ApplyPatch linux-2.6-720-undo-rttzero.patch
 ApplyPatch linux-2.6-10000-gcc-4.5.patch
 ApplyPatch linux-2.6-10001-gcc-4.6-warnoff.patch
+ApplyPatch linux-2.6-10002-gcc-4.6-sense_buffer.patch
+ApplyPatch linux-2.6-10003-gcc-4.6-vdso.patch
+ApplyPatch linux-2.6-10004-gcc-4.6-perf.patch
+ApplyPatch linux-2.6-10911-perftools-f8-build.patch
 #### Planet-Lab ####
 
 ApplyOptionalPatch linux-kernel-test.patch
@@ -1733,7 +1752,9 @@ fi
 /etc/ld.so.conf.d/kernel-%{KVERREL}%{?2:.%{2}}.conf\
 %endif\
 /lib/modules/%{KVERREL}%{?2:.%{2}}/modules.*\
+%if %{with_firmware}\
 /lib/firmware/*\
+%endif\
 %if %{with_dracut}\
 %ghost /boot/initramfs-%{KVERREL}%{?2:.%{2}}.img\
 %else\
@@ -1778,6 +1799,27 @@ fi
 %endif
 
 %changelog
+* Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-32-27
+- 2 places for pulling sources from in case of network outage
+
+* Wed Oct 05 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-26
+- Tweak to the f8 build-fixing patch
+
+* Tue Oct 04 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-25
+- Apply f8-build-fixing patch
+
+* Mon Aug 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-32-24
+- fix patch filename
+
+* Tue Aug 09 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-23
+- The option commented out in this patch braeks the build on f8.
+
+* Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-32-22
+- fixed specfile for --without firmware
+
+* Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-32-21
+- build tweaks for gcc-4.6 on f15
+
 * Thu Jun 02 2011 S.Çağlar Onur <caglar@verivue.com> - linux-2.6-32-20
 - fix spec file