fix rpm-build dependency problem
[linux-2.6.git] / kernel-2.6.spec
index 24fb21d..2513a7b 100644 (file)
@@ -10,7 +10,7 @@ URL: %(echo %{url} | cut -d ' ' -f 2)
 
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 1
+%define taglevel 2
 
 %define sublevel 32
 #### Planet-Lab ####
@@ -130,8 +130,14 @@ Summary: The Linux kernel
 %define with_bootwrapper %{?_without_bootwrapper: 0} %{?!_without_bootwrapper: 1}
 # Want to build a the vsdo directories installed
 %define with_vdso_install %{?_without_vdso_install: 0} %{?!_without_vdso_install: 1}
+#### Planet-Lab ####
 # Use dracut instead of mkinitrd for initrd image generation
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12
 %define with_dracut       %{?_without_dracut:       0} %{?!_without_dracut:       1}
+%else
+%define with_dracut       %{?_without_dracut:       1} %{?!_without_dracut:       0}
+%endif
+#### Planet-Lab ####
 
 # Build the kernel-doc package, but don't fail the build if it botches.
 # Here "true" means "continue" and "false" means "fail the build".
@@ -454,7 +460,13 @@ Summary: The Linux kernel
 # problems with the newer kernel or lack certain things that make
 # integration in the distro harder than needed.
 #
+#### Planet-Lab ####
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12
 %define package_conflicts initscripts < 7.23, udev < 145-11, iptables < 1.3.2-1, ipw2200-firmware < 2.4, iwl4965-firmware < 228.57.2, selinux-policy-targeted < 1.25.3-14, squashfs-tools < 4.0, wireless-tools < 29-3
+%else
+%define package_conflicts initscripts < 7.23, iptables < 1.3.2-1, ipw2200-firmware < 2.4, iwl4965-firmware < 228.57.2, selinux-policy-targeted < 1.25.3-14, squashfs-tools < 4.0, wireless-tools < 29-3
+%endif
+#### Planet-Lab ####
 
 #
 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
@@ -477,11 +489,24 @@ Summary: The Linux kernel
 # Packages that need to be installed before the kernel is, because the %post
 # scripts use them.
 #
+#### Planet-Lab ####
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12
 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 8.11.1-1, kernel-firmware >= %{rpmversion}-%{pkg_release}, grubby >= 7.0.4-1
+%else
+%define kernel_prereq  fileutils, module-init-tools, initscripts >= 8.11.1-1, kernel-firmware >= %{rpmversion}-%{pkg_release}
+%endif
+#### Planet-Lab ####
+
 %if %{with_dracut}
 %define initrd_prereq  dracut-kernel >= 002-18.git413bcf78
 %else
+#### Planet-Lab ####
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12
 %define initrd_prereq  mkinitrd >= 6.0.61-1
+%else
+%define initrd_prereq  mkinitrd >= 6.0.19-1
+%endif
+#### Planet-Lab ####
 %endif
 
 #
@@ -538,7 +563,13 @@ Obsoletes: kernel-smp
 BuildRequires: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
 BuildRequires: bzip2, findutils, gzip, m4, perl, make >= 3.78, diffutils, gawk
 BuildRequires: gcc >= 3.4.2, binutils >= 2.12, redhat-rpm-config
+#### Planet-Lab ####
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 14
 BuildRequires: net-tools, patchutils, rpm-build >= 4.8.0-7
+%else
+BuildRequires: net-tools, patchutils, rpm-build
+%endif
+#### Planet-Lab ####
 %if %{with_doc}
 BuildRequires: xmlto
 BuildRequires: asciidoc
@@ -1026,11 +1057,6 @@ cd ..
 ###
 %build
 
-#### Planet-Lab ####
-# -Werror breaks F14 builds
-sed -i -e "s:-Wno-array-bounds -Werror:-Wno-array-bounds:g" Makefile
-#### Planet-Lab ####
-
 %if %{with_sparse}
 %define sparse_mflags  C=1
 %endif
@@ -1082,6 +1108,11 @@ BuildKernel() {
     %endif
     %endif
 
+    #### Planet-Lab ####
+    # -Werror breaks F14 builds
+    sed -i -e "s:-Wno-array-bounds -Werror:-Wno-array-bounds:g" Makefile
+    #### Planet-Lab ####
+
     # and now to start the build process
 
     make -s mrproper
@@ -1523,11 +1554,23 @@ fi\
 %else\
 /sbin/new-kernel-pkg --package kernel%{?1:-%{1}} --mkinitrd --depmod --update %{KVERREL}%{?1:.%{1}} $NEWKERNARGS || exit $?\
 %endif}\
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12\
 /sbin/new-kernel-pkg --package kernel%{?1:-%{1}} --rpmposttrans %{KVERREL}%{?1:.%{1}} || exit $?\
 if [ -x /sbin/weak-modules ]\
 then\
     /sbin/weak-modules --add-kernel %{KVERREL}%{?1:.%{1}} || exit $?\
 fi\
+%endif\
+pushd /boot > /dev/null\
+ln -sf config-%{KVERREL}%{?1:.%{1}} config\
+ln -sf config-%{KVERREL}%{?1:.%{1}} configsmp\
+ln -sf initrd-%{KVERREL}%{?1:.%{1}}.img initrd-boot\
+ln -sf initrd-%{KVERREL}%{?1:.%{1}}.img initrd-bootsmp\
+ln -sf vmlinuz-%{KVERREL}%{?1:.%{1}} kernel-boot\
+ln -sf vmlinuz-%{KVERREL}%{?1:.%{1}} kernel-bootsmp\
+popd > /dev/null\
+mkdir -p /etc/planetlab\
+touch /etc/planetlab/update-reboot\
 %{nil}
 
 #
@@ -1728,6 +1771,9 @@ fi
 %endif
 
 %changelog
+* Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-2
+- Fix F14 build problems
+
 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-1
 - Bump to latest RHEL6 kernel