Setting tag linux-2.6-32-35
[linux-2.6.git] / kernel-2.6.spec
index c162d80..2fc6b6e 100644 (file)
@@ -10,15 +10,11 @@ URL: %{SCMURL}
 
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 19
+%define taglevel 35
 
 %define sublevel 32
 
-%if ("%{distro}" == "Fedora" && %{distrorelease} >= 12) || ("%{distro}" == "SL" && %{distrorelease} >= 6) || ("%{distro}" == "CentOS" && %{distrorelease} >= 6)
 %define modern_distro 1
-%else
-%define modern_distro 0
-%endif
 #### Planet-Lab ####
 
 Summary: The Linux kernel
@@ -661,6 +657,8 @@ Source81: config-i686-debug-rhel
 Source82: config-generic
 Source83: config-x86_64-debug-rhel
 
+Patch0: linux-2.6-001-bcm5720.patch
+Patch20001: linux-2.6-002-divide-by-zero-fix.diff
 Patch1: patch-2.6.32-131.0.15.el6-vs2.3.0.36.29.6.diff
 Patch2: linux-2.6-255-vserver-delta-cow-fix23.patch
 Patch3: linux-2.6-250-ipsets.patch
@@ -683,6 +681,11 @@ Patch19: linux-2.6-660-nmi-watchdog-default.patch
 Patch20: linux-2.6-680-htb-hysteresis-tso.patch
 
 Patch10000: linux-2.6-10000-gcc-4.5.patch
+Patch10001: linux-2.6-10001-gcc-4.6-warnoff.patch
+Patch10002: linux-2.6-10002-gcc-4.6-sense_buffer.patch
+Patch10003: linux-2.6-10003-gcc-4.6-vdso.patch
+Patch10004: linux-2.6-10004-gcc-4.6-perf.patch
+Patch10911: linux-2.6-10911-perftools-f8-build.patch
 # empty final patch file to facilitate testing of kernel patches
 Patch999999: linux-kernel-test.patch
 
@@ -974,6 +977,8 @@ cp %{SOURCE15} %{SOURCE1} %{SOURCE16} %{SOURCE17} %{SOURCE18} .
 make -f %{SOURCE20} VERSION=%{version} configs
 
 #### Planet-Lab ####
+ApplyPatch linux-2.6-001-bcm5720.patch
+ApplyPatch linux-2.6-002-divide-by-zero-fix.patch
 ApplyPatch patch-2.6.32-131.0.15.el6-vs2.3.0.36.29.6.diff
 ApplyPatch linux-2.6-255-vserver-delta-cow-fix23.patch
 ApplyPatch linux-2.6-250-ipsets.patch
@@ -996,6 +1001,11 @@ ApplyPatch linux-2.6-650-hangcheck-reboot.patch
 ApplyPatch linux-2.6-660-nmi-watchdog-default.patch
 ApplyPatch linux-2.6-680-htb-hysteresis-tso.patch
 ApplyPatch linux-2.6-10000-gcc-4.5.patch
+ApplyPatch linux-2.6-10001-gcc-4.6-warnoff.patch
+ApplyPatch linux-2.6-10002-gcc-4.6-sense_buffer.patch
+ApplyPatch linux-2.6-10003-gcc-4.6-vdso.patch
+ApplyPatch linux-2.6-10004-gcc-4.6-perf.patch
+ApplyPatch linux-2.6-10911-perftools-f8-build.patch
 #### Planet-Lab ####
 
 ApplyOptionalPatch linux-kernel-test.patch
@@ -1132,6 +1142,11 @@ BuildKernel() {
     sed -i -e "s:-Wno-array-bounds -Werror:-Wno-array-bounds:g" Makefile
     #### Planet-Lab ####
 
+    #### Planet-Lab ####
+    # -Werror breaks F16 builds in tools/perf
+    sed -i -e "s: -Werror : :g" tools/perf/Makefile
+    #### Planet-Lab ####
+
     # and now to start the build process
 
     make -s mrproper
@@ -1731,7 +1746,9 @@ fi
 /etc/ld.so.conf.d/kernel-%{KVERREL}%{?2:.%{2}}.conf\
 %endif\
 /lib/modules/%{KVERREL}%{?2:.%{2}}/modules.*\
+%if %{with_firmware}\
 /lib/firmware/*\
+%endif\
 %if %{with_dracut}\
 %ghost /boot/initramfs-%{KVERREL}%{?2:.%{2}}.img\
 %else\
@@ -1776,6 +1793,54 @@ fi
 %endif
 
 %changelog
+* Wed Aug 29 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-35
+
+* Wed Aug 29 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-34
+
+* Thu May 03 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-33
+- More compiletime fixes.
+
+* Thu May 03 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-32
+- Fixed some parantheses.
+
+* Thu May 03 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-31
+- For some reason the -30 tag did not get created in Linux-2.6. Might be because of a temporary problem with the git
+- server.
+
+* Tue May 01 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-30
+- Fixed a compile error.
+
+* Tue May 01 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-29
+- Renamed the latest patch file to something build doesn't reject.
+
+* Tue May 01 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-28
+- This patch adds a backported version of a patchset to support the bcm5720 chipset, used by various PlanetLab and MLab
+- members.
+
+* Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-32-27
+- 2 places for pulling sources from in case of network outage
+
+* Wed Oct 05 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-26
+- Tweak to the f8 build-fixing patch
+
+* Tue Oct 04 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-25
+- Apply f8-build-fixing patch
+
+* Mon Aug 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-32-24
+- fix patch filename
+
+* Tue Aug 09 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-23
+- The option commented out in this patch braeks the build on f8.
+
+* Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-32-22
+- fixed specfile for --without firmware
+
+* Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-32-21
+- build tweaks for gcc-4.6 on f15
+
+* Thu Jun 02 2011 S.Çağlar Onur <caglar@verivue.com> - linux-2.6-32-20
+- fix spec file
+
 * Wed Jun 01 2011 S.Çağlar Onur <caglar@verivue.com> - linux-2.6-32-19
 - bump to 2.6.32-131.0.15.el6, see https://rhn.redhat.com/errata/RHSA-2011-0498.html and https://rhn.redhat.com/errata/RHSA-2011-0542.html