trying to fix following warning: 'override: reassigning to symbol SYSFS_DEPRECATED_V2'
[linux-2.6.git] / kernel-2.6.spec
index 25635e1..3c3a993 100644 (file)
@@ -4,13 +4,13 @@
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %{SCMURL}
 
 %{!?pldistro:%global pldistro planetlab}
 
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 4
+%define taglevel 7
 
 %define sublevel 32
 #### Planet-Lab ####
@@ -124,8 +124,14 @@ Summary: The Linux kernel
 %define with_perftool  %{?_without_perftool:  0} %{?!_without_perftool:  1}
 # perf noarch subpkg
 %define with_perf      %{?_without_perf:      0} %{?!_without_perf:      1}
+#### Planet-Lab ####
 # kernel-debuginfo
+%if "%{distro}" == "CentOS" && %{distrorelease} == 5
+%define with_debuginfo %{?_without_debuginfo: 1} %{?!_without_debuginfo: 0}
+%else
 %define with_debuginfo %{?_without_debuginfo: 0} %{?!_without_debuginfo: 1}
+%endif
+#### Planet-Lab ####
 # kernel-bootwrapper (for creating zImages from kernel + initrd)
 %define with_bootwrapper %{?_without_bootwrapper: 0} %{?!_without_bootwrapper: 1}
 # Want to build a the vsdo directories installed
@@ -504,7 +510,7 @@ Summary: The Linux kernel
 %if "%{distro}" == "Fedora" && %{distrorelease} >= 12
 %define initrd_prereq  mkinitrd >= 6.0.61-1
 %else
-%define initrd_prereq  mkinitrd >= 6.0.19-1
+%define initrd_prereq  mkinitrd >= 5.1
 %endif
 #### Planet-Lab ####
 %endif
@@ -682,6 +688,7 @@ Patch18: linux-2.6-650-hangcheck-reboot.patch
 Patch19: linux-2.6-660-nmi-watchdog-default.patch
 Patch20: linux-2.6-680-htb-hysteresis-tso.patch
 
+Patch10000: linux-2.6-10000-gcc-4.5.patch
 # empty final patch file to facilitate testing of kernel patches
 Patch999999: linux-kernel-test.patch
 
@@ -977,6 +984,7 @@ ApplyPatch linux-2.6-640-netlink-audit-hack.patch
 ApplyPatch linux-2.6-650-hangcheck-reboot.patch
 ApplyPatch linux-2.6-660-nmi-watchdog-default.patch
 ApplyPatch linux-2.6-680-htb-hysteresis-tso.patch
+ApplyPatch linux-2.6-10000-gcc-4.5.patch
 #### Planet-Lab ####
 
 ApplyOptionalPatch linux-kernel-test.patch
@@ -1771,6 +1779,15 @@ fi
 %endif
 
 %changelog
+* Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-7
+- Adjust mkinitrd requirement for CentOS 5
+
+* Wed Jan 05 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-6
+- Disable debuginfo packages for CentOS 5
+
+* Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-5
+- Fix problems caused by gcc 4.5.1 on F14
+
 * Fri Dec 17 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-4
 - Fix build problems for Fedora 8 and 12