trying to fix following warning: 'override: reassigning to symbol SYSFS_DEPRECATED_V2'
[linux-2.6.git] / kernel-2.6.spec
index fc9f909..3c3a993 100644 (file)
@@ -4,13 +4,13 @@
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %{SCMURL}
 
 %{!?pldistro:%global pldistro planetlab}
 
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 0
+%define taglevel 7
 
 %define sublevel 32
 #### Planet-Lab ####
@@ -116,20 +116,34 @@ Summary: The Linux kernel
 %define with_doc       %{?_without_doc:       0} %{?!_without_doc:       1}
 # kernel-headers
 %define with_headers   %{?_without_headers:   0} %{?!_without_headers:   1}
+#### Planet-Lab ####
 # kernel-firmware
-%define with_firmware  %{?_with_firmware:     1} %{?!_with_firmware:     0}
+%define with_firmware  %{?_with_firmware:     0} %{?!_with_firmware:     1}
+#### Planet-Lab ####
 # tools/perf
 %define with_perftool  %{?_without_perftool:  0} %{?!_without_perftool:  1}
 # perf noarch subpkg
 %define with_perf      %{?_without_perf:      0} %{?!_without_perf:      1}
+#### Planet-Lab ####
 # kernel-debuginfo
+%if "%{distro}" == "CentOS" && %{distrorelease} == 5
+%define with_debuginfo %{?_without_debuginfo: 1} %{?!_without_debuginfo: 0}
+%else
 %define with_debuginfo %{?_without_debuginfo: 0} %{?!_without_debuginfo: 1}
+%endif
+#### Planet-Lab ####
 # kernel-bootwrapper (for creating zImages from kernel + initrd)
 %define with_bootwrapper %{?_without_bootwrapper: 0} %{?!_without_bootwrapper: 1}
 # Want to build a the vsdo directories installed
 %define with_vdso_install %{?_without_vdso_install: 0} %{?!_without_vdso_install: 1}
+#### Planet-Lab ####
 # Use dracut instead of mkinitrd for initrd image generation
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12
 %define with_dracut       %{?_without_dracut:       0} %{?!_without_dracut:       1}
+%else
+%define with_dracut       %{?_without_dracut:       1} %{?!_without_dracut:       0}
+%endif
+#### Planet-Lab ####
 
 # Build the kernel-doc package, but don't fail the build if it botches.
 # Here "true" means "continue" and "false" means "fail the build".
@@ -139,10 +153,12 @@ Summary: The Linux kernel
 %define doc_build_fail true
 %endif
 
+#### Planet-Lab ####
 # Control whether we perform a compat. check against published ABI.
-%define with_kabichk   %{?_without_kabichk:   0} %{?!_without_kabichk: 1}
+%define with_kabichk   %{?_without_kabichk:   1} %{?!_without_kabichk: 0}
 # Control whether we perform a compat. check against published ABI.
-%define with_fips      %{?_without_fips:      0} %{?!_without_fips:      1}
+%define with_fips      %{?_without_fips:      1} %{?!_without_fips:      0}
+#### Planet-Lab ####
 
 # Additional options for user-friendly one-off kernel building:
 #
@@ -450,7 +466,13 @@ Summary: The Linux kernel
 # problems with the newer kernel or lack certain things that make
 # integration in the distro harder than needed.
 #
+#### Planet-Lab ####
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12
 %define package_conflicts initscripts < 7.23, udev < 145-11, iptables < 1.3.2-1, ipw2200-firmware < 2.4, iwl4965-firmware < 228.57.2, selinux-policy-targeted < 1.25.3-14, squashfs-tools < 4.0, wireless-tools < 29-3
+%else
+%define package_conflicts initscripts < 7.23, iptables < 1.3.2-1, ipw2200-firmware < 2.4, iwl4965-firmware < 228.57.2, selinux-policy-targeted < 1.25.3-14, squashfs-tools < 4.0, wireless-tools < 29-3
+%endif
+#### Planet-Lab ####
 
 #
 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
@@ -473,11 +495,24 @@ Summary: The Linux kernel
 # Packages that need to be installed before the kernel is, because the %post
 # scripts use them.
 #
+#### Planet-Lab ####
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12
 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 8.11.1-1, kernel-firmware >= %{rpmversion}-%{pkg_release}, grubby >= 7.0.4-1
+%else
+%define kernel_prereq  fileutils, module-init-tools, initscripts >= 8.11.1-1, kernel-firmware >= %{rpmversion}-%{pkg_release}
+%endif
+#### Planet-Lab ####
+
 %if %{with_dracut}
 %define initrd_prereq  dracut-kernel >= 002-18.git413bcf78
 %else
+#### Planet-Lab ####
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12
 %define initrd_prereq  mkinitrd >= 6.0.61-1
+%else
+%define initrd_prereq  mkinitrd >= 5.1
+%endif
+#### Planet-Lab ####
 %endif
 
 #
@@ -534,7 +569,13 @@ Obsoletes: kernel-smp
 BuildRequires: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
 BuildRequires: bzip2, findutils, gzip, m4, perl, make >= 3.78, diffutils, gawk
 BuildRequires: gcc >= 3.4.2, binutils >= 2.12, redhat-rpm-config
+#### Planet-Lab ####
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 14
 BuildRequires: net-tools, patchutils, rpm-build >= 4.8.0-7
+%else
+BuildRequires: net-tools, patchutils, rpm-build
+%endif
+#### Planet-Lab ####
 %if %{with_doc}
 BuildRequires: xmlto
 BuildRequires: asciidoc
@@ -626,6 +667,28 @@ Source79: config-debug-rhel
 Source80: config-generic-rhel
 Source81: config-powerpc64
 
+Patch1: patch-2.6.32-71.7.1.el6-vs2.3.0.36.29.4.diff
+Patch2: linux-2.6-220-delta-ptrace-fix01.patch
+Patch3: linux-2.6-250-ipsets.patch
+Patch4: linux-2.6-510-ipod.patch
+Patch5: linux-2.6-521-packet-tagging.patch
+Patch6: linux-2.6-522-iptables-connection-tagging.patch
+Patch7: linux-2.6-523-raw-sockets.patch
+Patch8: linux-2.6-524-peercred.patch
+Patch9: linux-2.6-525-sknid-elevator.patch
+Patch10: linux-2.6-527-iptables-classify-add-mark.patch
+Patch11: linux-2.6-530-built-by-support.patch
+Patch12: linux-2.6-550-raise-default-nfile-ulimit.patch
+Patch13: linux-2.6-570-tagxid.patch
+Patch14: linux-2.6-580-show-proc-virt.patch
+Patch15: linux-2.6-590-dcookies-mm.patch
+Patch16: linux-2.6-591-chopstix-intern.patch
+Patch17: linux-2.6-640-netlink-audit-hack.patch
+Patch18: linux-2.6-650-hangcheck-reboot.patch
+Patch19: linux-2.6-660-nmi-watchdog-default.patch
+Patch20: linux-2.6-680-htb-hysteresis-tso.patch
+
+Patch10000: linux-2.6-10000-gcc-4.5.patch
 # empty final patch file to facilitate testing of kernel patches
 Patch999999: linux-kernel-test.patch
 
@@ -916,12 +979,12 @@ ApplyPatch linux-2.6-550-raise-default-nfile-ulimit.patch
 ApplyPatch linux-2.6-570-tagxid.patch
 ApplyPatch linux-2.6-580-show-proc-virt.patch
 ApplyPatch linux-2.6-590-dcookies-mm.patch
-# fails with -Wall build
-#ApplyPatch linux-2.6-591-chopstix-intern.patch
+ApplyPatch linux-2.6-591-chopstix-intern.patch
 ApplyPatch linux-2.6-640-netlink-audit-hack.patch
 ApplyPatch linux-2.6-650-hangcheck-reboot.patch
 ApplyPatch linux-2.6-660-nmi-watchdog-default.patch
 ApplyPatch linux-2.6-680-htb-hysteresis-tso.patch
+ApplyPatch linux-2.6-10000-gcc-4.5.patch
 #### Planet-Lab ####
 
 ApplyOptionalPatch linux-kernel-test.patch
@@ -1053,6 +1116,11 @@ BuildKernel() {
     %endif
     %endif
 
+    #### Planet-Lab ####
+    # -Werror breaks F14 builds
+    sed -i -e "s:-Wno-array-bounds -Werror:-Wno-array-bounds:g" Makefile
+    #### Planet-Lab ####
+
     # and now to start the build process
 
     make -s mrproper
@@ -1494,11 +1562,23 @@ fi\
 %else\
 /sbin/new-kernel-pkg --package kernel%{?1:-%{1}} --mkinitrd --depmod --update %{KVERREL}%{?1:.%{1}} $NEWKERNARGS || exit $?\
 %endif}\
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12\
 /sbin/new-kernel-pkg --package kernel%{?1:-%{1}} --rpmposttrans %{KVERREL}%{?1:.%{1}} || exit $?\
 if [ -x /sbin/weak-modules ]\
 then\
     /sbin/weak-modules --add-kernel %{KVERREL}%{?1:.%{1}} || exit $?\
 fi\
+%endif\
+pushd /boot > /dev/null\
+ln -sf config-%{KVERREL}%{?1:.%{1}} config\
+ln -sf config-%{KVERREL}%{?1:.%{1}} configsmp\
+ln -sf initrd-%{KVERREL}%{?1:.%{1}}.img initrd-boot\
+ln -sf initrd-%{KVERREL}%{?1:.%{1}}.img initrd-bootsmp\
+ln -sf vmlinuz-%{KVERREL}%{?1:.%{1}} kernel-boot\
+ln -sf vmlinuz-%{KVERREL}%{?1:.%{1}} kernel-bootsmp\
+popd > /dev/null\
+mkdir -p /etc/planetlab\
+touch /etc/planetlab/update-reboot\
 %{nil}
 
 #
@@ -1699,6 +1779,29 @@ fi
 %endif
 
 %changelog
+* Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-7
+- Adjust mkinitrd requirement for CentOS 5
+
+* Wed Jan 05 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-6
+- Disable debuginfo packages for CentOS 5
+
+* Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-5
+- Fix problems caused by gcc 4.5.1 on F14
+
+* Fri Dec 17 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-4
+- Fix build problems for Fedora 8 and 12
+
+* Thu Dec 16 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-3
+- Tweak vserver configs based on Daniel's suggestions
+- Add appropriate postinstall steps required by PL nodes
+- Tweak dependencies for F8 compatibility
+
+* Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-2
+- Fix F14 build problems
+
+* Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-1
+- Bump to latest RHEL6 kernel
+
 * Wed Oct 27 2010 Frantisek Hrbata <fhrbata@redhat.com> [2.6.32-71.7.1.el6]
 - [drm] ttm: fix regression introduced in dfb4a4250168008c5ac61e90ab2b86f074a83a6c (Dave Airlie) [646994 644896]