Setting tag linux-2.6-22-50
[linux-2.6.git] / kernel-2.6.spec
index 3cda548..6f21d28 100644 (file)
@@ -1,8 +1,3 @@
-#
-# $Id$
-#
-%define url $URL$
-
 Summary: The Linux kernel (the core of the Linux operating system)
 
 # What parts do we want to build?  We must build at least one kernel.
@@ -34,7 +29,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # for module-tag.py - sublevel is used for the version (middle) part of tag names
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 44
+%define taglevel 50
 
 #
 # Polite request for people who spin their own kernel rpms:
@@ -53,14 +48,19 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # updated every time the PL kernel is updated.
 %define vini_pl_patch 561
 
-#%define updatelevel 1
+%define requiresreboot 0
 
-%define kernelrelease vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}%{?updatelevel:.%{updatelevel}}
+%define kernelrelease vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define packagerelease %{kernelrelease}
 
 %define signmodules 0
 %define make_target bzImage
+
+#%if "%{distro}" == "Fedora" && %{distrorelease} >= 13
+#%define KVERREL %{version}-%{kernelrelease}
+#%else
 %define KVERREL %{PACKAGE_VERSION}-%{kernelrelease}
+#%endif
 
 # Override generic defaults with per-arch defaults
 
@@ -108,7 +108,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %{SCMURL}
 
 Name: kernel
 Group: System Environment/Kernel
@@ -157,8 +157,7 @@ Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
 
 Patch010: linux-2.6-010-e1000e.patch
 Patch015: linux-2.6-015-igb.patch
-# disabled
-#Patch016: linux-2.6-016-bnx2x.patch
+Patch017: linux-2.6-017-bnx2.patch
 Patch020: linux-2.6-020-build-id.patch
 Patch030: linux-2.6-030-netns.patch
 Patch040: linux-2.6-040-i_mutex-check.patch
@@ -168,6 +167,7 @@ Patch050: linux-2.6-050-getline.patch
 Patch100: linux-2.6-100-build-nonintconfig.patch
 
 Patch150: linux-2.6-150-cciss-allow-kexec-to-work.patch
+Patch151: linux-2.6-151-cciss-SAS.patch
 
 # Linux-VServer
 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
@@ -217,6 +217,11 @@ Patch800: linux-2.6-800-fix-4-bit-apicid-assumption.patch
 
 Patch810: linux-2.6-810-ich10.patch
 
+Patch900: linux-2.6-900-ext3_mount_default_to_barrier.patch
+Patch910: linux-2.6-910-support_barriers_on_single_device_dm_devices.patch
+
+Patch950: linux-2.6.950-ext3_backports.patch
+
 # See also the file named 'sources' here for the related checksums
 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
@@ -364,7 +369,7 @@ else
   cd kernel-%{kversion}
 fi
 
-%if "0%{updatelevel}"
+%if %{requiresreboot}
 echo "This is a trivial maintenance update. There will be no reboot following installation."
 %endif
 
@@ -394,8 +399,7 @@ KERNEL_PREVIOUS=vanilla
 
 %ApplyPatch 10
 %ApplyPatch 15
-# linux-2.6-016-bnx2x.patch
-# %ApplyPatch 16
+%ApplyPatch 17
 %ApplyPatch 20
 
 # NetNS patch for VINI
@@ -408,6 +412,7 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 100
 
 %ApplyPatch 150
+%ApplyPatch 151
 
 %ApplyPatch 200
 %ApplyPatch 210
@@ -453,6 +458,10 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 800
 %ApplyPatch 810
 
+%ApplyPatch 900
+%ApplyPatch 910
+
+%ApplyPatch 950
 
 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
 # break with later patches.
@@ -545,6 +554,7 @@ BuildKernel() {
     make -s ARCH=$Arch INSTALL_HDR_PATH=$RPM_BUILD_ROOT/usr
     find $RPM_BUILD_ROOT/%{_includedir} -name \*.cmd -delete
     rm -f $RPM_BUILD_ROOT/%{_includedir}/{..,.}{check,install}*
+    rm -rf $RPM_BUILD_ROOT/usr/include/scsi
 %endif
 
 %if %{iwlwifi}
@@ -801,11 +811,10 @@ pushd /boot > /dev/null ; {
 }
 popd > /dev/null
 
+%if %{requiresreboot}
 # ask for a reboot
 mkdir -p /etc/planetlab
-
-%if "%{updatelevel}"==""
-#touch /etc/planetlab/update-reboot
+touch /etc/planetlab/update-reboot
 %endif
 
 %post devel
@@ -929,6 +938,25 @@ rm -f /lib/modules/%{KVERREL}uml/modules.*
 %endif
 
 %changelog
+* Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-50
+- no semantic change - just fixed specfile for git URL, and pull from onelab.eu
+
+* Fri May 07 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-22-48
+- Support next generation of HP Smart Array SAS/SATA controllers
+
+* Thu Apr 15 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-22-47
+- Tagging 22 branch with following changes;
+- * Make barrier=1 for ext3 filesystem,
+- * Support barriers on single device dm devices,
+- * Introduce various ext3 related fixes,
+- * Fix conflict between glibc-headers kernel-headers packages
+
+* Tue Mar 16 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-22-46
+- every released package should have a tag in svn, so remove updatelevel from naming scheme and also change the variable name
+
+* Tue Mar 16 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-22-45
+- add support for ICH10
+
 * Fri Feb 19 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-22-44
 - Disable rebooting