include warnings caused by the code for future references
[linux-2.6.git] / kernel-2.6.spec
index 6643147..8b132ee 100644 (file)
@@ -10,7 +10,7 @@ URL: %(echo %{url} | cut -d ' ' -f 2)
 
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 0
+%define taglevel 1
 
 %define sublevel 32
 #### Planet-Lab ####
@@ -116,8 +116,10 @@ Summary: The Linux kernel
 %define with_doc       %{?_without_doc:       0} %{?!_without_doc:       1}
 # kernel-headers
 %define with_headers   %{?_without_headers:   0} %{?!_without_headers:   1}
+#### Planet-Lab ####
 # kernel-firmware
-%define with_firmware  %{?_with_firmware:     1} %{?!_with_firmware:     0}
+%define with_firmware  %{?_with_firmware:     0} %{?!_with_firmware:     1}
+#### Planet-Lab ####
 # tools/perf
 %define with_perftool  %{?_without_perftool:  0} %{?!_without_perftool:  1}
 # perf noarch subpkg
@@ -628,6 +630,27 @@ Source79: config-debug-rhel
 Source80: config-generic-rhel
 Source81: config-powerpc64
 
+Patch1: patch-2.6.32-71.7.1.el6-vs2.3.0.36.29.4.diff
+Patch2: linux-2.6-220-delta-ptrace-fix01.patch
+Patch3: linux-2.6-250-ipsets.patch
+Patch4: linux-2.6-510-ipod.patch
+Patch5: linux-2.6-521-packet-tagging.patch
+Patch6: linux-2.6-522-iptables-connection-tagging.patch
+Patch7: linux-2.6-523-raw-sockets.patch
+Patch8: linux-2.6-524-peercred.patch
+Patch9: linux-2.6-525-sknid-elevator.patch
+Patch10: linux-2.6-527-iptables-classify-add-mark.patch
+Patch11: linux-2.6-530-built-by-support.patch
+Patch12: linux-2.6-550-raise-default-nfile-ulimit.patch
+Patch13: linux-2.6-570-tagxid.patch
+Patch14: linux-2.6-580-show-proc-virt.patch
+Patch15: linux-2.6-590-dcookies-mm.patch
+Patch16: linux-2.6-591-chopstix-intern.patch
+Patch17: linux-2.6-640-netlink-audit-hack.patch
+Patch18: linux-2.6-650-hangcheck-reboot.patch
+Patch19: linux-2.6-660-nmi-watchdog-default.patch
+Patch20: linux-2.6-680-htb-hysteresis-tso.patch
+
 # empty final patch file to facilitate testing of kernel patches
 Patch999999: linux-kernel-test.patch
 
@@ -918,8 +941,7 @@ ApplyPatch linux-2.6-550-raise-default-nfile-ulimit.patch
 ApplyPatch linux-2.6-570-tagxid.patch
 ApplyPatch linux-2.6-580-show-proc-virt.patch
 ApplyPatch linux-2.6-590-dcookies-mm.patch
-# fails with -Wall build
-#ApplyPatch linux-2.6-591-chopstix-intern.patch
+ApplyPatch linux-2.6-591-chopstix-intern.patch
 ApplyPatch linux-2.6-640-netlink-audit-hack.patch
 ApplyPatch linux-2.6-650-hangcheck-reboot.patch
 ApplyPatch linux-2.6-660-nmi-watchdog-default.patch
@@ -1055,6 +1077,11 @@ BuildKernel() {
     %endif
     %endif
 
+    #### Planet-Lab ####
+    # -Werror breaks F14 builds
+    sed -i -e "s:-Wno-array-bounds -Werror:-Wno-array-bounds:g" Makefile
+    #### Planet-Lab ####
+
     # and now to start the build process
 
     make -s mrproper
@@ -1701,6 +1728,9 @@ fi
 %endif
 
 %changelog
+* Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-1
+- Bump to latest RHEL6 kernel
+
 * Wed Oct 27 2010 Frantisek Hrbata <fhrbata@redhat.com> [2.6.32-71.7.1.el6]
 - [drm] ttm: fix regression introduced in dfb4a4250168008c5ac61e90ab2b86f074a83a6c (Dave Airlie) [646994 644896]