try (#1) to solve gcc 4.5 miscompilation related boot problems
[linux-2.6.git] / kernel-2.6.spec
index 5cc4a87..b1cc407 100644 (file)
@@ -10,7 +10,7 @@ URL: %(echo %{url} | cut -d ' ' -f 2)
 
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 2
+%define taglevel 4
 
 %define sublevel 32
 #### Planet-Lab ####
@@ -563,7 +563,13 @@ Obsoletes: kernel-smp
 BuildRequires: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
 BuildRequires: bzip2, findutils, gzip, m4, perl, make >= 3.78, diffutils, gawk
 BuildRequires: gcc >= 3.4.2, binutils >= 2.12, redhat-rpm-config
+#### Planet-Lab ####
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 14
 BuildRequires: net-tools, patchutils, rpm-build >= 4.8.0-7
+%else
+BuildRequires: net-tools, patchutils, rpm-build
+%endif
+#### Planet-Lab ####
 %if %{with_doc}
 BuildRequires: xmlto
 BuildRequires: asciidoc
@@ -676,6 +682,7 @@ Patch18: linux-2.6-650-hangcheck-reboot.patch
 Patch19: linux-2.6-660-nmi-watchdog-default.patch
 Patch20: linux-2.6-680-htb-hysteresis-tso.patch
 
+Patch10000: linux-2.6-10000-gcc-4.5.patch
 # empty final patch file to facilitate testing of kernel patches
 Patch999999: linux-kernel-test.patch
 
@@ -971,6 +978,7 @@ ApplyPatch linux-2.6-640-netlink-audit-hack.patch
 ApplyPatch linux-2.6-650-hangcheck-reboot.patch
 ApplyPatch linux-2.6-660-nmi-watchdog-default.patch
 ApplyPatch linux-2.6-680-htb-hysteresis-tso.patch
+ApplyPatch linux-2.6-10000-gcc-4.5.patch
 #### Planet-Lab ####
 
 ApplyOptionalPatch linux-kernel-test.patch
@@ -1555,16 +1563,14 @@ then\
     /sbin/weak-modules --add-kernel %{KVERREL}%{?1:.%{1}} || exit $?\
 fi\
 %endif\
-# make some useful links
-pushd /boot\
+pushd /boot > /dev/null\
 ln -sf config-%{KVERREL}%{?1:.%{1}} config\
 ln -sf config-%{KVERREL}%{?1:.%{1}} configsmp\
 ln -sf initrd-%{KVERREL}%{?1:.%{1}}.img initrd-boot\
 ln -sf initrd-%{KVERREL}%{?1:.%{1}}.img initrd-bootsmp\
 ln -sf vmlinuz-%{KVERREL}%{?1:.%{1}} kernel-boot\
 ln -sf vmlinuz-%{KVERREL}%{?1:.%{1}} kernel-bootsmp\
-popd\
-# ask for a reboot
+popd > /dev/null\
 mkdir -p /etc/planetlab\
 touch /etc/planetlab/update-reboot\
 %{nil}
@@ -1767,6 +1773,14 @@ fi
 %endif
 
 %changelog
+* Fri Dec 17 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-4
+- Fix build problems for Fedora 8 and 12
+
+* Thu Dec 16 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-3
+- Tweak vserver configs based on Daniel's suggestions
+- Add appropriate postinstall steps required by PL nodes
+- Tweak dependencies for F8 compatibility
+
 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-32-2
 - Fix F14 build problems