Setting tag linux-2.6-27-37
[linux-2.6.git] / kernel-2.6.spec
index 85d79e6..c20159f 100644 (file)
@@ -1,8 +1,3 @@
-#
-# $Id$
-#
-%define url $URL$
-
 Summary: The Linux kernel (the core of the Linux operating system)
 
 # What parts do we want to build?  We must build at least one kernel.
@@ -28,7 +23,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # for module-tag.py - sublevel is used for the version (middle) part of tag names
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 26
+%define taglevel 37
 
 #
 # Polite request for people who spin their own kernel rpms:
@@ -37,7 +32,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # adding some text to the end of the version number.
 #
 %define sublevel 27
-%define patchlevel 53
+%define patchlevel 57
 %define kversion 2.6.%{sublevel}
 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
 
@@ -51,11 +46,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 
 %define signmodules 0
 %define make_target bzImage
-#%if "%{distro}" == "Fedora" && %{distrorelease} >= 13
-#%define KVERREL %{version}-%{release}
-#%else
-%define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
-#%endif
+%define KVERREL %{version}-%{release}
 
 # Override generic defaults with per-arch defaults
 
@@ -97,12 +88,12 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # Packages that need to be installed before the kernel is, because the %post
 # scripts use them.
 #
-%define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
+%define kernel_requires  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %{SCMURL}
 
 Name: kernel
 Group: System Environment/Kernel
@@ -124,7 +115,7 @@ Provides: kernel-drm = 4.3.0
 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
 Provides: kernel-smp = %{rpmversion}-%{release}
 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
-Prereq: %{kernel_prereq}
+Requires: %{kernel_requires}
 Conflicts: %{kernel_dot_org_conflicts}
 Conflicts: %{package_conflicts}
 Conflicts: %{nptl_conflicts}
@@ -136,8 +127,8 @@ AutoReqProv: no
 #
 # List the packages used during the kernel build
 #
-BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
-BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
+BuildRequires: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
+BuildRequires: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
 
@@ -159,6 +150,7 @@ Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
 %endif
 
 Patch010: linux-2.6-010-e1000e-ich10lan.patch
+#Patch011: linux-2.6-011-e1000e-82574L.patch
 Patch017: linux-2.6-017-bnx2.patch
 
 Patch100: linux-2.6-100-build-nonintconfig.patch
@@ -203,6 +195,7 @@ Patch800: linux-2.6-800-rename-ext4dev-to-ext4.patch
 
 #Patch900: linux-2.6-900-ext3_mount_default_to_barrier.patch
 #Patch910: linux-2.6-910-support_barriers_on_single_device_dm_devices.patch
+Patch911: linux-2.6-911-perftools-f8-build.patch
 
 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
 
@@ -220,7 +213,7 @@ AutoReqProv: no
 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
 Provides: kernel-smp-devel = %{rpmversion}-%{release}
 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
-Prereq: /usr/bin/find
+Requires: /usr/bin/find
 
 %description devel
 This package provides kernel headers and makefiles sufficient to build modules
@@ -245,7 +238,7 @@ Summary: The Linux kernel compiled for unprivileged Xen guest VMs
 Group: System Environment/Kernel
 Provides: kernel = %{version}
 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
-Prereq: %{kernel_prereq}
+Requires: %{kernel_requires}
 Conflicts: %{kernel_dot_org_conflicts}
 Conflicts: %{package_conflicts}
 Conflicts: %{nptl_conflicts}
@@ -271,7 +264,7 @@ AutoReqProv: no
 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
 Provides: kernel-devel = %{rpmversion}-%{release}xenU
-Prereq: /usr/sbin/hardlink, /usr/bin/find
+Requires: /usr/sbin/hardlink, /usr/bin/find
 
 %description xenU-devel
 This package provides kernel headers and makefiles sufficient to build modules
@@ -292,7 +285,7 @@ Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
 Provides: kernel-devel = %{rpmversion}-%{release}smp
 AutoReqProv: no
-Prereq: /usr/sbin/hardlink, /usr/bin/find
+Requires: /usr/sbin/hardlink, /usr/bin/find
 
 %description uml-devel
 This package provides kernel headers and makefiles sufficient to build modules
@@ -366,6 +359,9 @@ KERNEL_PREVIOUS=vanilla
 %endif
 
 %ApplyPatch 10
+%if 0
+%ApplyPatch 11
+%endif
 %ApplyPatch 17
 
 %ApplyPatch 100
@@ -841,6 +837,40 @@ rm -f /lib/modules/%{KVERREL}uml/modules.*
 %endif
 
 %changelog
+* Tue Aug 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-27-37
+- fixed patch filename
+
+* Thu Jul 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-27-36
+- This patch fixes an issue that causes Build to fail on f8.
+
+* Sat Mar 26 2011 S.Çağlar Onur <caglar@verivue.com> - linux-2.6-27-35
+- Use build-planetlab.prg
+
+* Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-27-34
+- no semantic change - just fixed specfile for git URL
+
+* Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-33
+- Bump to 2.6.27.57
+
+* Thu Dec 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-27-32
+- harmless changes in specfile to build on fedora14
+
+* Tue Nov 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-31
+- Bump to 2.6.27.56
+
+* Thu Nov 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-30
+- Boot on Dell R410
+- Enable some config options
+
+* Fri Oct 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-29
+- bump to 2.6.27.55
+
+* Tue Oct 05 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-28
+- bump to 2.6.27.54
+
+* Fri Sep 24 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - linux-2.6-27-27
+- f12 workaround
+
 * Sun Aug 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-26
 - the check_stack_guard_page() has, under certain circumstances, side-effects which can not easily be undone in case the vx_rss_avail() fails