Default to build a coblitz kernel.
[linux-2.6.git] / kernel-2.6.spec
index 38f06a7..c75d295 100644 (file)
@@ -25,7 +25,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # for module-tag.py - sublevel is used for the version (middle) part of tag names
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 39
+%define taglevel 43
 
 #
 # Polite request for people who spin their own kernel rpms:
@@ -46,7 +46,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 
 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
-%{!?pldistro:%global pldistro planetlab}
+%{!?pldistro:%global pldistro coblitz}
 
 %define signmodules 0
 %define make_target bzImage
@@ -146,13 +146,18 @@ Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
 %endif
 
 Patch010: linux-2.6-010-e1000e.patch
+Patch015: linux-2.6-015-igb.patch
 Patch020: linux-2.6-020-build-id.patch
 Patch030: linux-2.6-030-netns.patch
 Patch040: linux-2.6-040-i_mutex-check.patch
+Patch050: linux-2.6-050-ixgbe.patch
 
 # These are patches picked up from Fedora/RHEL
 Patch100: linux-2.6-100-build-nonintconfig.patch
 
+Patch150: linux-2.6-150-cciss-allow-kexec-to-work.patch
+Patch151: linux-2.6-151-cciss-SAS.patch
+
 # Linux-VServer
 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
 Patch210: linux-2.6-210-vserver-cpu-sched.patch
@@ -188,9 +193,11 @@ Patch660: linux-2.6-660-nmi-watchdog-default.patch
 Patch670: linux-2.6-670-gcc43.patch
 %endif
 Patch680: linux-2.6-680-htb-hysteresis-tso.patch
-Patch690: linux-2.6-690-web100.patch
+#Patch690: linux-2.6-690-web100.patch
 Patch710: linux-2.6-710-avoid-64bits-addr-pcmcia.patch
 
+Patch800: linux-2.6-800-fix-4-bit-apicid-assumption.patch
+
 # See also the file named 'sources' here for the related checksums
 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
@@ -362,6 +369,7 @@ KERNEL_PREVIOUS=vanilla
 %endif
 
 %ApplyPatch 10
+%ApplyPatch 15
 %ApplyPatch 20
 
 # NetNS patch for VINI
@@ -369,9 +377,13 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 30
 %endif
 %ApplyPatch 40
+%ApplyPatch 50
 
 %ApplyPatch 100
 
+%ApplyPatch 150
+%ApplyPatch 151
+
 %ApplyPatch 200
 %ApplyPatch 210
 %ApplyPatch 220
@@ -407,9 +419,10 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 670
 %endif
 %ApplyPatch 680
-%ApplyPatch 690
 %ApplyPatch 710
 
+%ApplyPatch 800
+
 
 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
 # break with later patches.
@@ -502,6 +515,12 @@ BuildKernel() {
     make -s ARCH=$Arch INSTALL_HDR_PATH=$RPM_BUILD_ROOT/usr
     find $RPM_BUILD_ROOT/%{_includedir} -name \*.cmd -delete
     rm -f $RPM_BUILD_ROOT/%{_includedir}/{..,.}{check,install}*
+
+    # glibc provides scsi headers for itself, for now
+    rm -rf $RPM_BUILD_ROOT/usr/include/scsi
+    rm -f $RPM_BUILD_ROOT/usr/include/asm*/atomic.h
+    rm -f $RPM_BUILD_ROOT/usr/include/asm*/io.h
+    rm -f $RPM_BUILD_ROOT/usr/include/asm*/irq.h
 %endif
 
 %if %{build_iwlwifi}
@@ -883,6 +902,13 @@ rm -f /lib/modules/%{KVERREL}uml/modules.*
 %endif
 
 %changelog
+* Fri Feb 19 2010 Daniel Hokka Zakrisson <dhozac@coblitz.com> linux-2.6-22-42.coblitz
+- Use CoBlitz support address
+- hardware support
+
+* Sun Nov  8 2009 Daniel Hokka Zakrisson <daniel@hozac.com> linux-2.6-22-40.coblitz
+- Tag CoBlitz kernel
+
 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-39
 - outputs the kernel-headers rpm as backported from 2.6.27