Fix build on F16
[linux-2.6.git] / kernel-2.6.spec
index 53fa2f3..eeb33c7 100644 (file)
@@ -10,7 +10,7 @@ URL: %{SCMURL}
 
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 16
+%define taglevel 17
 
 %define sublevel 32
 
@@ -689,6 +689,7 @@ Patch19: linux-2.6-660-nmi-watchdog-default.patch
 Patch20: linux-2.6-680-htb-hysteresis-tso.patch
 
 Patch10000: linux-2.6-10000-gcc-4.5.patch
+Patch10001: linux-2.6-10001-f16-fix.patch
 # empty final patch file to facilitate testing of kernel patches
 Patch999999: linux-kernel-test.patch
 
@@ -985,6 +986,7 @@ ApplyPatch linux-2.6-650-hangcheck-reboot.patch
 ApplyPatch linux-2.6-660-nmi-watchdog-default.patch
 ApplyPatch linux-2.6-680-htb-hysteresis-tso.patch
 ApplyPatch linux-2.6-10000-gcc-4.5.patch
+ApplyPatch linux-2.6-10001-f16-fix.patch
 #### Planet-Lab ####
 
 ApplyOptionalPatch linux-kernel-test.patch
@@ -1117,8 +1119,9 @@ BuildKernel() {
     %endif
 
     #### Planet-Lab ####
-    # -Werror breaks F14 builds
+    # -Werror breaks F14+ builds
     sed -i -e "s:-Wno-array-bounds -Werror:-Wno-array-bounds:g" Makefile
+    sed -i -e "s: -Werror::g" tools/perf/Makefile
     #### Planet-Lab ####
 
     # and now to start the build process
@@ -1786,6 +1789,9 @@ fi
 %endif
 
 %changelog
+* Tue May 31 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-17
+- This commit fixes the COW issue through a patch provided by Daniel Hozac.
+
 * Sat Apr 09 2011 S.Çağlar Onur <caglar@verivue.com> - linux-2.6-32-16
 - bump to 2.6.32-71.24.1.el6, see https://rhn.redhat.com/errata/RHSA-2011-0421.html