Setting tag linux-2.6-22-47
[linux-2.6.git] / kernel-2.6.spec
index f07db61..f2465be 100644 (file)
@@ -34,7 +34,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # for module-tag.py - sublevel is used for the version (middle) part of tag names
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 44
+%define taglevel 47
 
 #
 # Polite request for people who spin their own kernel rpms:
@@ -53,9 +53,9 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # updated every time the PL kernel is updated.
 %define vini_pl_patch 561
 
-#%define updatelevel 1
+%define requiresreboot 0
 
-%define kernelrelease vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}%{?updatelevel:.%{updatelevel}}
+%define kernelrelease vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define packagerelease %{kernelrelease}
 
 %define signmodules 0
@@ -217,6 +217,11 @@ Patch800: linux-2.6-800-fix-4-bit-apicid-assumption.patch
 
 Patch810: linux-2.6-810-ich10.patch
 
+Patch900: linux-2.6-900-ext3_mount_default_to_barrier.patch
+Patch910: linux-2.6-910-support_barriers_on_single_device_dm_devices.patch
+
+Patch950: linux-2.6.950-ext3_backports.patch
+
 # See also the file named 'sources' here for the related checksums
 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
@@ -364,7 +369,7 @@ else
   cd kernel-%{kversion}
 fi
 
-%if "0%{updatelevel}"
+%if %{requiresreboot}
 echo "This is a trivial maintenance update. There will be no reboot following installation."
 %endif
 
@@ -454,6 +459,10 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 800
 %ApplyPatch 810
 
+%ApplyPatch 900
+%ApplyPatch 910
+
+%ApplyPatch 950
 
 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
 # break with later patches.
@@ -546,6 +555,7 @@ BuildKernel() {
     make -s ARCH=$Arch INSTALL_HDR_PATH=$RPM_BUILD_ROOT/usr
     find $RPM_BUILD_ROOT/%{_includedir} -name \*.cmd -delete
     rm -f $RPM_BUILD_ROOT/%{_includedir}/{..,.}{check,install}*
+    rm -rf $RPM_BUILD_ROOT/usr/include/scsi
 %endif
 
 %if %{iwlwifi}
@@ -802,11 +812,10 @@ pushd /boot > /dev/null ; {
 }
 popd > /dev/null
 
+%if %{requiresreboot}
 # ask for a reboot
 mkdir -p /etc/planetlab
-
-%if "%{updatelevel}"==""
-#touch /etc/planetlab/update-reboot
+touch /etc/planetlab/update-reboot
 %endif
 
 %post devel
@@ -930,6 +939,19 @@ rm -f /lib/modules/%{KVERREL}uml/modules.*
 %endif
 
 %changelog
+* Thu Apr 15 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-22-47
+- Tagging 22 branch with following changes;
+- * Make barrier=1 for ext3 filesystem,
+- * Support barriers on single device dm devices,
+- * Introduce various ext3 related fixes,
+- * Fix conflict between glibc-headers kernel-headers packages
+
+* Tue Mar 16 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-22-46
+- every released package should have a tag in svn, so remove updatelevel from naming scheme and also change the variable name
+
+* Tue Mar 16 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-22-45
+- add support for ICH10
+
 * Fri Feb 19 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-22-44
 - Disable rebooting