Some hacks that should make it build
[linux-3.git] / kernel-3.1.spec
index 2b41cf4..1f57e92 100644 (file)
@@ -1019,7 +1019,7 @@ ApplyPatch()
     exit 1
   fi
 %if !%{using_upstream_branch}
-  if ! grep -E "^Patch[0-9]+: $patch\$" %{_specdir}/${RPM_PACKAGE_NAME%%%%%{?variant}}.spec ; then
+  if ! grep -E "^Patch[0-9]+: $patch\$" %{_specdir}/kernel-3.1.spec ; then
     if [ "${patch:0:8}" != "patch-3." ] ; then
       echo "ERROR: Patch  $patch  not listed as a source patch in specfile"
       exit 1
@@ -1406,7 +1406,7 @@ ApplyPatch oom-fix-integer-overflow-of-points.patch
 # END OF PATCH APPLICATIONS
 
 # BEGIN Planet-Lab Patches
-%(cat planetlab-patches.in)
+%(cat planetlab-patches.in)
 # END OF Planet-Lab Patches
 
 %endif
@@ -2023,7 +2023,7 @@ fi
 %endif
 
 %if %{with_tools}
-%files -n kernel-tools -f cpupower.lang
+#%files -n kernel-tools -f cpupower.lang
 %defattr(-,root,root)
 %{_bindir}/perf
 %dir %{_libexecdir}/perf-core