Setting tag lxc-userspace-1.0-9
[lxc-userspace.git] / lxc-userspace.spec
1 %define name lxc-userspace
2 %define version 1.0
3 %define taglevel 9
4
5 %define percent %
6 %define braop \{
7 %define bracl \}
8
9 # this is getting really a lot of stuff, could be made simpler probably
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Userspace tools for switching between lxc containers
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Kernel
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 Source0: lxc-userspace-%{version}.tar.gz
25 Requires: binutils
26
27 Obsoletes: lxctools
28
29 %description
30 Userspace tools for switching between lxc containers.
31
32 %prep 
33 %setup -q
34
35 %build
36 make 
37
38 %install
39 mkdir -p $RPM_BUILD_ROOT/usr/sbin
40 install -D -m 755 vsh $RPM_BUILD_ROOT/usr/sbin/vsh
41 install -D -m 755 lxcsu $RPM_BUILD_ROOT/usr/sbin/lxcsu
42 install -D -m 755 lxcsu-internal $RPM_BUILD_ROOT/usr/sbin/lxcsu-internal
43 chmod u+s $RPM_BUILD_ROOT/usr/sbin/lxcsu
44 cp build/lib*/setns.so $RPM_BUILD_ROOT/usr/sbin
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /usr/sbin/*
51
52 %post
53 chmod u+s /usr/sbin/vsh
54
55 %postun
56
57 %changelog
58 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-9
59 - does not rely on capsh (actually this was the one in the sliver)
60 - use native capability dropping instead
61 - provides new slicesu binary
62 - suitable for libvirt-1.1 and above
63
64 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-8
65 - fix vsh permissions
66
67 * Sat Aug 31 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-7
68 - perform vsys sysctl inside of container
69 - remove unnecessary proc remounts
70 - prevent setting LD_PRELOAD if the library doesn't exist in image
71 - add --noslicehome option
72 - check /etc/lxcsu_default for default arguments
73 - fix permissions
74 - support conventional invocation of make
75
76 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-6
77 - merge back lxcsu and -internal into a single source file
78 - capsh --uid instead of --user that was not yet supported in f12 (hopefully tmp)
79
80 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-5
81 - entering in a slice now correctly ends up with right uid and pwd
82 - make sync
83
84 * Mon Jul 01 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxc-userspace-1.0-4
85 - Bug fixes:
86 - - lxcsu <slice_name> works again
87 - - pid namespace issue that would let slices see all processes
88
89 * Fri Jun 28 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxc-userspace-1.0-3
90 - Fixed bug that would let slices see all processes in root context.
91
92 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-2
93 - split into lxcsu{,-internal}
94
95 * Wed Jun 05 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-1
96 - rename module and package from lxctools into lxc-userspace
97
98 * Mon Jun 03 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxctools-0.9-8
99 - - Upgraded code for compatibility with kernel 3.6.9
100 - - Obsoleted modules for switching into mnt and pid namespaces
101 - - Added command to mount /proc if not mounted
102
103 * Wed May 29 2013 Andy Bavier <acb@cs.princeton.edu> - lxctools-0.9-7
104 - Use ArgumentParser, fix issue with sensing arch
105
106 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-6
107 - implements vm's arch
108
109 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-5
110 - more flexible and more robust lxcsu
111
112 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-4
113 - nicer polish to lxcsu returning the right thing
114
115 * Mon Mar 04 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-3
116 - lxcsu to propagate its forked process's return code
117
118 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-2
119 - various fixes
120