e047b90a098026b98b9b6211d691865bc42e4998
[lxc-userspace.git] / lxc-userspace.spec
1 %define name lxc-userspace
2 %define version 1.0
3 %define taglevel 0
4
5 %define percent %
6 %define braop \{
7 %define bracl \}
8
9 # this is getting really a lot of stuff, could be made simpler probably
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Userspace tools for switching between lxc containers
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Kernel
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 Source0: lxc-userspace-%{version}.tar.gz
25 Requires: binutils
26
27 Obsoletes: lxctools
28
29 %description
30 Userspace tools for switching between lxc containers.
31
32 %prep 
33 %setup -q
34
35 %build
36 make 
37
38 %install
39 mkdir -p $RPM_BUILD_ROOT/usr/sbin
40 install -D -m 755 vsh $RPM_BUILD_ROOT/usr/sbin/vsh
41 install -D -m 755 lxcsu $RPM_BUILD_ROOT/usr/sbin/lxcsu
42 chmod u+s $RPM_BUILD_ROOT/usr/sbin/lxcsu
43 cp build/lib*/setns.so $RPM_BUILD_ROOT/usr/sbin
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 /usr/sbin/*
50
51 %post
52 chmod u+s /usr/sbin/vsh
53
54 %postun
55
56 %changelog
57 * Mon Jun 03 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxctools-0.9-8
58 - - Upgraded code for compatibility with kernel 3.6.9
59 - - Obsoleted modules for switching into mnt and pid namespaces
60 - - Added command to mount /proc if not mounted
61
62 * Wed May 29 2013 Andy Bavier <acb@cs.princeton.edu> - lxctools-0.9-7
63 - Use ArgumentParser, fix issue with sensing arch
64
65 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-6
66 - implements vm's arch
67
68 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-5
69 - more flexible and more robust lxcsu
70
71 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-4
72 - nicer polish to lxcsu returning the right thing
73
74 * Mon Mar 04 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-3
75 - lxcsu to propagate its forked process's return code
76
77 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-2
78 - various fixes
79