perform vsys sysctl inside of container
[lxc-userspace.git] / lxc-userspace.spec
1 %define name lxc-userspace
2 %define version 1.0
3 %define taglevel 6
4
5 %define percent %
6 %define braop \{
7 %define bracl \}
8
9 # this is getting really a lot of stuff, could be made simpler probably
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Userspace tools for switching between lxc containers
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Kernel
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 Source0: lxc-userspace-%{version}.tar.gz
25 Requires: binutils
26
27 Obsoletes: lxctools
28
29 %description
30 Userspace tools for switching between lxc containers.
31
32 %prep 
33 %setup -q
34
35 %build
36 make 
37
38 %install
39 mkdir -p $RPM_BUILD_ROOT/usr/sbin
40 install -D -m 755 vsh $RPM_BUILD_ROOT/usr/sbin/vsh
41 install -D -m 755 lxcsu $RPM_BUILD_ROOT/usr/sbin/lxcsu
42 install -D -m 755 lxcsu-internal $RPM_BUILD_ROOT/usr/sbin/lxcsu-internal
43 chmod u+s $RPM_BUILD_ROOT/usr/sbin/lxcsu
44 cp build/lib*/setns.so $RPM_BUILD_ROOT/usr/sbin
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /usr/sbin/*
51
52 %post
53 chmod u+s /usr/sbin/vsh
54
55 %postun
56
57 %changelog
58 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-6
59 - merge back lxcsu and -internal into a single source file
60 - capsh --uid instead of --user that was not yet supported in f12 (hopefully tmp)
61
62 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-5
63 - entering in a slice now correctly ends up with right uid and pwd
64 - make sync
65
66 * Mon Jul 01 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxc-userspace-1.0-4
67 - Bug fixes:
68 - - lxcsu <slice_name> works again
69 - - pid namespace issue that would let slices see all processes
70
71 * Fri Jun 28 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxc-userspace-1.0-3
72 - Fixed bug that would let slices see all processes in root context.
73
74 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-2
75 - split into lxcsu{,-internal}
76
77 * Wed Jun 05 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-1
78 - rename module and package from lxctools into lxc-userspace
79
80 * Mon Jun 03 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxctools-0.9-8
81 - - Upgraded code for compatibility with kernel 3.6.9
82 - - Obsoleted modules for switching into mnt and pid namespaces
83 - - Added command to mount /proc if not mounted
84
85 * Wed May 29 2013 Andy Bavier <acb@cs.princeton.edu> - lxctools-0.9-7
86 - Use ArgumentParser, fix issue with sensing arch
87
88 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-6
89 - implements vm's arch
90
91 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-5
92 - more flexible and more robust lxcsu
93
94 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-4
95 - nicer polish to lxcsu returning the right thing
96
97 * Mon Mar 04 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-3
98 - lxcsu to propagate its forked process's return code
99
100 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-2
101 - various fixes
102