iron out argument parser usage, add --debug option, and get this to work again in...
[lxc-userspace.git] / lxctools.spec
1 %define name lxctools
2 %define version 0.9
3 %define taglevel 7
4
5 %define percent %
6 %define braop \{
7 %define bracl \}
8
9 # this is getting really a lot of stuff, could be made simpler probably
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Userspace tools for switching between lxc containers
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Kernel
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 Source0: lxctools-%{version}.tar.gz
25 Requires: binutils
26
27 %description
28 Userspace tools for switching between lxc containers.
29
30 %prep 
31 %setup -q
32
33 %build
34 make 
35
36 %install
37 mkdir -p $RPM_BUILD_ROOT/usr/sbin
38 install -D -m 755 vsh $RPM_BUILD_ROOT/usr/sbin/vsh
39 install -D -m 755 lxcsu $RPM_BUILD_ROOT/usr/sbin/lxcsu
40 chmod u+s $RPM_BUILD_ROOT/usr/sbin/lxcsu
41 cp build/lib*/setns.so $RPM_BUILD_ROOT/usr/sbin
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 /usr/sbin/*
48
49 %post
50 chmod u+s /usr/sbin/vsh
51
52 %postun
53
54 %changelog
55 * Wed May 29 2013 Andy Bavier <acb@cs.princeton.edu> - lxctools-0.9-7
56 - Use ArgumentParser, fix issue with sensing arch
57
58 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-6
59 - implements vm's arch
60
61 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-5
62 - more flexible and more robust lxcsu
63
64 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-4
65 - nicer polish to lxcsu returning the right thing
66
67 * Mon Mar 04 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-3
68 - lxcsu to propagate its forked process's return code
69
70 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-2
71 - various fixes
72