changes for 3.0
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 1.0
9 %define taglevel 16
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: Monitor account initialization for the root image.
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Requires: curl
28 Requires: coreutils
29
30 %description
31 Scripts for creating the monitor account in the root filesystem, to enable node access 
32 without using the 'root' account.
33
34 %prep
35 %setup -q
36
37 %build
38 echo "There is no build stage.  Simply copy files."
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -D -m 755 monitor.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
43 install -D -m 755 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(-,root,root)
50 %{_initrddir}/monitor
51 %{_sysconfdir}/cron.d/monitor
52
53 %post
54 chkconfig --add monitor
55 chkconfig monitor on
56
57 %changelog
58 * Mon Apr 13 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-16
59 - add email exceptions.
60 - add better timeouts for commands even once ssh has opened a connection
61
62 * Thu Feb 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-15
63 - fixed bug that prevented penalties from escalating and PIs from getting
64 - emails.
65
66 * Fri Feb 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-14
67 - updated printbadnodes.py to include diff_time()
68 - changed eamils to use literal addresses not tech-* and pi-* aliases
69 - updates to automation script to prevent false errors.
70
71 * Tue Nov 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-13
72 - Fixed for email change in unified_model.py tweaks in others.
73
74 * Wed Oct 29 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-12
75 - Improvements in web pages, and default installation options, and RT queue
76 - setup.
77 - Send direct emails rather than using tech- & pi- aliases
78
79 * Tue Oct 21 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-11
80 - send direct email, not to tech-* and pi-* aliases.
81
82 * Tue Oct 14 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-10
83 - an update to the latest tag.  looks like I actually needed to update the tags
84 - file more than this.
85
86 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-9
87 - includes all removals of 'monitorconfig'
88
89 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
90 - These are all changes in the latest Monitor code.  I will branch this version
91 - next, before making additional large changes.
92
93 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
94 - Checkpointing current version for 4.2-rc21 - many many changes
95
96 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
97 - This is a major tag of every thing.  probably needs a very different release
98 - number.
99
100 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
101 - Incremental improvements
102
103 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
104 - tagging everything for OneLab tech-transfer.
105
106
107 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
108
109
110 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
111
112
113 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
114 - This should be ready for 4.2rc2
115
116
117 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
118 - initial addition.