Many small updates and fixes:
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.1
10 %define taglevel 0
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28
29 Summary: Monitor account initialization for the root image.
30 Group: Applications/System
31
32 %description
33 Monitor is a collection of secondary scripts for configuring the node polling
34 system, syncing the PLC db with the monitoring database, notifying users,
35 interacting with PCU hardware, applying penalties to sites that violate
36 acceptable use.
37
38 ######################################## NAGIOS
39
40 %package nagios
41 Summary: Monitor integration with Nagios
42 Group: Applications/System
43
44 Requires: coreutils
45 Requires: passwd
46 Requires: gd
47 Requires: gd-devel
48 Requires: mysql
49 Requires: mysql-server
50 Requires: mysql-devel
51 Requires: mysql-libs
52 Requires: mailx
53 Requires: sendmail
54 Requires: php
55 Requires: httpd
56
57 Requires: cronie
58 Requires: nagios
59 Requires: nagios-common
60 Requires: nagios-devel
61 Requires: nagios-plugins-all
62 Requires: ndoutils
63 Requires: ndoutils-mysql
64
65 Requires: rt3
66
67
68 %description nagios
69 Scripts and setup necessary to integrate and monitor PLC with Nagios.
70 Best suited to F12 or above.
71
72 ######################################## CLIENT
73
74 %package client
75 Summary: Monitor hooks for a PLC node
76 Group: Applications/System
77 Requires: curl
78 Requires: coreutils
79
80 %description client
81 The client scripts handle account creation inside of a node.  This will
82 include configuration setup for the monitoring agent running on the node.  It
83 will also include any cron or init scripts needed to perform this kind of
84 maintenance.
85 ######################################## Server Deps
86 %package server-deps
87 Summary: Monitor hooks for the PLC server.
88 Group: Applications/System
89
90 Requires: python
91 Requires: python-setuptools-devel
92 Requires: python-peak-util-extremes
93
94 Requires: compat-libstdc++-296
95 Requires: openssh-clients
96 Requires: perl-libwww-perl
97 Requires: perl-IO-Socket-SSL 
98 Requires: MySQL-python
99 Requires: nmap
100 Requires: nc
101 Requires: rt3
102
103 Requires: plewww-plekit
104
105 #Requires: zabbix-client
106 #Requires: zabbix-gui
107 #Requires: zabbix-server
108
109 %description server-deps
110 The server side include all python modules and scripts needed to fully
111
112 ######################################## Server
113 %package server
114 Summary: Monitor hooks for the PLC server.
115 Group: Applications/System
116
117 Requires: python
118
119 Requires: monitor-server-deps
120 Requires: PLCWWW >= 4.2
121 Requires: bootcd-%{pldistro}-%{distroname}-%{_arch} >= 5.0
122 Requires: pcucontrol
123
124 %description server
125 The server side include all python modules and scripts needed to fully
126 operation, track, and interact with any third-party monitoring software, such
127 as Zabbix DB.
128
129 ####################################### RunlevelAgent
130 %package runlevelagent
131 summary: the RunlevelAgent that reports node runlevels
132 group: applications/system
133 requires: python
134
135 %description runlevelagent
136 The RunlevelAgent starts as early as possible during boot-up and production
137 mode to actively report the observed runlevel to PLC and update the
138 'last_contact' field.
139
140 %prep
141 %setup -q
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 #################### CLIENT 
146 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
147 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
148 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
149
150
151 #################### SERVER
152 install -d $RPM_BUILD_ROOT/usr/share/%{name}
153 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
154 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
155 install -d $RPM_BUILD_ROOT/var/lib/%{name}
156 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
157 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
158 install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
159 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
160
161 # plc.d scripts
162 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
163 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
164 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
165
166 install -D -m 755 nagios/monitor-nagios.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor-nagios
167 install -D -m 644 nagios/monitor-nagios.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-nagios.cron
168
169 # cron job for automated polling
170 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
171
172 # apache configuration
173 install -D -m 644 web/monitorweb-httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
174
175 # we'll install monitor in site-packages install rest to
176 # /usr/share/monitor
177 rsync -a --exclude archive-pdb --exclude .cvsignore --exclude .svn --exclude CVS  \
178     --exclude monitor/ \
179     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
180
181 # install monitor python package
182 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
183
184 install -D -m 644 monitor/wrapper/plc.py $RPM_BUILD_ROOT/usr/share/%{name}/nagios/
185 install -D -m 644 monitor/generic.py $RPM_BUILD_ROOT/usr/share/%{name}/nagios/
186
187 # install third-party module to site-packages
188 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
189
190 # TODO: 
191 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
192 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
193
194 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
195 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
196
197 #################### RunlevelAgent
198 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
199 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
200
201 mkdir -p $RPM_BUILD_ROOT/var/log
202 touch $RPM_BUILD_ROOT/var/log/server-deps.log
203
204
205 %clean
206 rm -rf $RPM_BUILD_ROOT
207
208 %files server-deps
209 /var/log/server-deps.log
210
211 %files nagios
212 %defattr(-,root,root)
213 %{_sysconfdir}/plc.d/monitor-nagios
214 /usr/share/%{name}/nagios 
215 %{_sysconfdir}/cron.d/monitor-nagios.cron
216
217 %files server
218 %defattr(-,root,root)
219 #%config /usr/share/%{name}/monitorconfig.py
220 #%config /etc/monitor.conf
221 /var/lib/%{name}
222 /usr/share/%{name}/MANIFEST.in
223 /usr/share/%{name}/Makefile
224 /usr/share/%{name}/Monitor.spec
225 /usr/share/%{name}/README.txt
226 /usr/share/%{name}/RunlevelAgent.py*
227 /usr/share/%{name}/automate-default.sh
228 /usr/share/%{name}/monitor-default.conf
229 /usr/share/%{name}/monitor-runlevelagent.init
230 /usr/share/%{name}/monitor-server.cron
231 /usr/share/%{name}/monitor-server.init
232 /usr/share/%{name}/monitor.functions
233 /usr/share/%{name}/setup.py*
234 /usr/share/%{name}/threadpool.py*
235 /usr/share/%{name}/zabbix.spec
236
237 /usr/share/%{name}/bootcd
238 /usr/share/%{name}/commands
239 /usr/share/%{name}/config.d
240 /usr/share/%{name}/cron.d
241 /usr/share/%{name}/docs
242 /usr/share/%{name}/keys
243 /usr/share/%{name}/log
244 /usr/share/%{name}/statistics
245 /usr/share/%{name}/tests
246 /usr/share/%{name}/tools
247 /usr/share/%{name}/upgrade
248 /usr/share/%{name}/web
249 /usr/share/%{name}/zabbix
250
251 #/var/www/cgi-bin/monitor
252 %{_sysconfdir}/cron.d/monitor-server.cron
253 %{_sysconfdir}/plc.d/monitor
254 %{_sysconfdir}/plc.d/monitor.functions
255 %{_sysconfdir}/plc.d/zabbix
256 %{_sysconfdir}/httpd/conf.d
257 %{python_sitearch}
258
259
260 %files client
261 %defattr(-,root,root)
262 #%{_initrddir}/monitor
263 #%{_sysconfdir}/cron.d/monitor
264 /usr/bin/timeout.pl
265
266 %files runlevelagent
267 /usr/bin/RunlevelAgent.py*
268 /%{_initrddir}/monitor-runlevelagent
269
270
271 %post server-deps
272 #
273 # TODO: depend on distribution packages where feasible.
274 #
275 #  it would be better to be able to depend on the distribution's
276 # packages for these additional python modules, but packages provided
277 # by fedora 8 (our current deployment) doesn't match the version
278 # requirements.
279 export TMPDIR=/var/tmp/
280 easy_install -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
281 easy_install -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
282 easy_install -UZ Elixir
283
284 # crazy openssl libs for racadm binary
285 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
286 mkdir %{_datadir}/%{name}/.ssh
287 chmod 700 %{_datadir}/%{name}/.ssh
288
289 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
290     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
291 fi
292
293 # NOTE: enable monitor by default, since we're installing it.
294 if ! plc-config --category plc_monitor --variable enabled ; then 
295         plc-config --category plc_monitor --variable enabled --value true \
296                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
297 fi
298 if ! plc-config --category plc_monitor --variable from_email ; then
299         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
300                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
301 fi
302 if ! plc-config --category plc_monitor --variable cc_email ; then
303         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
304                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
305 fi
306 if ! plc-config --category plc_monitor --variable rt_queue ; then
307         plc-config --category plc_monitor --variable rt_queue --value support \
308                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
309 fi
310
311 # zabbix:
312 if ! plc-config --category plc_zabbix --variable enabled ; then
313         plc-config --category plc_zabbix --variable enabled --value false \
314                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
315 fi
316 if ! plc-config --category plc_zabbix --variable host ; then
317         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
318                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
319 fi
320 if ! plc-config --category plc_zabbix --variable ip ; then
321         plc-config --category plc_zabbix --variable ip --value "" \ 
322                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
323 fi
324
325 %post nagios
326 # TODO: do as much as possible to get the host setup and running.
327 #chkconfig --add monitor-nagios
328 #chkconfig monitor-nagios on
329 chkconfig mysqld on
330
331 %post server
332 # TODO: this will be nice when we have a web-based service running., such as
333 #               an API server or so on.
334 # TODO: create real monitorconfig.py from monitorconfig-default.py
335 # TODO: create symlink in /var/lib/monitor for chroot environments
336 # TODO: update the content of automate_pl03.sh 
337 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
338
339 # NOTE: generate the python defines from zabbix include files.
340 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
341
342 # apply patches to zabbix
343 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
344
345 #chkconfig --add monitor-server
346 #chkconfig monitor-server on
347
348 %post client
349 chkconfig --add monitor
350 chkconfig monitor on
351
352 %post runlevelagent
353 if [ -f /etc/planetlab/node_id ] ; then
354     chkconfig --add monitor-runlevelagent
355     chkconfig monitor-runlevelagent on
356     if [ "$PL_BOOTCD" != "1" ] ; then
357         service monitor-runlevelagent restart
358     fi
359 fi
360
361
362 %changelog
363 * Thu May 20 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-35
364 - Add CSV link on Advanced query
365 - Preparing to branch
366
367 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-34
368 - * copy selections to clipbord on Advanced Query page
369 - * RPM Pattern as regexp
370 - * scan ipmi port
371
372 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-33
373 - handle hostname changes
374
375 * Tue Apr 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-32
376 - from this version, suitable for 5.0
377 - requires bootcd with the new 5.0 naming style 3-part nodefamily
378
379 * Mon Apr 12 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-31
380 - added fix for node delete/add causing conflicts in MyOps db.
381 - added statistics scripts
382
383 * Thu Jan 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-30
384 - * fix paths for automate script
385
386 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-29
387 - - separate pcucontrol as an svn module
388 - - restore easy_instal back into post install stage of server-deps
389 - - template imporovements for web interface
390
391 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-28
392 - do not need buildrequires. a new tag to fix centos builds
393
394 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-27
395 - fix rpm build issues
396
397 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
398 - to many changes, but mostly moved stuff around. there are some small fixes here and there.
399
400 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
401 - add option for site status to include both node & pcu status
402 - improve ticket handling
403 - template gadget.xml for a site-specific google-gadget summary
404
405 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
406 - - add install_date
407
408 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
409 - - remove monitor-client.cron
410 - - remove unused monitor-client init script
411 - - fix UP/DOWN summary on nodes page.
412 - - make node page display all nodes by default
413 - - add boot_server field
414 - - add myops_ssh_key to the keychain
415 - - use ext_consortium_id to distinguish pending sites.
416
417 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
418 - show/hide advance query form.
419
420 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
421 - fixed pause_penalty bug.
422 - fixed IPAL pcucontrol bug
423 - fixed bootman tunnel setup bug (occurred in rare cases)
424 - deprecated pcuview
425 - added BootmanSequenceRecords to separate config data from source code
426 - added get/setBootmanSequence(s) to xmlrpc API
427
428 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
429 - Major Features:
430 - added bm log collection and optional integration with BootManager's log Upload()
431 - added iptables_status
432 - expanded advanced query
433 - added differentiated bootmanager_restore actions so that actionsummary displays
434 - counts for each kind of bootmanager action
435 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
436 - added plain-text options for query page by adding tg_format=plain to URL
437 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
438 - fixed a bug in determining whether comon's dir was running on a node
439
440 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
441 - Major increment -
442 - adds multiple features and web changes
443 - adds new fields to db
444 - improved layout
445 - general improvements otherwise
446
447 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
448 - bug fixes.
449 - improved templates and views
450 - cleaned controller code for web
451 - added IPMI requirement to pcucontrol package.
452
453 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
454 - added bootmanager log links
455 - addressed root cause of IntegrityErrors ; big deal
456 - adjusted templates to accomodate fix for IntegrityErrors
457 - added session.flush() to bootman.py to write out ActionsRecords
458 - fixed policy to either pause penalties or apply them ; not both.
459
460 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
461 -- Added Rpyc from 1.0 branch.
462 -- add pcuhistory
463 -- add setup-agent for password protected keys.
464 -- other minor improvements.
465
466 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
467 - automate install
468 - auto-close tickets
469
470 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
471 - update web
472 - update policy
473 - added statistics dir
474
475 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
476 - remove plccache from controllers, all lookups from db.
477 - reformat emailTxt messags
478 - updated bootstates in bootman.py
479
480 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
481 - tag of latest changes.
482 - need to test end to end.
483
484 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
485 - big merge from the 2.0 branch
486
487 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
488 - minor improvements in rendering with sortable tables
489
490 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
491
492 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
493 - first draft with sortable tables + checkpoint
494
495 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
496 - use plekit tables from plewww.
497 - depend on plewww-plekit
498
499 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
500 - make docs a noop
501 - fix for package name dependency
502 - correct docs
503
504 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
505 - add improved docs to the latest build and tag.
506
507 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
508 - add documentation hooks for adding in-line docs like NM and PLCAPI
509
510 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
511 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
512 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
513 - 'safeboot', 'failboot', 'reinstall', etc.
514
515 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
516 - same as 2.0-12 tag.
517
518 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
519 - merge from 2.0, remove more zabbix code, simplify install, etc.
520
521 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
522 - major merge from 2.0 branch.
523 - ready to be updated with 4.3 and web changes.
524
525 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
526 - preparing to make a 2.0 branch for monitor.
527
528 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
529 - new changes are significantly different, that I'm upping the number for clarity.
530
531 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
532 - These are all changes in the latest Monitor code.  I will branch this version
533 - next, before making additional large changes.
534
535 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
536 - Checkpointing current version for 4.2-rc21 - many many changes
537
538 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
539 - This is a major tag of every thing.  probably needs a very different release
540 - number.
541
542 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
543 - Incremental improvements
544
545 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
546 - tagging everything for OneLab tech-transfer.
547
548
549 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
550
551
552 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
553
554
555 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
556 - This should be ready for 4.2rc2
557
558
559 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
560 - initial addition.
561
562 %define module_current_branch 3.0