more fixes for a new install
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.0
10 %Define Taglevel 25
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 Summary: Monitor account initialization for the root image.
29 Group: Applications/System
30
31 %description
32 Monitor is a collection of secondary scripts for configuring the node polling
33 system, syncing the PLC db with the monitoring database, notifying users,
34 interacting with PCU hardware, applying penalties to sites that violate
35 acceptable use.
36
37 ######################################## CLIENT
38
39 %package client
40 Summary: Monitor hooks for a PLC node
41 Group: Applications/System
42 Requires: curl
43 Requires: coreutils
44
45 %description client
46 The client scripts handle account creation inside of a node.  This will
47 include configuration setup for the monitoring agent running on the node.  It
48 will also include any cron or init scripts needed to perform this kind of
49 maintenance.
50 ######################################## Server Deps
51 %package server-deps
52 Summary: Monitor hooks for the PLC server.
53 Group: Applications/System
54
55 Requires: python
56 Requires: python-setuptools-devel
57 Requires: python-peak-util-extremes
58
59 Requires: compat-libstdc++-296
60 Requires: openssh-clients
61 Requires: perl-libwww-perl
62 Requires: perl-IO-Socket-SSL 
63 Requires: MySQL-python
64 Requires: nmap
65 Requires: nc
66 Requires: rt3
67
68 Requires: plewww-plekit
69
70 #Requires: zabbix-client
71 #Requires: zabbix-gui
72 #Requires: zabbix-server
73
74 %description server-deps
75 The server side include all python modules and scripts needed to fully
76
77 ######################################## Server
78 %package server
79 Summary: Monitor hooks for the PLC server.
80 Group: Applications/System
81
82 Requires: python
83
84 Requires: monitor-server-deps
85 Requires: monitor-pcucontrol
86 Requires: PLCWWW >= 4.2
87 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
88
89 %description server
90 The server side include all python modules and scripts needed to fully
91 operation, track, and interact with any third-party monitoring software, such
92 as Zabbix DB.
93
94 ######################################## PCU Control
95
96 %package pcucontrol
97 summary: pcu controls for monitor and plcapi
98 group: applications/system
99 requires: python
100 requires: OpenIPMI-tools
101
102 %description pcucontrol
103 both monitor and the plcapi use a set of common commands to reboot machines
104 using their external or internal pcus.  this package is a library of several
105 supported models.
106
107 ####################################### RunlevelAgent
108 %package runlevelagent
109 summary: the RunlevelAgent that reports node runlevels
110 group: applications/system
111 requires: python
112
113 %description runlevelagent
114 The RunlevelAgent starts as early as possible during boot-up and production
115 mode to actively report the observed runlevel to PLC and update the
116 'last_contact' field.
117
118 %prep
119 %setup -q
120
121 %build
122 # NOTE: the build uses g++ cmdamt/
123 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
124 cd pcucontrol/models/intelamt
125 export TMPDIR=$PWD/tmp
126 make
127 cd ..
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 #################### CLIENT 
132 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
133 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
134 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
135
136
137 #################### SERVER
138 install -d $RPM_BUILD_ROOT/usr/share/%{name}
139 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
140 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
141 install -d $RPM_BUILD_ROOT/var/lib/%{name}
142 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
143 #install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
144 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
145 install -d $RPM_BUILD_ROOT/%{python_sitearch}/
146
147 export PYTHONPATH=$PYTHONPATH:$RPM_BUILD_ROOT/%{python_sitearch}/
148 # pack monitor's dependencies in RPM to make it easier to deploy.
149 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
150 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
151 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ Elixir
152 rm -rf $RPM_BUILD_ROOT/%{python_sitearch}/site.py*
153
154 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
155 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
156 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
157
158 echo " * Installing core scripts"
159 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
160           ./ $RPM_BUILD_ROOT/usr/share/%{name}/
161
162 install -D -m 644 web/monitorweb-httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
163
164
165 echo " * Installing web pages"
166 #rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
167 rsync -a log/ $RPM_BUILD_ROOT/var/www/html/monitorlog/
168
169 echo " * Installing cron job for automated polling"
170 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
171 echo " * TODO: Setting up Monitor account in local MyPLC"
172 # TODO: 
173
174 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
175 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
176 # TODO: need a much better way to do this.
177 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
178 #for file in __init__.py database.py config.py ; do 
179 #       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
180 #done
181 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
182 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
183
184 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
185 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
186
187 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
188 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
189
190 #################### RunlevelAgent
191 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
192 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
193
194 mkdir -p $RPM_BUILD_ROOT/var/log
195 touch $RPM_BUILD_ROOT/var/log/server-deps.log
196
197
198 %clean
199 rm -rf $RPM_BUILD_ROOT
200
201 %files server-deps
202 /var/log/server-deps.log
203
204 %files server
205 %defattr(-,root,root)
206 #%config /usr/share/%{name}/monitorconfig.py
207 #%config /etc/monitor.conf
208 /usr/share/%{name}
209 /var/lib/%{name}
210 #/var/www/cgi-bin/monitor
211 %{_sysconfdir}/cron.d/monitor-server.cron
212 %{python_sitearch}/threadpool.py
213 %{python_sitearch}/threadpool.pyc
214 %{python_sitearch}/threadpool.pyo
215 %{python_sitearch}/monitor
216 %{python_sitearch}/Turbo*
217 %{python_sitearch}/SQLAlchemy*
218 %{python_sitearch}/Elixir*
219 %{python_sitearch}/easy-install.pth
220 %{python_sitearch}/tg-admin
221 %{_sysconfdir}/plc.d/monitor
222 %{_sysconfdir}/plc.d/monitor.functions
223 %{_sysconfdir}/plc.d/zabbix
224
225 %files client
226 %defattr(-,root,root)
227 #%{_initrddir}/monitor
228 #%{_sysconfdir}/cron.d/monitor
229 /usr/bin/timeout.pl
230
231 %files pcucontrol
232 %{python_sitearch}/pcucontrol
233
234 %files runlevelagent
235 /usr/bin/RunlevelAgent.py
236 /usr/bin/RunlevelAgent.pyo
237 /usr/bin/RunlevelAgent.pyc
238 /%{_initrddir}/monitor-runlevelagent
239
240 %post server-deps
241
242 # crazy openssl libs for racadm binary
243 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
244 mkdir %{_datadir}/%{name}/.ssh
245 chmod 700 %{_datadir}/%{name}/.ssh
246
247 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
248     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
249 fi
250
251 # NOTE: enable monitor by default, since we're installing it.
252 if ! plc-config --category plc_monitor --variable enabled ; then 
253         plc-config --category plc_monitor --variable enabled --value true \
254                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
255 fi
256 if ! plc-config --category plc_monitor --variable from_email ; then
257         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
258                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
259 fi
260 if ! plc-config --category plc_monitor --variable cc_email ; then
261         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
262                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
263 fi
264 if ! plc-config --category plc_monitor --variable rt_queue ; then
265         plc-config --category plc_monitor --variable rt_queue --value support \
266                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
267 fi
268
269 # zabbix:
270 if ! plc-config --category plc_zabbix --variable enabled ; then
271         plc-config --category plc_zabbix --variable enabled --value false \
272                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
273 fi
274 if ! plc-config --category plc_zabbix --variable host ; then
275         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
276                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
277 fi
278 if ! plc-config --category plc_zabbix --variable ip ; then
279         plc-config --category plc_zabbix --variable ip --value "" \ 
280                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
281 fi
282
283 %post server
284 # TODO: this will be nice when we have a web-based service running., such as
285 #               an API server or so on.
286 # TODO: create real monitorconfig.py from monitorconfig-default.py
287 # TODO: create symlink in /var/lib/monitor for chroot environments
288 # TODO: update the content of automate_pl03.sh 
289 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
290
291 # NOTE: generate the python defines from zabbix include files.
292 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
293
294 # apply patches to zabbix
295 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
296
297 #chkconfig --add monitor-server
298 #chkconfig monitor-server on
299
300 %post client
301 chkconfig --add monitor
302 chkconfig monitor on
303
304 %post runlevelagent
305 chkconfig --add monitor-runlevelagent
306 chkconfig monitor-runlevelagent on
307 if [ "$PL_BOOTCD" != "1" ] ; then
308         service monitor-runlevelagent restart
309 fi
310
311
312 %changelog
313 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
314 - add option for site status to include both node & pcu status
315 - improve ticket handling
316 - template gadget.xml for a site-specific google-gadget summary
317
318 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
319 - - add install_date
320
321 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
322 - - remove monitor-client.cron
323 - - remove unused monitor-client init script
324 - - fix UP/DOWN summary on nodes page.
325 - - make node page display all nodes by default
326 - - add boot_server field
327 - - add myops_ssh_key to the keychain
328 - - use ext_consortium_id to distinguish pending sites.
329
330 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
331 - show/hide advance query form.
332
333 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
334 - fixed pause_penalty bug.
335 - fixed IPAL pcucontrol bug
336 - fixed bootman tunnel setup bug (occurred in rare cases)
337 - deprecated pcuview
338 - added BootmanSequenceRecords to separate config data from source code
339 - added get/setBootmanSequence(s) to xmlrpc API
340
341 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
342 - Major Features:
343 - added bm log collection and optional integration with BootManager's log Upload()
344 - added iptables_status
345 - expanded advanced query
346 - added differentiated bootmanager_restore actions so that actionsummary displays
347 - counts for each kind of bootmanager action
348 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
349 - added plain-text options for query page by adding tg_format=plain to URL
350 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
351 - fixed a bug in determining whether comon's dir was running on a node
352
353 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
354 - Major increment -
355 - adds multiple features and web changes
356 - adds new fields to db
357 - improved layout
358 - general improvements otherwise
359
360 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
361 - bug fixes.
362 - improved templates and views
363 - cleaned controller code for web
364 - added IPMI requirement to pcucontrol package.
365
366 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
367 - added bootmanager log links
368 - addressed root cause of IntegrityErrors ; big deal
369 - adjusted templates to accomodate fix for IntegrityErrors
370 - added session.flush() to bootman.py to write out ActionsRecords
371 - fixed policy to either pause penalties or apply them ; not both.
372
373 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
374 -- Added Rpyc from 1.0 branch.
375 -- add pcuhistory
376 -- add setup-agent for password protected keys.
377 -- other minor improvements.
378
379 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
380 - automate install
381 - auto-close tickets
382
383 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
384 - update web
385 - update policy
386 - added statistics dir
387
388 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
389 - remove plccache from controllers, all lookups from db.
390 - reformat emailTxt messags
391 - updated bootstates in bootman.py
392
393 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
394 - tag of latest changes.
395 - need to test end to end.
396
397 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
398 - big merge from the 2.0 branch
399
400 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
401 - minor improvements in rendering with sortable tables
402
403 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
404
405 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
406 - first draft with sortable tables + checkpoint
407
408 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
409 - use plekit tables from plewww.
410 - depend on plewww-plekit
411
412 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
413 - make docs a noop
414 - fix for package name dependency
415 - correct docs
416
417 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
418 - add improved docs to the latest build and tag.
419
420 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
421 - add documentation hooks for adding in-line docs like NM and PLCAPI
422
423 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
424 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
425 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
426 - 'safeboot', 'failboot', 'reinstall', etc.
427
428 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
429 - same as 2.0-12 tag.
430
431 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
432 - merge from 2.0, remove more zabbix code, simplify install, etc.
433
434 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
435 - major merge from 2.0 branch.
436 - ready to be updated with 4.3 and web changes.
437
438 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
439 - preparing to make a 2.0 branch for monitor.
440
441 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
442 - new changes are significantly different, that I'm upping the number for clarity.
443
444 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
445 - These are all changes in the latest Monitor code.  I will branch this version
446 - next, before making additional large changes.
447
448 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
449 - Checkpointing current version for 4.2-rc21 - many many changes
450
451 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
452 - This is a major tag of every thing.  probably needs a very different release
453 - number.
454
455 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
456 - Incremental improvements
457
458 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
459 - tagging everything for OneLab tech-transfer.
460
461
462 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
463
464
465 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
466
467
468 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
469 - This should be ready for 4.2rc2
470
471
472 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
473 - initial addition.
474
475 %define module_current_branch 2.0