ops...
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version %(python -c "import sys; sys.path.append('$RPM_SOURCE_DIR');from monitor.monitor_version import *; print monitor_version")
9 %define taglevel 25
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Summary: Monitor account initialization for the root image.
28 Group: Applications/System
29
30 %description
31 Monitor is a collection of secondary scripts for configuring the node polling
32 system, syncing the PLC db with the monitoring database, notifying users,
33 interacting with PCU hardware, applying penalties to sites that violate
34 acceptable use.
35
36 ######################################## CLIENT
37
38 %package client
39 Summary: Monitor hooks for a PLC node
40 Group: Applications/System
41 Requires: curl
42 Requires: coreutils
43
44 %description client
45 The client scripts handle account creation inside of a node.  This will
46 include configuration setup for the monitoring agent running on the node.  It
47 will also include any cron or init scripts needed to perform this kind of
48 maintenance.
49 ######################################## Server Deps
50 %package server-deps
51 Summary: Monitor hooks for the PLC server.
52 Group: Applications/System
53
54 Requires: python
55 Requires: python-setuptools-devel
56 Requires: python-peak-util-extremes
57
58 Requires: compat-libstdc++-296
59 Requires: openssh-clients
60 Requires: perl-libwww-perl
61 Requires: perl-IO-Socket-SSL 
62 Requires: MySQL-python
63 Requires: nmap
64 Requires: nc
65 Requires: rt3
66
67 Requires: plewww-plekit
68
69 #Requires: zabbix-client
70 #Requires: zabbix-gui
71 #Requires: zabbix-server
72
73 %description server-deps
74 The server side include all python modules and scripts needed to fully
75
76 ######################################## Server
77 %package server
78 Summary: Monitor hooks for the PLC server.
79 Group: Applications/System
80
81 Requires: python
82
83 Requires: monitor-server-deps
84 Requires: monitor-pcucontrol
85 Requires: PLCWWW >= 4.2
86 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
87
88 %description server
89 The server side include all python modules and scripts needed to fully
90 operation, track, and interact with any third-party monitoring software, such
91 as Zabbix DB.
92
93 ######################################## PCU Control
94
95 %package pcucontrol
96 summary: pcu controls for monitor and plcapi
97 group: applications/system
98 requires: python
99 requires: OpenIPMI-tools
100
101 %description pcucontrol
102 both monitor and the plcapi use a set of common commands to reboot machines
103 using their external or internal pcus.  this package is a library of several
104 supported models.
105
106 ####################################### RunlevelAgent
107 %package runlevelagent
108 summary: the RunlevelAgent that reports node runlevels
109 group: applications/system
110 requires: python
111
112 %description runlevelagent
113 The RunlevelAgent starts as early as possible during boot-up and production
114 mode to actively report the observed runlevel to PLC and update the
115 'last_contact' field.
116
117 %prep
118 %setup -q
119
120 %build
121 # NOTE: the build uses g++ cmdamt/
122 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
123 cd pcucontrol/models/intelamt
124 export TMPDIR=$PWD/tmp
125 make
126 cd ..
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 #################### CLIENT 
131 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
132 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
133 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
134
135
136 #################### SERVER
137 install -d $RPM_BUILD_ROOT/usr/share/%{name}
138 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
139 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
140 install -d $RPM_BUILD_ROOT/var/lib/%{name}
141 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
142 #install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
143 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
144 install -d $RPM_BUILD_ROOT/%{python_sitearch}/
145
146 export PYTHONPATH=$PYTHONPATH:$RPM_BUILD_ROOT/%{python_sitearch}/
147 # pack monitor's dependencies in RPM to make it easier to deploy.
148 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
149 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
150 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ Elixir
151 rm -rf $RPM_BUILD_ROOT/%{python_sitearch}/site.py*
152
153 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
154 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
155 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
156
157 install -D -m 644 monitor_version.py $RPM_BUILD_ROOT/usr/share/%{name}/
158
159 echo " * Installing core scripts"
160 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
161           ./ $RPM_BUILD_ROOT/usr/share/%{name}/
162
163 echo " * Installing web pages"
164 #rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
165 rsync -a log/ $RPM_BUILD_ROOT/var/www/html/monitorlog/
166
167 echo " * Installing cron job for automated polling"
168 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
169 echo " * TODO: Setting up Monitor account in local MyPLC"
170 # TODO: 
171
172 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
173 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
174 # TODO: need a much better way to do this.
175 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
176 #for file in __init__.py database.py config.py ; do 
177 #       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
178 #done
179 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
180 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
181
182 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
183 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
184
185 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
186 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
187
188 #################### RunlevelAgent
189 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
190 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
191
192 mkdir -p $RPM_BUILD_ROOT/var/log
193 touch $RPM_BUILD_ROOT/var/log/server-deps.log
194
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %files server-deps
200 /var/log/server-deps.log
201
202 %files server
203 %defattr(-,root,root)
204 #%config /usr/share/%{name}/monitorconfig.py
205 #%config /etc/monitor.conf
206 /usr/share/%{name}
207 /var/lib/%{name}
208 #/var/www/cgi-bin/monitor
209 %{_sysconfdir}/cron.d/monitor-server.cron
210 %{python_sitearch}/threadpool.py
211 %{python_sitearch}/threadpool.pyc
212 %{python_sitearch}/threadpool.pyo
213 %{python_sitearch}/monitor
214 %{python_sitearch}/Turbo*
215 %{python_sitearch}/SQLAlchemy*
216 %{python_sitearch}/Elixir*
217 %{python_sitearch}/easy-install.pth
218 %{python_sitearch}/tg-admin
219 %{_sysconfdir}/plc.d/monitor
220 %{_sysconfdir}/plc.d/monitor.functions
221 %{_sysconfdir}/plc.d/zabbix
222
223 %files client
224 %defattr(-,root,root)
225 #%{_initrddir}/monitor
226 #%{_sysconfdir}/cron.d/monitor
227 /usr/bin/timeout.pl
228
229 %files pcucontrol
230 %{python_sitearch}/pcucontrol
231
232 %files runlevelagent
233 /usr/bin/RunlevelAgent.py
234 /usr/bin/RunlevelAgent.pyo
235 /usr/bin/RunlevelAgent.pyc
236 /%{_initrddir}/monitor-runlevelagent
237
238 %post server-deps
239
240 # crazy openssl libs for racadm binary
241 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
242 mkdir %{_datadir}/%{name}/.ssh
243 chmod 700 %{_datadir}/%{name}/.ssh
244
245 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
246     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
247 fi
248
249 # NOTE: enable monitor by default, since we're installing it.
250 if ! plc-config --category plc_monitor --variable enabled ; then 
251         plc-config --category plc_monitor --variable enabled --value true \
252                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
253 fi
254 if ! plc-config --category plc_monitor --variable from_email ; then
255         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
256                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
257 fi
258 if ! plc-config --category plc_monitor --variable cc_email ; then
259         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
260                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
261 fi
262 if ! plc-config --category plc_monitor --variable rt_queue ; then
263         plc-config --category plc_monitor --variable rt_queue --value support \
264                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
265 fi
266
267 # zabbix:
268 if ! plc-config --category plc_zabbix --variable enabled ; then
269         plc-config --category plc_zabbix --variable enabled --value false \
270                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
271 fi
272 if ! plc-config --category plc_zabbix --variable host ; then
273         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
274                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
275 fi
276 if ! plc-config --category plc_zabbix --variable ip ; then
277         plc-config --category plc_zabbix --variable ip --value "" \ 
278                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
279 fi
280
281 %post server
282 # TODO: this will be nice when we have a web-based service running., such as
283 #               an API server or so on.
284 # TODO: create real monitorconfig.py from monitorconfig-default.py
285 # TODO: create symlink in /var/lib/monitor for chroot environments
286 # TODO: update the content of automate_pl03.sh 
287 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
288
289 # NOTE: generate the python defines from zabbix include files.
290 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
291
292 # apply patches to zabbix
293 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
294
295 #chkconfig --add monitor-server
296 #chkconfig monitor-server on
297
298 %post client
299 chkconfig --add monitor
300 chkconfig monitor on
301
302 %post runlevelagent
303 chkconfig --add monitor-runlevelagent
304 chkconfig monitor-runlevelagent on
305 if [ "$PL_BOOTCD" != "1" ] ; then
306         service monitor-runlevelagent restart
307 fi
308
309
310 %changelog
311 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
312 - add option for site status to include both node & pcu status
313 - improve ticket handling
314 - template gadget.xml for a site-specific google-gadget summary
315
316 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
317 - - add install_date
318
319 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
320 - - remove monitor-client.cron
321 - - remove unused monitor-client init script
322 - - fix UP/DOWN summary on nodes page.
323 - - make node page display all nodes by default
324 - - add boot_server field
325 - - add myops_ssh_key to the keychain
326 - - use ext_consortium_id to distinguish pending sites.
327
328 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
329 - show/hide advance query form.
330
331 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
332 - fixed pause_penalty bug.
333 - fixed IPAL pcucontrol bug
334 - fixed bootman tunnel setup bug (occurred in rare cases)
335 - deprecated pcuview
336 - added BootmanSequenceRecords to separate config data from source code
337 - added get/setBootmanSequence(s) to xmlrpc API
338
339 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
340 - Major Features:
341 - added bm log collection and optional integration with BootManager's log Upload()
342 - added iptables_status
343 - expanded advanced query
344 - added differentiated bootmanager_restore actions so that actionsummary displays
345 - counts for each kind of bootmanager action
346 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
347 - added plain-text options for query page by adding tg_format=plain to URL
348 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
349 - fixed a bug in determining whether comon's dir was running on a node
350
351 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
352 - Major increment -
353 - adds multiple features and web changes
354 - adds new fields to db
355 - improved layout
356 - general improvements otherwise
357
358 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
359 - bug fixes.
360 - improved templates and views
361 - cleaned controller code for web
362 - added IPMI requirement to pcucontrol package.
363
364 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
365 - added bootmanager log links
366 - addressed root cause of IntegrityErrors ; big deal
367 - adjusted templates to accomodate fix for IntegrityErrors
368 - added session.flush() to bootman.py to write out ActionsRecords
369 - fixed policy to either pause penalties or apply them ; not both.
370
371 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
372 -- Added Rpyc from 1.0 branch.
373 -- add pcuhistory
374 -- add setup-agent for password protected keys.
375 -- other minor improvements.
376
377 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
378 - automate install
379 - auto-close tickets
380
381 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
382 - update web
383 - update policy
384 - added statistics dir
385
386 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
387 - remove plccache from controllers, all lookups from db.
388 - reformat emailTxt messags
389 - updated bootstates in bootman.py
390
391 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
392 - tag of latest changes.
393 - need to test end to end.
394
395 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
396 - big merge from the 2.0 branch
397
398 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
399 - minor improvements in rendering with sortable tables
400
401 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
402
403 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
404 - first draft with sortable tables + checkpoint
405
406 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
407 - use plekit tables from plewww.
408 - depend on plewww-plekit
409
410 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
411 - make docs a noop
412 - fix for package name dependency
413 - correct docs
414
415 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
416 - add improved docs to the latest build and tag.
417
418 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
419 - add documentation hooks for adding in-line docs like NM and PLCAPI
420
421 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
422 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
423 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
424 - 'safeboot', 'failboot', 'reinstall', etc.
425
426 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
427 - same as 2.0-12 tag.
428
429 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
430 - merge from 2.0, remove more zabbix code, simplify install, etc.
431
432 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
433 - major merge from 2.0 branch.
434 - ready to be updated with 4.3 and web changes.
435
436 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
437 - preparing to make a 2.0 branch for monitor.
438
439 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
440 - new changes are significantly different, that I'm upping the number for clarity.
441
442 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
443 - These are all changes in the latest Monitor code.  I will branch this version
444 - next, before making additional large changes.
445
446 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
447 - Checkpointing current version for 4.2-rc21 - many many changes
448
449 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
450 - This is a major tag of every thing.  probably needs a very different release
451 - number.
452
453 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
454 - Incremental improvements
455
456 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
457 - tagging everything for OneLab tech-transfer.
458
459
460 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
461
462
463 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
464
465
466 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
467 - This should be ready for 4.2rc2
468
469
470 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
471 - initial addition.
472
473 %define module_current_branch 2.0