typo
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.0
10 %define Taglevel 25
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 Summary: Monitor account initialization for the root image.
29 Group: Applications/System
30
31 %description
32 Monitor is a collection of secondary scripts for configuring the node polling
33 system, syncing the PLC db with the monitoring database, notifying users,
34 interacting with PCU hardware, applying penalties to sites that violate
35 acceptable use.
36
37 ######################################## CLIENT
38
39 %package client
40 Summary: Monitor hooks for a PLC node
41 Group: Applications/System
42 Requires: curl
43 Requires: coreutils
44
45 %description client
46 The client scripts handle account creation inside of a node.  This will
47 include configuration setup for the monitoring agent running on the node.  It
48 will also include any cron or init scripts needed to perform this kind of
49 maintenance.
50 ######################################## Server Deps
51 %package server-deps
52 Summary: Monitor hooks for the PLC server.
53 Group: Applications/System
54
55 Requires: python
56 Requires: python-setuptools-devel
57 Requires: python-peak-util-extremes
58
59 Requires: compat-libstdc++-296
60 Requires: openssh-clients
61 Requires: perl-libwww-perl
62 Requires: perl-IO-Socket-SSL 
63 Requires: MySQL-python
64 Requires: nmap
65 Requires: nc
66 Requires: rt3
67
68 Requires: plewww-plekit
69
70 #Requires: zabbix-client
71 #Requires: zabbix-gui
72 #Requires: zabbix-server
73
74 %description server-deps
75 The server side include all python modules and scripts needed to fully
76
77 ######################################## Server
78 %package server
79 Summary: Monitor hooks for the PLC server.
80 Group: Applications/System
81
82 Requires: python
83
84 Requires: monitor-server-deps
85 Requires: monitor-pcucontrol
86 Requires: PLCWWW >= 4.2
87 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
88
89 %description server
90 The server side include all python modules and scripts needed to fully
91 operation, track, and interact with any third-party monitoring software, such
92 as Zabbix DB.
93
94 ######################################## PCU Control
95
96 %package pcucontrol
97 summary: pcu controls for monitor and plcapi
98 group: applications/system
99 requires: python
100 requires: OpenIPMI-tools
101
102 %description pcucontrol
103 both monitor and the plcapi use a set of common commands to reboot machines
104 using their external or internal pcus.  this package is a library of several
105 supported models.
106
107 ####################################### RunlevelAgent
108 %package runlevelagent
109 summary: the RunlevelAgent that reports node runlevels
110 group: applications/system
111 requires: python
112
113 %description runlevelagent
114 The RunlevelAgent starts as early as possible during boot-up and production
115 mode to actively report the observed runlevel to PLC and update the
116 'last_contact' field.
117
118 %prep
119 %setup -q
120
121 %build
122 # NOTE: the build uses g++ cmdamt/
123 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
124 cd pcucontrol/models/intelamt
125 export TMPDIR=$PWD/tmp
126 make
127 cd ..
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 #################### CLIENT 
132 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
133 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
134 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
135
136
137 #################### SERVER
138 install -d $RPM_BUILD_ROOT/usr/share/%{name}
139 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
140 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
141 install -d $RPM_BUILD_ROOT/var/lib/%{name}
142 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
143 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
144 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
145
146 # pack monitor's dependencies in RPM to make it easier to deploy.
147 export PYTHONPATH=$PYTHONPATH:$RPM_BUILD_ROOT/%{python_sitearch}/
148 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
149 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
150 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ Elixir
151 rm -rf $RPM_BUILD_ROOT/%{python_sitearch}/site.py*
152
153 # plc.d scripts
154 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
155 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
156 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
157
158 # cron job for automated polling
159 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
160
161 # apache configuration
162 install -D -m 644 web/monitorweb-httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
163
164 # install everything to /usr/share/monitor
165 rsync -a --exclude archive-pdb --exclude .svn --exclude CVS  ./  $RPM_BUILD_ROOT/usr/share/%{name}/
166
167 # link site-packages/monitor to /usr/share/monitor/monitor
168 ln -s $RPM_BUILD_ROOT/usr/share/%{name}/%{name} $RPM_BUILD_ROOT/%{python_sitearch}/%{name}/
169
170 # and site-packages/pcucontrol to /usr/share/monitor/pcucontrol
171 ln -s $RPM_BUILD_ROOT/%{name}/pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
172
173 # install third-party module to site-packages
174 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
175
176 # TODO: 
177 echo " * TODO: Setting up Monitor account in local MyPLC"
178
179 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
180 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
181
182 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
183 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
184
185 #################### RunlevelAgent
186 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
187 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
188
189 mkdir -p $RPM_BUILD_ROOT/var/log
190 touch $RPM_BUILD_ROOT/var/log/server-deps.log
191
192
193 %clean
194 rm -rf $RPM_BUILD_ROOT
195
196 %files server-deps
197 /var/log/server-deps.log
198
199 %files server
200 %defattr(-,root,root)
201 #%config /usr/share/%{name}/monitorconfig.py
202 #%config /etc/monitor.conf
203 /usr/share/%{name}
204 /var/lib/%{name}
205 #/var/www/cgi-bin/monitor
206 %{_sysconfdir}/cron.d/monitor-server.cron
207 %{python_sitearch}/threadpool.py
208 %{python_sitearch}/threadpool.pyc
209 %{python_sitearch}/threadpool.pyo
210 %{python_sitearch}/monitor
211 %{python_sitearch}/Turbo*
212 %{python_sitearch}/SQLAlchemy*
213 %{python_sitearch}/Elixir*
214 %{python_sitearch}/easy-install.pth
215 %{python_sitearch}/tg-admin
216 %{_sysconfdir}/plc.d/monitor
217 %{_sysconfdir}/plc.d/monitor.functions
218 %{_sysconfdir}/plc.d/zabbix
219
220 %files client
221 %defattr(-,root,root)
222 #%{_initrddir}/monitor
223 #%{_sysconfdir}/cron.d/monitor
224 /usr/bin/timeout.pl
225
226 %files pcucontrol
227 %{python_sitearch}/pcucontrol
228
229 %files runlevelagent
230 /usr/bin/RunlevelAgent.py
231 /usr/bin/RunlevelAgent.pyo
232 /usr/bin/RunlevelAgent.pyc
233 /%{_initrddir}/monitor-runlevelagent
234
235 %post server-deps
236
237 # crazy openssl libs for racadm binary
238 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
239 mkdir %{_datadir}/%{name}/.ssh
240 chmod 700 %{_datadir}/%{name}/.ssh
241
242 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
243     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
244 fi
245
246 # NOTE: enable monitor by default, since we're installing it.
247 if ! plc-config --category plc_monitor --variable enabled ; then 
248         plc-config --category plc_monitor --variable enabled --value true \
249                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
250 fi
251 if ! plc-config --category plc_monitor --variable from_email ; then
252         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
253                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
254 fi
255 if ! plc-config --category plc_monitor --variable cc_email ; then
256         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
257                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
258 fi
259 if ! plc-config --category plc_monitor --variable rt_queue ; then
260         plc-config --category plc_monitor --variable rt_queue --value support \
261                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
262 fi
263
264 # zabbix:
265 if ! plc-config --category plc_zabbix --variable enabled ; then
266         plc-config --category plc_zabbix --variable enabled --value false \
267                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
268 fi
269 if ! plc-config --category plc_zabbix --variable host ; then
270         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
271                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
272 fi
273 if ! plc-config --category plc_zabbix --variable ip ; then
274         plc-config --category plc_zabbix --variable ip --value "" \ 
275                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
276 fi
277
278 %post server
279 # TODO: this will be nice when we have a web-based service running., such as
280 #               an API server or so on.
281 # TODO: create real monitorconfig.py from monitorconfig-default.py
282 # TODO: create symlink in /var/lib/monitor for chroot environments
283 # TODO: update the content of automate_pl03.sh 
284 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
285
286 # NOTE: generate the python defines from zabbix include files.
287 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
288
289 # apply patches to zabbix
290 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
291
292 #chkconfig --add monitor-server
293 #chkconfig monitor-server on
294
295 %post client
296 chkconfig --add monitor
297 chkconfig monitor on
298
299 %post runlevelagent
300 chkconfig --add monitor-runlevelagent
301 chkconfig monitor-runlevelagent on
302 if [ "$PL_BOOTCD" != "1" ] ; then
303         service monitor-runlevelagent restart
304 fi
305
306
307 %changelog
308 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
309 - add option for site status to include both node & pcu status
310 - improve ticket handling
311 - template gadget.xml for a site-specific google-gadget summary
312
313 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
314 - - add install_date
315
316 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
317 - - remove monitor-client.cron
318 - - remove unused monitor-client init script
319 - - fix UP/DOWN summary on nodes page.
320 - - make node page display all nodes by default
321 - - add boot_server field
322 - - add myops_ssh_key to the keychain
323 - - use ext_consortium_id to distinguish pending sites.
324
325 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
326 - show/hide advance query form.
327
328 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
329 - fixed pause_penalty bug.
330 - fixed IPAL pcucontrol bug
331 - fixed bootman tunnel setup bug (occurred in rare cases)
332 - deprecated pcuview
333 - added BootmanSequenceRecords to separate config data from source code
334 - added get/setBootmanSequence(s) to xmlrpc API
335
336 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
337 - Major Features:
338 - added bm log collection and optional integration with BootManager's log Upload()
339 - added iptables_status
340 - expanded advanced query
341 - added differentiated bootmanager_restore actions so that actionsummary displays
342 - counts for each kind of bootmanager action
343 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
344 - added plain-text options for query page by adding tg_format=plain to URL
345 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
346 - fixed a bug in determining whether comon's dir was running on a node
347
348 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
349 - Major increment -
350 - adds multiple features and web changes
351 - adds new fields to db
352 - improved layout
353 - general improvements otherwise
354
355 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
356 - bug fixes.
357 - improved templates and views
358 - cleaned controller code for web
359 - added IPMI requirement to pcucontrol package.
360
361 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
362 - added bootmanager log links
363 - addressed root cause of IntegrityErrors ; big deal
364 - adjusted templates to accomodate fix for IntegrityErrors
365 - added session.flush() to bootman.py to write out ActionsRecords
366 - fixed policy to either pause penalties or apply them ; not both.
367
368 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
369 -- Added Rpyc from 1.0 branch.
370 -- add pcuhistory
371 -- add setup-agent for password protected keys.
372 -- other minor improvements.
373
374 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
375 - automate install
376 - auto-close tickets
377
378 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
379 - update web
380 - update policy
381 - added statistics dir
382
383 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
384 - remove plccache from controllers, all lookups from db.
385 - reformat emailTxt messags
386 - updated bootstates in bootman.py
387
388 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
389 - tag of latest changes.
390 - need to test end to end.
391
392 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
393 - big merge from the 2.0 branch
394
395 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
396 - minor improvements in rendering with sortable tables
397
398 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
399
400 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
401 - first draft with sortable tables + checkpoint
402
403 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
404 - use plekit tables from plewww.
405 - depend on plewww-plekit
406
407 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
408 - make docs a noop
409 - fix for package name dependency
410 - correct docs
411
412 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
413 - add improved docs to the latest build and tag.
414
415 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
416 - add documentation hooks for adding in-line docs like NM and PLCAPI
417
418 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
419 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
420 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
421 - 'safeboot', 'failboot', 'reinstall', etc.
422
423 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
424 - same as 2.0-12 tag.
425
426 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
427 - merge from 2.0, remove more zabbix code, simplify install, etc.
428
429 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
430 - major merge from 2.0 branch.
431 - ready to be updated with 4.3 and web changes.
432
433 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
434 - preparing to make a 2.0 branch for monitor.
435
436 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
437 - new changes are significantly different, that I'm upping the number for clarity.
438
439 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
440 - These are all changes in the latest Monitor code.  I will branch this version
441 - next, before making additional large changes.
442
443 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
444 - Checkpointing current version for 4.2-rc21 - many many changes
445
446 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
447 - This is a major tag of every thing.  probably needs a very different release
448 - number.
449
450 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
451 - Incremental improvements
452
453 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
454 - tagging everything for OneLab tech-transfer.
455
456
457 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
458
459
460 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
461
462
463 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
464 - This should be ready for 4.2rc2
465
466
467 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
468 - initial addition.
469
470 %define module_current_branch 2.0