9cbca1d6727ba06804cc5facd8b8265a05d8a130
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.0
10 %define taglevel 26
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 BuildRequires: python-setuptools-devel
29
30
31 Summary: Monitor account initialization for the root image.
32 Group: Applications/System
33
34 %description
35 Monitor is a collection of secondary scripts for configuring the node polling
36 system, syncing the PLC db with the monitoring database, notifying users,
37 interacting with PCU hardware, applying penalties to sites that violate
38 acceptable use.
39
40 ######################################## CLIENT
41
42 %package client
43 Summary: Monitor hooks for a PLC node
44 Group: Applications/System
45 Requires: curl
46 Requires: coreutils
47
48 %description client
49 The client scripts handle account creation inside of a node.  This will
50 include configuration setup for the monitoring agent running on the node.  It
51 will also include any cron or init scripts needed to perform this kind of
52 maintenance.
53 ######################################## Server Deps
54 %package server-deps
55 Summary: Monitor hooks for the PLC server.
56 Group: Applications/System
57
58 Requires: python
59 Requires: python-peak-util-extremes
60
61 Requires: compat-libstdc++-296
62 Requires: openssh-clients
63 Requires: perl-libwww-perl
64 Requires: perl-IO-Socket-SSL 
65 Requires: MySQL-python
66 Requires: nmap
67 Requires: nc
68 Requires: rt3
69
70 Requires: plewww-plekit
71
72 #Requires: zabbix-client
73 #Requires: zabbix-gui
74 #Requires: zabbix-server
75
76 %description server-deps
77 The server side include all python modules and scripts needed to fully
78
79 ######################################## Server
80 %package server
81 Summary: Monitor hooks for the PLC server.
82 Group: Applications/System
83
84 Requires: python
85
86 Requires: monitor-server-deps
87 Requires: monitor-pcucontrol
88 Requires: PLCWWW >= 4.2
89 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
90
91 %description server
92 The server side include all python modules and scripts needed to fully
93 operation, track, and interact with any third-party monitoring software, such
94 as Zabbix DB.
95
96 ######################################## PCU Control
97
98 %package pcucontrol
99 summary: pcu controls for monitor and plcapi
100 group: applications/system
101 requires: python
102 requires: OpenIPMI-tools
103
104 %description pcucontrol
105 both monitor and the plcapi use a set of common commands to reboot machines
106 using their external or internal pcus.  this package is a library of several
107 supported models.
108
109 ####################################### RunlevelAgent
110 %package runlevelagent
111 summary: the RunlevelAgent that reports node runlevels
112 group: applications/system
113 requires: python
114
115 %description runlevelagent
116 The RunlevelAgent starts as early as possible during boot-up and production
117 mode to actively report the observed runlevel to PLC and update the
118 'last_contact' field.
119
120 %prep
121 %setup -q
122
123 %build
124 # NOTE: the build uses g++ cmdamt/
125 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
126 cd pcucontrol/models/intelamt
127 export TMPDIR=$PWD/tmp
128 make
129 cd ..
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 #################### CLIENT 
134 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
135 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
136 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
137
138
139 #################### SERVER
140 install -d $RPM_BUILD_ROOT/usr/share/%{name}
141 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
142 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
143 install -d $RPM_BUILD_ROOT/var/lib/%{name}
144 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
145 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
146 install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
147 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
148
149 # pack monitor's dependencies in RPM to make it easier to deploy.
150 export PYTHONPATH=$PYTHONPATH:$RPM_BUILD_ROOT/%{python_sitearch}/
151 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
152 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
153 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ Elixir
154 rm -rf $RPM_BUILD_ROOT/%{python_sitearch}/site.py*
155
156 # plc.d scripts
157 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
158 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
159 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
160
161 # cron job for automated polling
162 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
163
164 # apache configuration
165 install -D -m 644 web/monitorweb-httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
166
167 # we'll install monitor and pcucontrol in site-packages
168 # install rest to /usr/share/monitor
169 rsync -a --exclude archive-pdb --exclude .svn --exclude CVS  \
170     --exclude monitor/ \
171     --exclude pcucontol/ \
172     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
173
174 # install monitor python package
175 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
176
177 # and pcucontrol
178 rsync -a --exclude .svn  ./pcucontrol/    $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
179
180 # install third-party module to site-packages
181 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
182
183 # TODO: 
184 echo " * TODO: Setting up Monitor account in local MyPLC"
185
186 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
187 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
188
189 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
190 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
191
192 #################### RunlevelAgent
193 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
194 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
195
196 mkdir -p $RPM_BUILD_ROOT/var/log
197 touch $RPM_BUILD_ROOT/var/log/server-deps.log
198
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %files server-deps
204 /var/log/server-deps.log
205
206 %files server
207 %defattr(-,root,root)
208 #%config /usr/share/%{name}/monitorconfig.py
209 #%config /etc/monitor.conf
210 /usr/share/%{name}
211 /var/lib/%{name}
212 #/var/www/cgi-bin/monitor
213 %{_sysconfdir}/cron.d/monitor-server.cron
214 %{python_sitearch}/threadpool.py*
215 %{python_sitearch}/monitor
216 %{python_sitearch}/*.egg/
217 %{python_sitearch}/easy-install.pth
218 %{python_sitearch}/tg-admin
219 %{_sysconfdir}/plc.d/monitor
220 %{_sysconfdir}/plc.d/monitor.functions
221 %{_sysconfdir}/plc.d/zabbix
222 %{_sysconfdir}/httpd/conf.d
223
224 %files client
225 %defattr(-,root,root)
226 #%{_initrddir}/monitor
227 #%{_sysconfdir}/cron.d/monitor
228 /usr/bin/timeout.pl
229
230 %files pcucontrol
231 %{python_sitearch}/pcucontrol
232
233 %files runlevelagent
234 /usr/bin/RunlevelAgent.py
235 /usr/bin/RunlevelAgent.pyo
236 /usr/bin/RunlevelAgent.pyc
237 /%{_initrddir}/monitor-runlevelagent
238
239 %post server-deps
240
241 # crazy openssl libs for racadm binary
242 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
243 mkdir %{_datadir}/%{name}/.ssh
244 chmod 700 %{_datadir}/%{name}/.ssh
245
246 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
247     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
248 fi
249
250 # NOTE: enable monitor by default, since we're installing it.
251 if ! plc-config --category plc_monitor --variable enabled ; then 
252         plc-config --category plc_monitor --variable enabled --value true \
253                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
254 fi
255 if ! plc-config --category plc_monitor --variable from_email ; then
256         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
257                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
258 fi
259 if ! plc-config --category plc_monitor --variable cc_email ; then
260         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
261                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
262 fi
263 if ! plc-config --category plc_monitor --variable rt_queue ; then
264         plc-config --category plc_monitor --variable rt_queue --value support \
265                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
266 fi
267
268 # zabbix:
269 if ! plc-config --category plc_zabbix --variable enabled ; then
270         plc-config --category plc_zabbix --variable enabled --value false \
271                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
272 fi
273 if ! plc-config --category plc_zabbix --variable host ; then
274         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
275                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
276 fi
277 if ! plc-config --category plc_zabbix --variable ip ; then
278         plc-config --category plc_zabbix --variable ip --value "" \ 
279                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
280 fi
281
282 %post server
283 # TODO: this will be nice when we have a web-based service running., such as
284 #               an API server or so on.
285 # TODO: create real monitorconfig.py from monitorconfig-default.py
286 # TODO: create symlink in /var/lib/monitor for chroot environments
287 # TODO: update the content of automate_pl03.sh 
288 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
289
290 # NOTE: generate the python defines from zabbix include files.
291 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
292
293 # apply patches to zabbix
294 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
295
296 #chkconfig --add monitor-server
297 #chkconfig monitor-server on
298
299 %post client
300 chkconfig --add monitor
301 chkconfig monitor on
302
303 %post runlevelagent
304 chkconfig --add monitor-runlevelagent
305 chkconfig monitor-runlevelagent on
306 if [ "$PL_BOOTCD" != "1" ] ; then
307         service monitor-runlevelagent restart
308 fi
309
310
311 %changelog
312 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
313 - to many changes, but mostly moved stuff around. there are some small fixes here and there.
314
315 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
316 - add option for site status to include both node & pcu status
317 - improve ticket handling
318 - template gadget.xml for a site-specific google-gadget summary
319
320 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
321 - - add install_date
322
323 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
324 - - remove monitor-client.cron
325 - - remove unused monitor-client init script
326 - - fix UP/DOWN summary on nodes page.
327 - - make node page display all nodes by default
328 - - add boot_server field
329 - - add myops_ssh_key to the keychain
330 - - use ext_consortium_id to distinguish pending sites.
331
332 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
333 - show/hide advance query form.
334
335 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
336 - fixed pause_penalty bug.
337 - fixed IPAL pcucontrol bug
338 - fixed bootman tunnel setup bug (occurred in rare cases)
339 - deprecated pcuview
340 - added BootmanSequenceRecords to separate config data from source code
341 - added get/setBootmanSequence(s) to xmlrpc API
342
343 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
344 - Major Features:
345 - added bm log collection and optional integration with BootManager's log Upload()
346 - added iptables_status
347 - expanded advanced query
348 - added differentiated bootmanager_restore actions so that actionsummary displays
349 - counts for each kind of bootmanager action
350 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
351 - added plain-text options for query page by adding tg_format=plain to URL
352 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
353 - fixed a bug in determining whether comon's dir was running on a node
354
355 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
356 - Major increment -
357 - adds multiple features and web changes
358 - adds new fields to db
359 - improved layout
360 - general improvements otherwise
361
362 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
363 - bug fixes.
364 - improved templates and views
365 - cleaned controller code for web
366 - added IPMI requirement to pcucontrol package.
367
368 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
369 - added bootmanager log links
370 - addressed root cause of IntegrityErrors ; big deal
371 - adjusted templates to accomodate fix for IntegrityErrors
372 - added session.flush() to bootman.py to write out ActionsRecords
373 - fixed policy to either pause penalties or apply them ; not both.
374
375 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
376 -- Added Rpyc from 1.0 branch.
377 -- add pcuhistory
378 -- add setup-agent for password protected keys.
379 -- other minor improvements.
380
381 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
382 - automate install
383 - auto-close tickets
384
385 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
386 - update web
387 - update policy
388 - added statistics dir
389
390 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
391 - remove plccache from controllers, all lookups from db.
392 - reformat emailTxt messags
393 - updated bootstates in bootman.py
394
395 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
396 - tag of latest changes.
397 - need to test end to end.
398
399 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
400 - big merge from the 2.0 branch
401
402 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
403 - minor improvements in rendering with sortable tables
404
405 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
406
407 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
408 - first draft with sortable tables + checkpoint
409
410 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
411 - use plekit tables from plewww.
412 - depend on plewww-plekit
413
414 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
415 - make docs a noop
416 - fix for package name dependency
417 - correct docs
418
419 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
420 - add improved docs to the latest build and tag.
421
422 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
423 - add documentation hooks for adding in-line docs like NM and PLCAPI
424
425 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
426 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
427 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
428 - 'safeboot', 'failboot', 'reinstall', etc.
429
430 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
431 - same as 2.0-12 tag.
432
433 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
434 - merge from 2.0, remove more zabbix code, simplify install, etc.
435
436 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
437 - major merge from 2.0 branch.
438 - ready to be updated with 4.3 and web changes.
439
440 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
441 - preparing to make a 2.0 branch for monitor.
442
443 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
444 - new changes are significantly different, that I'm upping the number for clarity.
445
446 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
447 - These are all changes in the latest Monitor code.  I will branch this version
448 - next, before making additional large changes.
449
450 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
451 - Checkpointing current version for 4.2-rc21 - many many changes
452
453 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
454 - This is a major tag of every thing.  probably needs a very different release
455 - number.
456
457 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
458 - Incremental improvements
459
460 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
461 - tagging everything for OneLab tech-transfer.
462
463
464 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
465
466
467 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
468
469
470 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
471 - This should be ready for 4.2rc2
472
473
474 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
475 - initial addition.
476
477 %define module_current_branch 2.0